]> git.pld-linux.org Git - packages/curl.git/blame - curl.spec
- up to 7.32.0
[packages/curl.git] / curl.spec
CommitLineData
195ea5a8
JB
1#
2# Conditional build:
120855f9
JB
3%bcond_without ssh # without SSH support
4%bcond_without ssl # without SSL support
f73c4120 5%bcond_without kerberos5 # without Heimdal Kerberos 5 support
588be88f 6%bcond_without ldap # without LDAP support
de17b215
ER
7%if "%{pld_release}" != "ac"
8%bcond_without ares # with c-ares (asynchronous DNS operations) library
2a41c99b 9%bcond_with gnutls # use GnuTLS instead of OpenSSL
de17b215
ER
10%bcond_without rtmp # without Real Time Media Protocol
11%else
12%bcond_with ares # with c-ares (asynchronous DNS operations) library
13%bcond_with gnutls # use GnuTLS instead of OpenSSL
14%bcond_with rtmp # without Real Time Media Protocol
15%endif
16
f7f276d9 17Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
ce380d80
ER
18Summary(es.UTF-8): Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
19Summary(pl.UTF-8): Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
20Summary(pt_BR.UTF-8): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
21Summary(ru.UTF-8): Утилита для получения файлов с серверов FTP, HTTP и других
22Summary(uk.UTF-8): Утиліта для отримання файлів з серверів FTP, HTTP та інших
5767e1a7 23Name: curl
af8aec68 24Version: 7.32.0
d0cec3a8 25Release: 1
c091c0ac 26License: MIT-like
5767e1a7 27Group: Applications/Networking
0307878f 28Source0: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
af8aec68 29# Source0-md5: db5948f44e7ef3edbf9a7907af9556ac
d0cec3a8
JB
30Patch0: %{name}-ac.patch
31Patch1: %{name}-krb5flags.patch
4557544f 32URL: http://curl.haxx.se/
c091c0ac 33BuildRequires: autoconf >= 2.57
66cf63f1 34BuildRequires: automake
7c7ffb45 35%{?with_ares:BuildRequires: c-ares-devel >= 1.7.0}
f73c4120 36%{?with_kerberos5:BuildRequires: heimdal-devel}
5d94786d 37BuildRequires: libidn-devel >= 0.4.1
9defadab 38%{?with_rtmp:BuildRequires: librtmp-devel}
b83a223e 39%{?with_ssh:BuildRequires: libssh2-devel >= 1.2.8}
c091c0ac 40BuildRequires: libtool
0f90f9c0 41BuildRequires: nettle-devel
588be88f 42%{?with_ldap:BuildRequires: openldap-devel}
c260acfc 43BuildRequires: pkgconfig
de17b215
ER
44BuildRequires: rpm >= 4.4.9-56
45BuildRequires: rpmbuild(macros) >= 1.453
5559a124
AM
46%if %{with ssl}
47%if %{with gnutls}
48BuildRequires: gnutls-devel
49%else
50BuildRequires: openssl-devel >= 0.9.7d
51%endif
52%endif
d04a5e91 53BuildRequires: tar >= 1:1.22
6903f0dc 54BuildRequires: zlib-devel
3fb47407 55Requires: %{name}-libs = %{version}-%{release}
5d94786d 56Requires: libidn >= 0.4.1
b83a223e 57%{?with_ssh:Requires: libssh2 >= 1.2.8}
cfa95fc0 58Obsoletes: libcurl2
8aa4e5ec 59BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81714278 60
61%description
655b91ad 62cURL is a tool for getting files with URL syntax, supporting FTP,
63HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
64POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
65cookies, user+password authentication and a busload of other useful
66tricks. The main use for curl is when you want to get or send files
67automatically to or from a site using one of the supported protocols.
68
69cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
70Dict servers, using any of the supported protocols. cURL is designed
71to work without user interaction or any kind of interactivity. cURL
72offers many useful capabilities, like proxy support, user
e566d906 73authentication, FTP upload, HTTP post, and file transfer resume.
81714278 74
d63bcf1b
JR
75%description -l pl.UTF-8
76cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
77HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
78HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
655b91ad 79oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
d63bcf1b
JR
80użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
81się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
82pliki z/na serwer używając jednego z dostępnych protokołów.
83%{?with_ssl:Ten pakiet obsługuje także SSL.}
1310544e 84
d63bcf1b
JR
85%description -l pt_BR.UTF-8
86Curl é um cliente para baixar/enviar arquivos de/para servidores
87usando um dos protocolos suportados. É projetado para funcionar sem a
88interação do usuário.
1310544e 89
d63bcf1b
JR
90Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
91continuar transferências interrompidas, e mais...
1310544e 92
d63bcf1b
JR
93%description -l ru.UTF-8
94curl - это клиент с множеством поддерживаемых протоколов для получения
95файлов с серверов, спроектированный для работы как в неинтерактивном
96режиме, так и с возможностью диалога с пользователем.
f05b825f 97
d63bcf1b
JR
98curl поддерживает много полезных возможностей, среди которых поддержка
99прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
100POST, восстановление прерванной пересылки и многое другое.
f05b825f 101
d63bcf1b
JR
102curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
103файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
104режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
f05b825f 105
d63bcf1b
JR
106curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
107прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
108в╕дновлення перервано╖ пересилки та багато ╕ншого.
f05b825f 109
814b6f7d
JB
110%package libs
111Summary: curl library
ce380d80 112Summary(pl.UTF-8): Biblioteka curl
814b6f7d 113Group: Libraries
de17b215 114%{?with_ares:Requires: c-ares >= 1.7.0}
dfeb0d8d
PG
115Suggests: ca-certificates
116Conflicts: ca-certificates < 20080809-4
814b6f7d
JB
117
118%description libs
119curl library.
120
d63bcf1b 121%description libs -l pl.UTF-8
814b6f7d
JB
122Biblioteka curl.
123
1f54b511 124%package devel
125Summary: Header files and development documentation for curl library
ce380d80
ER
126Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do biblioteki curl
127Summary(pt_BR.UTF-8): Arquivos de cabeçalho e bibliotecas de desenvolvimento
128Summary(ru.UTF-8): Файлы для разработки с использованием библиотеки curl
129Summary(uk.UTF-8): Файли для розробки з використанням бібліотеки curl
1f54b511 130Group: Development/Libraries
3fb47407 131Requires: %{name}-libs = %{version}-%{release}
bd2c841c 132%{?with_ares:Requires: c-ares-devel}
f73c4120 133%{?with_kerberos5:Requires: heimdal-devel}
5d94786d 134Requires: libidn-devel >= 0.4.1
70778617 135%{?with_rtmp:Requires: librtmp-devel}
b83a223e 136%{?with_ssh:Requires: libssh2-devel >= 1.2.8}
588be88f 137%{?with_ldap:Requires: openldap-devel}
5559a124
AM
138%if %{with ssl}
139%if %{with gnutls}
140Requires: gnutls-devel
141%else
142Requires: openssl-devel >= 0.9.7c
143%endif
144%endif
5e1699d5 145Requires: zlib-devel
cfa95fc0 146Obsoletes: libcurl2-devel
1f54b511 147
148%description devel
149Header files and development documentation for curl library.
150
d63bcf1b
JR
151%description devel -l pl.UTF-8
152Pliki nagłówkowe i dokumentacja do biblioteki curl.
cec38cdf 153
d63bcf1b
JR
154%description devel -l pt_BR.UTF-8
155Arquivos de cabeçalho e bibliotecas de desenvolvimento.
1310544e 156
d63bcf1b
JR
157%description devel -l ru.UTF-8
158Этот пакет содержит файлы, необходимые для разработки программ с
159использованием библиотеки curl.
f05b825f 160
d63bcf1b
JR
161%description devel -l uk.UTF-8
162Цей пакет містить файли, необхідні для розробки програм з
163використанням бібліотеки curl.
f05b825f 164
1f54b511 165%package static
166Summary: Static version of curl library
ce380d80
ER
167Summary(pl.UTF-8): Statyczna wersja biblioteki curl
168Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento com o curl
169Summary(ru.UTF-8): Статические библиотеки для разработки с использованием библиотеки curl
170Summary(uk.UTF-8): Статичні бібліотеки для розробки з використанням бібліотеки curl
1f54b511 171Group: Development/Libraries
6e6a5186 172Requires: %{name}-devel = %{version}-%{release}
1f54b511 173
174%description static
d06d2fe1 175Static version of curl library.
1f54b511 176
d63bcf1b 177%description static -l pl.UTF-8
cec38cdf 178Statyczna wersja biblioteki curl.
b73e2a73 179
d63bcf1b
JR
180%description static -l pt_BR.UTF-8
181Bibliotecas estáticas para desenvolvimento com o curl.
1310544e 182
d63bcf1b
JR
183%description static -l ru.UTF-8
184Этот пакет содержит статическую библиотеку для разработки программ с
185использованием библиотеки curl.
f05b825f 186
d63bcf1b
JR
187%description static -l uk.UTF-8
188Цей пакет містить статичну бібліотеку для розробки програм з
189використанням бібліотеки curl.
f05b825f 190
81714278 191%prep
13caa23a 192%setup -q
d0cec3a8 193%patch0 -p1
d4dc980e 194%patch1 -p1
81714278 195
36cd7270
ER
196%{__rm} -v m4/lt*.m4 m4/libtool.m4
197
81714278 198%build
c091c0ac 199%{__libtoolize}
03613829 200%{__aclocal} -I m4
d4dc980e
AM
201%{__autoconf}
202%{__autoheader}
c091c0ac 203%{__automake}
e566d906 204%configure \
ef822e11 205 ac_cv_header_gss_h=no \
5559a124 206%if %{with ssl}
03613829 207 --with-ca-bundle=/etc/certs/ca-certificates.crt \
5559a124 208%if %{with gnutls}
28c87603 209 --with-gnutls --without-ssl \
5559a124
AM
210%else
211 --with-ssl=%{_prefix} \
212%endif
213%endif
7d46ac1d 214 %{?with_kerberos5:--with-gssapi=%{_prefix}} \
28c87603
JB
215 %{?with_rtmp:--with-librtmp} \
216 %{?with_ares:--enable-ares} \
588be88f
JK
217 %{?with_ldap:--enable-ldaps} \
218 %{!?with_ldap:--disable-ldap} \
8dd62861 219 --enable-ipv6
a436679a 220
c2167492 221%{__make}
81714278 222
223%install
5767e1a7 224rm -rf $RPM_BUILD_ROOT
e566d906 225
56f17d66
AM
226%{__make} install \
227 DESTDIR=$RPM_BUILD_ROOT
228
34ca770a 229# no longer in upstream but a lot of apps tries to include it so we create fake one
925b36ff
AM
230[ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
231echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
34ca770a 232
81714278 233%clean
234rm -rf $RPM_BUILD_ROOT
81714278 235
3fb47407
ER
236%post libs -p /sbin/ldconfig
237%postun libs -p /sbin/ldconfig
1f54b511 238
81714278 239%files
5767e1a7 240%defattr(644,root,root,755)
c091c0ac
JB
241%doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
242%attr(755,root,root) %{_bindir}/curl
c091c0ac 243%{_mandir}/man1/curl.1*
1f54b511 244
814b6f7d
JB
245%files libs
246%defattr(644,root,root,755)
247%attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
b3964ccb 248%attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
814b6f7d 249
1f54b511 250%files devel
251%defattr(644,root,root,755)
c091c0ac
JB
252%doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
253%attr(755,root,root) %{_bindir}/curl-config
254%attr(755,root,root) %{_libdir}/libcurl.so
255%{_libdir}/libcurl.la
256%{_includedir}/curl
8ad78925 257%{_pkgconfigdir}/libcurl.pc
c091c0ac 258%{_mandir}/man1/curl-config.1*
b3964ccb
JB
259%{_mandir}/man3/curl_*.3*
260%{_mandir}/man3/libcurl*.3*
1f54b511 261
262%files static
263%defattr(644,root,root,755)
c091c0ac 264%{_libdir}/libcurl.a
This page took 0.149302 seconds and 4 git commands to generate.