]> git.pld-linux.org Git - packages/cu.git/blob - cu.spec
- updated to 0.15.1
[packages/cu.git] / cu.spec
1 Summary:        Simple unit testing framework for handling automated tests in C
2 Summary(pl.UTF-8):      Szkielet automatycznych testów jednostkowych dla języka C
3 Name:           cu
4 Version:        0.15.1
5 Release:        1
6 License:        BSD
7 Group:          Development/Libraries
8 Source0:        http://cu.danfis.cz/files/%{name}-%{version}.tar.gz
9 # Source0-md5:  bd5f70ea6f06e2a050c7e5e280043927
10 URL:            http://cu.danfis.cz/
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %description
14 CU is simple unit testing framework for handling automated tests in C.
15 CU provides a simple interface for defining unit tests using macros.
16 Each test suite runs in separate process - test suites don't influence
17 each other and any failure (such as segfault) does not break up whole
18 test. CU also provides script for regression tests based on output of
19 test suites.
20
21 %description -l pl.UTF-8
22 CU to prosty szkielet testów jednostkowych do obsługi
23 zautomatyzowanego testowania w języku C. Zapewnia prosty interfejs do
24 definiowania testów jednostkowych przy użyciu makr. Każdy zestaw
25 testów działa w osobnym procesie - zbiory testów nie przeszkadzają
26 sobie nawzajem i jedna awaria (taka jak segfault) nie psuje całości
27 testów. CU dostarcza także skrypt do testów regresji w oparciu o
28 wyjście zestawów testów.
29
30 %prep
31 %setup -q
32
33 %build
34 %{__make} \
35         CC="%{__cc}" \
36         CFLAGS="%{rpmcflags} %{rpmcppflags} -Wall -pedantic"
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 %{__make} install \
42         PREFIX=$RPM_BUILD_ROOT \
43         BINDIR=%{_bindir} \
44         INCLUDEDIR=%{_includedir} \
45         LIBDIR=%{_libdir}
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc BSD-LICENSE CHANGELOG
53 %attr(755,root,root) %{_bindir}/cu-check-regressions
54 %{_libdir}/libcu.a
55 %{_includedir}/cu.h
This page took 0.096714 seconds and 3 git commands to generate.