]> git.pld-linux.org Git - packages/cu.git/blame - cu.spec
- updated to 0.15.1
[packages/cu.git] / cu.spec
CommitLineData
f2fba805
JB
1Summary: Simple unit testing framework for handling automated tests in C
2Summary(pl.UTF-8): Szkielet automatycznych testów jednostkowych dla języka C
3Name: cu
646233ea 4Version: 0.15.1
f2fba805
JB
5Release: 1
6License: BSD
7Group: Development/Libraries
8Source0: http://cu.danfis.cz/files/%{name}-%{version}.tar.gz
646233ea 9# Source0-md5: bd5f70ea6f06e2a050c7e5e280043927
f2fba805
JB
10URL: http://cu.danfis.cz/
11BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13%description
14CU is simple unit testing framework for handling automated tests in C.
15CU provides a simple interface for defining unit tests using macros.
16Each test suite runs in separate process - test suites don't influence
17each other and any failure (such as segfault) does not break up whole
18test. CU also provides script for regression tests based on output of
19test suites.
20
21%description -l pl.UTF-8
22CU to prosty szkielet testów jednostkowych do obsługi
23zautomatyzowanego testowania w języku C. Zapewnia prosty interfejs do
24definiowania testów jednostkowych przy użyciu makr. Każdy zestaw
25testów działa w osobnym procesie - zbiory testów nie przeszkadzają
26sobie nawzajem i jedna awaria (taka jak segfault) nie psuje całości
27testów. CU dostarcza także skrypt do testów regresji w oparciu o
28wyjście zestawów testów.
29
30%prep
31%setup -q
32
33%build
34%{__make} \
35 CC="%{__cc}" \
36 CFLAGS="%{rpmcflags} %{rpmcppflags} -Wall -pedantic"
37
38%install
39rm -rf $RPM_BUILD_ROOT
40
41%{__make} install \
42 PREFIX=$RPM_BUILD_ROOT \
43 BINDIR=%{_bindir} \
44 INCLUDEDIR=%{_includedir} \
45 LIBDIR=%{_libdir}
46
47%clean
48rm -rf $RPM_BUILD_ROOT
49
50%files
51%defattr(644,root,root,755)
52%doc BSD-LICENSE CHANGELOG
53%attr(755,root,root) %{_bindir}/cu-check-regressions
54%{_libdir}/libcu.a
55%{_includedir}/cu.h
This page took 0.061574 seconds and 4 git commands to generate.