]> git.pld-linux.org Git - packages/csync2.git/blob - csync2.spec
- Up to 2.0.
[packages/csync2.git] / csync2.spec
1 Summary:        Cluster sync tool
2 Summary(pl.UTF-8):      Narzędzie do synchronizacji klastra
3 Name:           csync2
4 Version:        2.0
5 Release:        1
6 License:        GPL v2+
7 Group:          Daemons
8 Source0:        http://oss.linbit.com/csync2/%{name}-%{version}.tar.gz
9 # Source0-md5:  4e189ff02af441e588ceaa7791732162
10 Source1:        %{name}.init
11 Source2:        %{name}.inet
12 Source3:        %{name}.sysconfig
13 URL:            http://oss.linbit.com/csync2/
14 BuildRequires:  bison
15 BuildRequires:  flex
16 BuildRequires:  gnutls-devel
17 BuildRequires:  librsync-devel
18 BuildRequires:  openssl-devel
19 BuildRequires:  sqlite-devel
20 Requires:       setup > 2.4.10-4
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _sysconfdir     /etc/%{name}
24
25 %description
26 Csync2 is a cluster synchronization tool. It can be used to keep files
27 on multiple hosts in a cluster in sync. Csync2 can handle complex
28 setups with much more than just 2 hosts, handle file deletions and can
29 detect conflicts. It is expedient for HA-clusters, HPC-clusters, COWs
30 and server farms.
31
32 %description -l pl.UTF-8
33 Csync2 to narzędzie do synchronizacji klastra. Może być używane do
34 utrzymywania zgodności plików na wielu hostach w klastrze. Csync2 jest
35 w stanie obsłużyć złożone konfiguracje z więcej niż 2 hostami,
36 obsługiwać usuwanie plików i wykrywać konflikty. Jest praktyczne dla
37 klastrów HA, HPC, COW oraz farm serwerów.
38
39 %package -n csync2-inetd
40 Summary:        Files necessary to run csync2 in inetd service mode
41 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia csync2 w trybie usługi inetd
42 Group:          Networking/Daemons
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       rc-inetd
45 Provides:       csyncd
46 Provides:       csyncd-inetd
47 Obsoletes:      csyncd
48 Obsoletes:      csync2-standalone
49 Obsoletes:      csyncd-standalone
50
51 %description -n csync2-inetd
52 Csync2 is a cluster synchronization tool. It can be used to keep files
53 on multiple hosts in a cluster in sync. Csync2 can handle complex
54 setups with much more than just 2 hosts, handle file deletions and can
55 detect conflicts. It is expedient for HA-clusters, HPC-clusters, COWs
56 and server farms.
57
58 %description -n csync2-inetd -l pl.UTF-8
59 Csync2 to narzędzie do synchronizacji klastra. Może być używane do
60 utrzymywania zgodności plików na wielu hostach w klastrze. Csync2 jest
61 w stanie obsłużyć złożone konfiguracje z więcej niż 2 hostami,
62 obsługiwać usuwanie plików i wykrywać konflikty. Jest praktyczne dla
63 klastrów HA, HPC, COW oraz farm serwerów.
64
65 %package -n csync2-standalone
66 Summary:        Files necessary to run csync2 in standalone daemon mode
67 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia csync2 w trybie samodzielnego serwera
68 Group:          Networking/Daemons
69 Requires(post,preun):   /sbin/chkconfig
70 Requires:       %{name} = %{version}-%{release}
71 Provides:       csyncd
72 Provides:       csyncd-standalone
73 Obsoletes:      csyncd
74 Obsoletes:      csync2-inetd
75 Obsoletes:      csyncd-inetd
76
77 %description -n csync2-standalone
78 Csync2 is a cluster synchronization tool. It can be used to keep files
79 on multiple hosts in a cluster in sync. Csync2 can handle complex
80 setups with much more than just 2 hosts, handle file deletions and can
81 detect conflicts. It is expedient for HA-clusters, HPC-clusters, COWs
82 and server farms.
83
84 %description -n csync2-standalone -l pl.UTF-8
85 Csync2 to narzędzie do synchronizacji klastra. Może być używane do
86 utrzymywania zgodności plików na wielu hostach w klastrze. Csync2 jest
87 w stanie obsłużyć złożone konfiguracje z więcej niż 2 hostami,
88 obsługiwać usuwanie plików i wykrywać konflikty. Jest praktyczne dla
89 klastrów HA, HPC, COW oraz farm serwerów.
90
91 %prep
92 %setup -q
93
94 %build
95 %configure \
96         --disable-gnutls
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101 install -d $RPM_BUILD_ROOT{%{_var}/lib/csync2,/etc/{sysconfig/rc-inetd,rc.d/init.d}}
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
107 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/%{name}
108 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post -n csync2-inetd
114 %service -q rc-inetd reload
115
116 %postun -n csync2-inetd
117 if [ "$1" = "0" ]; then
118         %service -q rc-inetd reload
119 fi
120
121 %post -n csync2-standalone
122 /sbin/chkconfig --add csync2
123 %service csync2 restart "csync2 server"
124
125 %preun -n csync2-standalone
126 if [ "$1" = "0" ]; then
127         %service csync2 stop
128         /sbin/chkconfig --del csync2
129 fi
130
131 %files
132 %defattr(644,root,root,755)
133 %doc AUTHORS ChangeLog README csync2.xinetd doc/csync2_paper.pdf
134 %dir %{_sysconfdir}
135 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/csync2.cfg
136 %attr(755,root,root) %{_sbindir}/csync2
137 %attr(755,root,root) %{_sbindir}/csync2-compare
138 %dir %{_var}/lib/csync2
139 %{_mandir}/man1/*.1*
140
141 %files -n csync2-inetd
142 %defattr(644,root,root,755)
143 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/%{name}
144
145 %files -n csync2-standalone
146 %defattr(644,root,root,755)
147 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
148 %attr(754,root,root) /etc/rc.d/init.d/%{name}
This page took 0.087992 seconds and 3 git commands to generate.