]> git.pld-linux.org Git - packages/csync2.git/blob - csync2.spec
- use versioned libraries in dlopen (taken from opensuse)
[packages/csync2.git] / csync2.spec
1 Summary:        Cluster sync tool
2 Summary(pl.UTF-8):      Narzędzie do synchronizacji klastra
3 Name:           csync2
4 Version:        2.0
5 Release:        1
6 License:        GPL v2+
7 Group:          Daemons
8 Source0:        http://oss.linbit.com/csync2/%{name}-%{version}.tar.gz
9 # Source0-md5:  4e189ff02af441e588ceaa7791732162
10 Source1:        %{name}.init
11 Source2:        %{name}.inet
12 Source3:        %{name}.sysconfig
13 Patch0:         %{name}-fix-sonames.patch
14 URL:            http://oss.linbit.com/csync2/
15 BuildRequires:  bison
16 BuildRequires:  flex
17 BuildRequires:  gnutls-devel
18 BuildRequires:  librsync-devel
19 BuildRequires:  openssl-devel
20 BuildRequires:  sqlite3-devel
21 BuildRequires:  texlive-format-pdflatex
22 Requires:       setup > 2.4.10-4
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _sysconfdir     /etc/%{name}
26
27 %description
28 Csync2 is a cluster synchronization tool. It can be used to keep files
29 on multiple hosts in a cluster in sync. Csync2 can handle complex
30 setups with much more than just 2 hosts, handle file deletions and can
31 detect conflicts. It is expedient for HA-clusters, HPC-clusters, COWs
32 and server farms.
33
34 %description -l pl.UTF-8
35 Csync2 to narzędzie do synchronizacji klastra. Może być używane do
36 utrzymywania zgodności plików na wielu hostach w klastrze. Csync2 jest
37 w stanie obsłużyć złożone konfiguracje z więcej niż 2 hostami,
38 obsługiwać usuwanie plików i wykrywać konflikty. Jest praktyczne dla
39 klastrów HA, HPC, COW oraz farm serwerów.
40
41 %package -n csync2-inetd
42 Summary:        Files necessary to run csync2 in inetd service mode
43 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia csync2 w trybie usługi inetd
44 Group:          Networking/Daemons
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       rc-inetd
47 Provides:       csyncd
48 Provides:       csyncd-inetd
49 Obsoletes:      csyncd
50 Obsoletes:      csync2-standalone
51 Obsoletes:      csyncd-standalone
52
53 %description -n csync2-inetd
54 Csync2 is a cluster synchronization tool. It can be used to keep files
55 on multiple hosts in a cluster in sync. Csync2 can handle complex
56 setups with much more than just 2 hosts, handle file deletions and can
57 detect conflicts. It is expedient for HA-clusters, HPC-clusters, COWs
58 and server farms.
59
60 %description -n csync2-inetd -l pl.UTF-8
61 Csync2 to narzędzie do synchronizacji klastra. Może być używane do
62 utrzymywania zgodności plików na wielu hostach w klastrze. Csync2 jest
63 w stanie obsłużyć złożone konfiguracje z więcej niż 2 hostami,
64 obsługiwać usuwanie plików i wykrywać konflikty. Jest praktyczne dla
65 klastrów HA, HPC, COW oraz farm serwerów.
66
67 %package -n csync2-standalone
68 Summary:        Files necessary to run csync2 in standalone daemon mode
69 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia csync2 w trybie samodzielnego serwera
70 Group:          Networking/Daemons
71 Requires(post,preun):   /sbin/chkconfig
72 Requires:       %{name} = %{version}-%{release}
73 Provides:       csyncd
74 Provides:       csyncd-standalone
75 Obsoletes:      csyncd
76 Obsoletes:      csync2-inetd
77 Obsoletes:      csyncd-inetd
78
79 %description -n csync2-standalone
80 Csync2 is a cluster synchronization tool. It can be used to keep files
81 on multiple hosts in a cluster in sync. Csync2 can handle complex
82 setups with much more than just 2 hosts, handle file deletions and can
83 detect conflicts. It is expedient for HA-clusters, HPC-clusters, COWs
84 and server farms.
85
86 %description -n csync2-standalone -l pl.UTF-8
87 Csync2 to narzędzie do synchronizacji klastra. Może być używane do
88 utrzymywania zgodności plików na wielu hostach w klastrze. Csync2 jest
89 w stanie obsłużyć złożone konfiguracje z więcej niż 2 hostami,
90 obsługiwać usuwanie plików i wykrywać konflikty. Jest praktyczne dla
91 klastrów HA, HPC, COW oraz farm serwerów.
92
93 %prep
94 %setup -q
95 %patch0 -p1
96
97 %build
98 %configure \
99         --disable-gnutls
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT{%{_var}/lib/csync2,/etc/{sysconfig/rc-inetd,rc.d/init.d}}
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
110 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/%{name}
111 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post -n csync2-inetd
117 %service -q rc-inetd reload
118
119 %postun -n csync2-inetd
120 if [ "$1" = "0" ]; then
121         %service -q rc-inetd reload
122 fi
123
124 %post -n csync2-standalone
125 /sbin/chkconfig --add csync2
126 %service csync2 restart "csync2 server"
127
128 %preun -n csync2-standalone
129 if [ "$1" = "0" ]; then
130         %service csync2 stop
131         /sbin/chkconfig --del csync2
132 fi
133
134 %files
135 %defattr(644,root,root,755)
136 %doc AUTHORS ChangeLog README csync2.xinetd doc/csync2_paper.pdf
137 %dir %{_sysconfdir}
138 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/csync2.cfg
139 %attr(755,root,root) %{_sbindir}/csync2
140 %attr(755,root,root) %{_sbindir}/csync2-compare
141 %dir %{_var}/lib/csync2
142 %{_mandir}/man1/*.1*
143
144 %files -n csync2-inetd
145 %defattr(644,root,root,755)
146 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/%{name}
147
148 %files -n csync2-standalone
149 %defattr(644,root,root,755)
150 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
151 %attr(754,root,root) /etc/rc.d/init.d/%{name}
This page took 0.092968 seconds and 3 git commands to generate.