]> git.pld-linux.org Git - packages/cryptlib.git/blame - cryptlib.spec
- updated to 3.3.2
[packages/cryptlib.git] / cryptlib.spec
CommitLineData
6d278238 1#
c04feed4 2%define libver 3.3.2
6d278238 3#
cdb4650b 4Summary: Peter Gutmann's general purpose encryption library
a23f1eac 5Summary(pl.UTF-8): Biblioteka kryptograficzna ogólnego przeznaczenia Petera Gutmanna
cdb4650b 6Name: cryptlib
c04feed4 7Version: 3.3.2
8%define _ver %(echo %{version} | tr -d .)
6d278238 9Release: 0.1
cdb4650b 10License: sleepycat
313eb19f 11Group: Libraries
c04feed4 12Source0: ftp://ftp.franken.de/pub/crypt/cryptlib/cl%{_ver}.zip
13# Source0-md5: 8736e8a78eb35a4abd3b057420357527
33c869a9
JB
14Patch0: %{name}-rdtsc.patch
15Patch1: %{name}-soname.patch
313eb19f 16URL: http://www.cs.auckland.ac.nz/~pgut001/cryptlib/
33c869a9
JB
17BuildRequires: python-devel >= 1:2.5
18BuildRequires: python-setuptools
19BuildRequires: rpm-pythonprov
015ece3d 20BuildRequires: sed >= 4.0
cdb4650b 21BuildRequires: unzip
6d278238 22%pyrequires_eq python-modules
cdb4650b 23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26The cryptlib encryption library provides an easy-to-use interface
27which allows even inexperienced crypto programmers to easily add
28strong encryption and authentication services to their software. The
29library contains DES, triple DES, IDEA, MDC/SHS, RC2, RC4, RC5, SAFER,
30SAFER-SK, Blowfish, and Blowfish-SK conventional encryption, MD2, MD4,
31MD5, RIPEMD-160 and SHA hash algorithms, and Diffie-Hellman, DSA, and
32RSA public-key encryption.
33
de8d3220
JR
34%description -l pl.UTF-8
35Biblioteka kryptograficzna cryptlib udostępnia łatwy w użyciu
36interfejs pozwalający nawet niedoświaczonym programistom kryptografii
37łatwo dodawać do swoich programów usługi kryptograficzne i
313eb19f
JB
38uwierzytelnienia. Biblioteka zawiera szyfry konwencjonalne DES, 3DES,
39IDEA, MDC/SHS, RC2, RC4, RC5, SAFER, SAFER-SK, Blowfish i Blowfish-SK,
de8d3220 40algorytmy skrótu MD2, MD4, MD5, RIPEMD-160 i SHA oraz szyfry klucza
313eb19f 41publicznego Diffie-Hellmana, DSA i RSA.
cdb4650b 42
43%package devel
313eb19f 44Summary: Header file for cryptlib library
a23f1eac 45Summary(pl.UTF-8): Plik nagłówkowy biblioteki cryptlib
cdb4650b 46Group: Development/Libraries
313eb19f 47Requires: %{name} = %{version}-%{release}
cdb4650b 48
49%description devel
313eb19f
JB
50The header file for developing applications that use the cryptlib
51cryptography library.
52
de8d3220
JR
53%description devel -l pl.UTF-8
54Plik nagłówkowy do tworzenia aplikacji korzystających z biblioteki
313eb19f
JB
55kryptograficznej cryptlib.
56
57%package static
58Summary: Static cryptlib library
a23f1eac 59Summary(pl.UTF-8): Statyczna biblioteka cryptlib
313eb19f
JB
60Group: Development/Libraries
61Requires: %{name}-devel = %{version}-%{release}
62
63%description static
64Static cryptlib library.
65
de8d3220 66%description static -l pl.UTF-8
313eb19f 67Statyczna biblioteka cryptlib.
cdb4650b 68
6d278238 69%package -n python-cryptlib
70Summary: Python bindings for cryptlib
71Summary(pl.UTF-8): Wiązania języka Python do biblioteki cryptlib
72Group: Libraries/Python
73Requires: python >= 1:2.4
74
75%description -n python-cryptlib
76Python bindings for cryptlib library.
77
78%description -n python-cryptlib -l pl.UTF-8
79Wiązania języka Python do biblioteki cryptlib.
80
cdb4650b 81%prep
82%setup -q -T -c
33c869a9
JB
83unzip -q -L -a %{SOURCE0}
84%patch0 -p1
85%patch1 -p1
cdb4650b 86
015ece3d
JB
87sed -i -e 's/ -O3 / %{rpmcflags} /' makefile
88
cdb4650b 89%build
313eb19f 90%{__make} \
015ece3d
JB
91 CC="%{__cc}"
92
313eb19f 93%{__make} shared \
015ece3d 94 CC="%{__cc}"
cdb4650b 95
6d278238 96ln -sf libcl.so.%{libver} libcl.so
97
98cd bindings
99python setup.py build
100
cdb4650b 101%install
102rm -rf $RPM_BUILD_ROOT
6d278238 103install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir},%{py_sitedir}}
313eb19f 104
cdb4650b 105install cryptlib.h $RPM_BUILD_ROOT%{_includedir}
313eb19f 106install libcl.a $RPM_BUILD_ROOT%{_libdir}
6d278238 107install libcl.so.%{libver} $RPM_BUILD_ROOT%{_libdir}
33c869a9
JB
108ln -s libcl.so.%{libver} $RPM_BUILD_ROOT%{_libdir}/libcl.so.3
109ln -s libcl.so.%{libver} $RPM_BUILD_ROOT%{_libdir}/libcl.so
6d278238 110
111cd bindings
112python setup.py install \
113 --optimize=2 \
114 --root=$RPM_BUILD_ROOT
313eb19f
JB
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%post -p /sbin/ldconfig
120%postun -p /sbin/ldconfig
cdb4650b 121
122%files
123%defattr(644,root,root,755)
6d278238 124%attr(755,root,root) %{_libdir}/libcl.so.%{libver}
33c869a9 125%attr(755,root,root) %ghost %{_libdir}/libcl.so.3
cdb4650b 126
127%files devel
128%defattr(644,root,root,755)
33c869a9 129%attr(755,root,root) %{_libdir}/libcl.so
cdb4650b 130%{_includedir}/cryptlib.h
131
313eb19f
JB
132%files static
133%defattr(644,root,root,755)
134%{_libdir}/libcl.a
6d278238 135
136%files -n python-cryptlib
137%defattr(644,root,root,755)
33c869a9
JB
138%attr(755,root,root) %{py_sitedir}/cryptlib_py.so
139%{py_sitedir}/cryptlib_py-*.egg-info
This page took 0.135881 seconds and 4 git commands to generate.