]> git.pld-linux.org Git - packages/cryptlib.git/blame_incremental - cryptlib.spec
- updated to 3.3.2
[packages/cryptlib.git] / cryptlib.spec
... / ...
CommitLineData
1#
2%define libver 3.3.2
3#
4Summary: Peter Gutmann's general purpose encryption library
5Summary(pl.UTF-8): Biblioteka kryptograficzna ogólnego przeznaczenia Petera Gutmanna
6Name: cryptlib
7Version: 3.3.2
8%define _ver %(echo %{version} | tr -d .)
9Release: 0.1
10License: sleepycat
11Group: Libraries
12Source0: ftp://ftp.franken.de/pub/crypt/cryptlib/cl%{_ver}.zip
13# Source0-md5: 8736e8a78eb35a4abd3b057420357527
14Patch0: %{name}-rdtsc.patch
15Patch1: %{name}-soname.patch
16URL: http://www.cs.auckland.ac.nz/~pgut001/cryptlib/
17BuildRequires: python-devel >= 1:2.5
18BuildRequires: python-setuptools
19BuildRequires: rpm-pythonprov
20BuildRequires: sed >= 4.0
21BuildRequires: unzip
22%pyrequires_eq python-modules
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26The cryptlib encryption library provides an easy-to-use interface
27which allows even inexperienced crypto programmers to easily add
28strong encryption and authentication services to their software. The
29library contains DES, triple DES, IDEA, MDC/SHS, RC2, RC4, RC5, SAFER,
30SAFER-SK, Blowfish, and Blowfish-SK conventional encryption, MD2, MD4,
31MD5, RIPEMD-160 and SHA hash algorithms, and Diffie-Hellman, DSA, and
32RSA public-key encryption.
33
34%description -l pl.UTF-8
35Biblioteka kryptograficzna cryptlib udostępnia łatwy w użyciu
36interfejs pozwalający nawet niedoświaczonym programistom kryptografii
37łatwo dodawać do swoich programów usługi kryptograficzne i
38uwierzytelnienia. Biblioteka zawiera szyfry konwencjonalne DES, 3DES,
39IDEA, MDC/SHS, RC2, RC4, RC5, SAFER, SAFER-SK, Blowfish i Blowfish-SK,
40algorytmy skrótu MD2, MD4, MD5, RIPEMD-160 i SHA oraz szyfry klucza
41publicznego Diffie-Hellmana, DSA i RSA.
42
43%package devel
44Summary: Header file for cryptlib library
45Summary(pl.UTF-8): Plik nagłówkowy biblioteki cryptlib
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48
49%description devel
50The header file for developing applications that use the cryptlib
51cryptography library.
52
53%description devel -l pl.UTF-8
54Plik nagłówkowy do tworzenia aplikacji korzystających z biblioteki
55kryptograficznej cryptlib.
56
57%package static
58Summary: Static cryptlib library
59Summary(pl.UTF-8): Statyczna biblioteka cryptlib
60Group: Development/Libraries
61Requires: %{name}-devel = %{version}-%{release}
62
63%description static
64Static cryptlib library.
65
66%description static -l pl.UTF-8
67Statyczna biblioteka cryptlib.
68
69%package -n python-cryptlib
70Summary: Python bindings for cryptlib
71Summary(pl.UTF-8): Wiązania języka Python do biblioteki cryptlib
72Group: Libraries/Python
73Requires: python >= 1:2.4
74
75%description -n python-cryptlib
76Python bindings for cryptlib library.
77
78%description -n python-cryptlib -l pl.UTF-8
79Wiązania języka Python do biblioteki cryptlib.
80
81%prep
82%setup -q -T -c
83unzip -q -L -a %{SOURCE0}
84%patch0 -p1
85%patch1 -p1
86
87sed -i -e 's/ -O3 / %{rpmcflags} /' makefile
88
89%build
90%{__make} \
91 CC="%{__cc}"
92
93%{__make} shared \
94 CC="%{__cc}"
95
96ln -sf libcl.so.%{libver} libcl.so
97
98cd bindings
99python setup.py build
100
101%install
102rm -rf $RPM_BUILD_ROOT
103install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir},%{py_sitedir}}
104
105install cryptlib.h $RPM_BUILD_ROOT%{_includedir}
106install libcl.a $RPM_BUILD_ROOT%{_libdir}
107install libcl.so.%{libver} $RPM_BUILD_ROOT%{_libdir}
108ln -s libcl.so.%{libver} $RPM_BUILD_ROOT%{_libdir}/libcl.so.3
109ln -s libcl.so.%{libver} $RPM_BUILD_ROOT%{_libdir}/libcl.so
110
111cd bindings
112python setup.py install \
113 --optimize=2 \
114 --root=$RPM_BUILD_ROOT
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%post -p /sbin/ldconfig
120%postun -p /sbin/ldconfig
121
122%files
123%defattr(644,root,root,755)
124%attr(755,root,root) %{_libdir}/libcl.so.%{libver}
125%attr(755,root,root) %ghost %{_libdir}/libcl.so.3
126
127%files devel
128%defattr(644,root,root,755)
129%attr(755,root,root) %{_libdir}/libcl.so
130%{_includedir}/cryptlib.h
131
132%files static
133%defattr(644,root,root,755)
134%{_libdir}/libcl.a
135
136%files -n python-cryptlib
137%defattr(644,root,root,755)
138%attr(755,root,root) %{py_sitedir}/cryptlib_py.so
139%{py_sitedir}/cryptlib_py-*.egg-info
This page took 0.095371 seconds and 4 git commands to generate.