]> git.pld-linux.org Git - packages/crossnacl-binutils.git/blob - crossnacl-binutils.spec
- cleanup
[packages/crossnacl-binutils.git] / crossnacl-binutils.spec
1 %define         gitver f412ed5
2 Summary:        Cross NaCL GNU binary utility development utilities - binutils
3 Name:           crossnacl-binutils
4 Version:        2.20.1
5 Release:        1.git%{gitver}
6 License:        GPL
7 Group:          Development/Tools
8 Source0:        nacl-binutils-%{version}-git%{gitver}.tar.bz2
9 # Source0-md5:  b49c25e5cb1bbfb5333aa82bcbda12df
10 Source1:        get-source.sh
11 URL:            http://sources.redhat.com/binutils/
12 BuildRequires:  bash
13 BuildRequires:  bison
14 BuildRequires:  flex
15 BuildRequires:  fslint
16 BuildRequires:  python-modules
17 ExclusiveArch:  %{ix86} %{x8664}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         target          x86_64-nacl
21 %define         arch            %{_prefix}/%{target}
22
23 %description
24 Binutils is a collection of binary utilities, including:
25 - ar - create, modify and extract from archives,
26 - nm - lists symbols from object files,
27 - objcopy - copy and translate object files,
28 - objdump - display information from object files,
29 - ranlib - generate an index for the contents of an archive,
30 - size - list the section sizes of an object or archive file,
31 - strings - list printable strings from files,
32 - strip - discard symbols,
33 - c++filt - a filter for demangling encoded C++ symbols,
34 - addr2line - convert addresses to file and line,
35 - nlmconv - convert object code into an NLM.
36
37 This package contains the cross version for NaCL.
38
39 %description -l pl.UTF-8
40 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
41 programów. Znajdują się tutaj między innymi assembler, konsolidator
42 (linker), a także inne narzędzia do manipulowania binarnymi plikami
43 programów i bibliotek.
44
45 Ten pakiet zawiera wersję skrośną generującą kod dla NaCl.
46
47 %prep
48 %setup -q -n nacl-binutils-%{version}-git%{gitver}
49
50 %build
51 # ldscripts won't be generated properly if SHELL is not bash...
52 CFLAGS="%{rpmcflags} -fno-strict-aliasing" \
53 LDFLAGS="%{rpmldflags}" \
54 CONFIG_SHELL="/bin/bash" \
55 ./configure \
56         --build=%{_target_platform} \
57         --host=%{_target_platform} \
58         --target=%{target} \
59         --enable-targets=%{_host} \
60 %ifarch ia64
61         --enable-targets=i386-linux \
62 %endif
63 %ifarch ppc ppc64
64         --enable-targets=spu \
65 %endif
66 %ifarch %{ix86} sparc sparc64 ppc ppc64 s390 sh arm
67         --enable-64-bit-bfd \
68 %endif
69         --disable-shared \
70         --disable-nls \
71         --disable-werror \
72         --prefix=%{_prefix} \
73         --libdir=%{_libdir} \
74         --mandir=%{_mandir} \
75         --infodir=%{_infodir} \
76         --enable-plugins
77
78 %{__make} all \
79         tooldir=%{_prefix} \
80         EXEEXT=""
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT%{_prefix}
85
86 %{__make} install \
87         prefix=$RPM_BUILD_ROOT%{_prefix} \
88         mandir=$RPM_BUILD_ROOT%{_mandir} \
89         infodir=$RPM_BUILD_ROOT%{_infodir} \
90         libdir=$RPM_BUILD_ROOT%{_libdir}
91
92 # fix copies to be hardlinks (maybe should symlink in the future)
93 findup -m $RPM_BUILD_ROOT
94
95 # remove these man pages unless we cross-build for win*/netware platforms.
96 # however, this should be done in Makefiles.
97 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
98
99 # don't want this here
100 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libiberty.a
101
102 # packaged in base binutils
103 %{__rm} -r $RPM_BUILD_ROOT%{_infodir}
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %files
109 %defattr(644,root,root,755)
110 %doc README
111 %attr(755,root,root) %{_bindir}/%{target}-*
112 %dir %{arch}
113 %dir %{arch}/bin
114 %attr(755,root,root) %{arch}/bin/*
115 %dir %{arch}/lib
116 %dir %{arch}/lib/*
117 %{arch}/lib/ldscripts/*
118 %{_mandir}/man?/%{target}-*
This page took 0.068839 seconds and 3 git commands to generate.