]> git.pld-linux.org Git - packages/crossnacl-binutils.git/blob - crossnacl-binutils.spec
- fetch only master branch
[packages/crossnacl-binutils.git] / crossnacl-binutils.spec
1 %define         gitver 38c9b31a
2 Summary:        Cross NaCL GNU binary utility development utilities - binutils
3 Name:           crossnacl-binutils
4 Version:        2.20.1
5 Release:        0.git%{gitver}
6 License:        GPL
7 Group:          Development/Tools
8 Source0:        nacl-binutils-%{version}-git%{gitver}.tar.bz2
9 # Source0-md5:  baae1be3ea143743e5734b549fa017da
10 URL:            http://sources.redhat.com/binutils/
11 BuildRequires:  bash
12 BuildRequires:  bison
13 BuildRequires:  flex
14 BuildRequires:  fslint
15 BuildRequires:  python-modules
16 ExclusiveArch:  %{ix86} %{x8664}
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         target          x86_64-nacl
20 %define         arch            %{_prefix}/%{target}
21
22 %description
23 Binutils is a collection of binary utilities, including:
24 - ar - create, modify and extract from archives,
25 - nm - lists symbols from object files,
26 - objcopy - copy and translate object files,
27 - objdump - display information from object files,
28 - ranlib - generate an index for the contents of an archive,
29 - size - list the section sizes of an object or archive file,
30 - strings - list printable strings from files,
31 - strip - discard symbols,
32 - c++filt - a filter for demangling encoded C++ symbols,
33 - addr2line - convert addresses to file and line,
34 - nlmconv - convert object code into an NLM.
35
36 This package contains the cross version for NaCL.
37
38 %description -l pl.UTF-8
39 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
40 programów. Znajdują się tutaj między innymi assembler, konsolidator
41 (linker), a także inne narzędzia do manipulowania binarnymi plikami
42 programów i bibliotek.
43
44 Ten pakiet zawiera wersję skrośną generującą kod dla NaCl.
45
46 %prep
47 %setup -q -n nacl-binutils-%{version}-git%{gitver}
48
49 %build
50 # ldscripts won't be generated properly if SHELL is not bash...
51 CFLAGS="%{rpmcflags} -fno-strict-aliasing" \
52 LDFLAGS="%{rpmldflags}" \
53 CONFIG_SHELL="/bin/bash" \
54 ./configure \
55         --build=%{_target_platform} \
56         --host=%{_target_platform} \
57         --target=%{target} \
58         --enable-targets=%{_host} \
59 %ifarch ia64
60         --enable-targets=i386-linux \
61 %endif
62 %ifarch ppc ppc64
63         --enable-targets=spu \
64 %endif
65 %ifarch %{ix86} sparc sparc64 ppc ppc64 s390 sh arm
66         --enable-64-bit-bfd \
67 %endif
68         --disable-shared \
69         --disable-nls \
70         --disable-werror \
71         --prefix=%{_prefix} \
72         --libdir=%{_libdir} \
73         --mandir=%{_mandir} \
74         --infodir=%{_infodir} \
75         --enable-plugins
76
77 %{__make} all \
78         tooldir=%{_prefix} \
79         EXEEXT=""
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT%{_prefix}
84
85 %{__make} install \
86         prefix=$RPM_BUILD_ROOT%{_prefix} \
87         mandir=$RPM_BUILD_ROOT%{_mandir} \
88         infodir=$RPM_BUILD_ROOT%{_infodir} \
89         libdir=$RPM_BUILD_ROOT%{_libdir}
90
91 # fix copies to be hardlinks (maybe should symlink in the future)
92 findup -m $RPM_BUILD_ROOT
93
94 # remove these man pages unless we cross-build for win*/netware platforms.
95 # however, this should be done in Makefiles.
96 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
97
98 # don't want this here
99 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libiberty.a
100
101 # packaged in base binutils
102 %{__rm} -r $RPM_BUILD_ROOT%{_infodir}
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %files
108 %defattr(644,root,root,755)
109 %doc README
110 %attr(755,root,root) %{_bindir}/%{target}-*
111 %dir %{arch}
112 %dir %{arch}/bin
113 %attr(755,root,root) %{arch}/bin/*
114 %dir %{arch}/lib
115 %dir %{arch}/lib/*
116 %{arch}/lib/ldscripts/*
117 %{_mandir}/man?/%{target}-*
This page took 0.100027 seconds and 3 git commands to generate.