]> git.pld-linux.org Git - packages/crossmingw64-binutils.git/blob - crossmingw64-binutils.spec
- updated to 2.42
[packages/crossmingw64-binutils.git] / crossmingw64-binutils.spec
1 Summary:        Cross MinGW-W64 GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - MinGW-W64 binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - MinGW-W64 binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla MinGW-W64 - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - MinGW-W64 binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - MinGW-W64 binutils
7 Name:           crossmingw64-binutils
8 Version:        2.42
9 Release:        1
10 License:        GPL v3+
11 Group:          Development/Tools
12 Source0:        https://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.lz
13 # Source0-md5:  c1526faed7197b4e79dfe04eded7fc11
14 URL:            http://www.sourceware.org/binutils/
15 BuildRequires:  autoconf >= 2.69
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  bash
18 BuildRequires:  bison
19 BuildRequires:  elfutils-debuginfod-devel >= 0.179
20 BuildRequires:  flex
21 BuildRequires:  gettext-tools
22 BuildRequires:  lzip
23 BuildRequires:  msgpack-devel
24 BuildRequires:  perl-tools-pod
25 BuildRequires:  tar >= 1:1.22
26 # not necessary unless we patch .texi docs; but they are not packaged here anyway
27 #BuildRequires: texinfo >= 6.3
28 BuildRequires:  zstd-devel
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 # mingw-w64 project uses x86_64-w64-mingw32 triplet for 64-bit Windows
32 # and (i?86-w64-mingw32 for 32-bit Windows)
33 %define         target          x86_64-w64-mingw32
34 %define         arch            %{_prefix}/%{target}
35
36 %description
37 crossmingw64 is a complete cross-compiling development system for
38 building stand-alone Microsoft Windows applications under Linux using
39 the MinGW64 build libraries. This includes a binutils, gcc with g++
40 and objc, and libstdc++, all cross targeted to x86_64-w64-mingw32,
41 along with supporting Win64 libraries in 'coff' format from free
42 sources.
43
44 This package contains cross targeted binutils.
45
46 %description -l pl.UTF-8
47 crossmingw64 jest kompletnym systemem do kroskompilacji, pozwalającym
48 budować aplikacje MS Windows pod Linuksem używając bibliotek mingw64.
49 System składa się z binutils, gcc z g++ i objc, libstdc++ - wszystkie
50 generujące kod dla platformy x86_64-w64-mingw32, oraz z bibliotek
51 Win64 w formacie COFF.
52
53 Ten pakiet zawiera binutils generujące skrośnie binaria dla
54 64-bitowych Windows.
55
56 %prep
57 %setup -q -n binutils-%{version}
58
59 # file contains hacks for ac 2.69 only
60 %{__rm} config/override.m4
61 %{__sed} -i '/^m4_include(config\/override\.m4/d' configure.ac
62
63 %build
64 cp -f /usr/share/automake/config.* .
65 %{__aclocal}
66 %{__autoconf}
67
68 # non-standard regeneration (needed because of libdir patch)
69 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
70 for dir in gas bfd; do
71         cd $dir || exit 1
72         %{__aclocal} -I .. -I ../config -I ../bfd
73         %{__automake} Makefile
74         test -f doc/Makefile.am && %{__automake} doc/Makefile
75         %{__autoconf}
76         cd ..
77 done
78
79 # We don't install libbfd (nor use shared binutils libraries) to avoid
80 # conflict with native binutils.
81
82 # ldscripts won't be generated properly if SHELL is not bash...
83 CFLAGS="%{rpmcflags}" \
84 LDFLAGS="%{rpmldflags}" \
85 CONFIG_SHELL="/bin/bash" \
86 ./configure \
87         --disable-nls \
88         --disable-shared \
89         --disable-silent-rules \
90         --prefix=%{_prefix} \
91         --libdir=%{_libdir} \
92         --mandir=%{_mandir} \
93         --infodir=%{_infodir} \
94         --host=%{_target_platform} \
95         --build=%{_target_platform} \
96         --target=%{target}
97
98 %{__make} all \
99         tooldir=%{_prefix}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         INSTALL='$$s/install-sh -c' \
106         prefix=$RPM_BUILD_ROOT%{_prefix} \
107         mandir=$RPM_BUILD_ROOT%{_mandir} \
108         infodir=$RPM_BUILD_ROOT%{_infodir} \
109         libdir=$RPM_BUILD_ROOT%{_libdir}
110
111 %{__rm} $RPM_BUILD_ROOT%{_libdir}/bfd-plugins/*.a
112
113 # not prefixed, keep infos only from native packages
114 %{__rm} -r $RPM_BUILD_ROOT%{_infodir}
115
116 # "filesystem" for crossmingw32-* packages (move to crossmingw32-dirs?)
117 install -d $RPM_BUILD_ROOT%{arch}/lib/pkgconfig
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 %defattr(644,root,root,755)
124 %doc README
125 # mingw64 directory tree
126 %dir %{arch}
127 %dir %{arch}/lib
128 %dir %{arch}/lib/pkgconfig
129 %dir %{arch}/bin
130 # binutils files
131 %attr(755,root,root) %{arch}/bin/ar
132 %attr(755,root,root) %{arch}/bin/as
133 %attr(755,root,root) %{arch}/bin/dlltool
134 %attr(755,root,root) %{arch}/bin/ld
135 %attr(755,root,root) %{arch}/bin/ld.bfd
136 %attr(755,root,root) %{arch}/bin/nm
137 %attr(755,root,root) %{arch}/bin/objcopy
138 %attr(755,root,root) %{arch}/bin/objdump
139 %attr(755,root,root) %{arch}/bin/ranlib
140 %attr(755,root,root) %{arch}/bin/readelf
141 %attr(755,root,root) %{arch}/bin/strip
142 %{arch}/lib/ldscripts
143 %attr(755,root,root) %{_bindir}/%{target}-addr2line
144 %attr(755,root,root) %{_bindir}/%{target}-ar
145 %attr(755,root,root) %{_bindir}/%{target}-as
146 %attr(755,root,root) %{_bindir}/%{target}-c++filt
147 %attr(755,root,root) %{_bindir}/%{target}-dlltool
148 %attr(755,root,root) %{_bindir}/%{target}-dllwrap
149 %attr(755,root,root) %{_bindir}/%{target}-elfedit
150 %attr(755,root,root) %{_bindir}/%{target}-gprof
151 %attr(755,root,root) %{_bindir}/%{target}-ld
152 %attr(755,root,root) %{_bindir}/%{target}-ld.bfd
153 %attr(755,root,root) %{_bindir}/%{target}-nm
154 %attr(755,root,root) %{_bindir}/%{target}-objcopy
155 %attr(755,root,root) %{_bindir}/%{target}-objdump
156 %attr(755,root,root) %{_bindir}/%{target}-ranlib
157 %attr(755,root,root) %{_bindir}/%{target}-readelf
158 %attr(755,root,root) %{_bindir}/%{target}-size
159 %attr(755,root,root) %{_bindir}/%{target}-strings
160 %attr(755,root,root) %{_bindir}/%{target}-strip
161 %attr(755,root,root) %{_bindir}/%{target}-windmc
162 %attr(755,root,root) %{_bindir}/%{target}-windres
163 %{_mandir}/man1/%{target}-addr2line.1*
164 %{_mandir}/man1/%{target}-ar.1*
165 %{_mandir}/man1/%{target}-as.1*
166 %{_mandir}/man1/%{target}-c++filt.1*
167 %{_mandir}/man1/%{target}-dlltool.1*
168 %{_mandir}/man1/%{target}-elfedit.1*
169 %{_mandir}/man1/%{target}-gprof.1*
170 %{_mandir}/man1/%{target}-ld.1*
171 %{_mandir}/man1/%{target}-nm.1*
172 %{_mandir}/man1/%{target}-objcopy.1*
173 %{_mandir}/man1/%{target}-objdump.1*
174 %{_mandir}/man1/%{target}-ranlib.1*
175 %{_mandir}/man1/%{target}-readelf.1*
176 %{_mandir}/man1/%{target}-size.1*
177 %{_mandir}/man1/%{target}-strings.1*
178 %{_mandir}/man1/%{target}-strip.1*
179 %{_mandir}/man1/%{target}-windmc.1*
180 %{_mandir}/man1/%{target}-windres.1*
This page took 0.175185 seconds and 4 git commands to generate.