]> git.pld-linux.org Git - packages/crossmingw32-xz.git/blob - crossmingw32-xz.spec
- updated to 5.6.1
[packages/crossmingw32-xz.git] / crossmingw32-xz.spec
1 Summary:        LZMA library - MinGW32 cross version
2 Summary(pl.UTF-8):      Biblioteka LZMA - wersja skrośna dla MinGW32
3 Name:           crossmingw32-xz
4 Version:        5.2.3
5 Release:        1
6 License:        LGPL v2.1+
7 Group:          Development/Libraries
8 Source0:        http://tukaani.org/xz/xz-%{version}.tar.bz2
9 # Source0-md5:  1592e7ca3eece099b03b35f4d9179e7c
10 URL:            http://tukaani.org/xz/
11 BuildRequires:  crossmingw32-gcc >= 3.4
12 BuildRequires:  tar >= 1:1.22
13 BuildRequires:  xz
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         no_install_post_strip   1
17
18 %define         target                  i386-mingw32
19 %define         target_platform         i386-pc-mingw32
20
21 %define         _sysprefix              /usr
22 %define         _prefix                 %{_sysprefix}/%{target}
23 %define         _libdir                 %{_prefix}/lib
24 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
25 %define         _dlldir                 /usr/share/wine/windows/system
26 %define         __cc                    %{target}-gcc
27 %define         __cxx                   %{target}-g++
28 %define         __pkgconfig_provides    %{nil}
29 %define         __pkgconfig_requires    %{nil}
30
31 %ifnarch %{ix86}
32 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
33 %define         optflags        -O2
34 %endif
35 # -z options are invalid for mingw linker
36 %define         filterout_ld    -Wl,-z,.*
37 %define         filterout_c     -f[-a-z0-9=]*
38
39 %description
40 LZMA is default and general compression method of 7z format in 7-Zip
41 program. LZMA provides high compression ratio and very fast
42 decompression, so it is very suitable for embedded applications.
43
44 This package contains the cross version for Win32.
45
46 %description -l pl.UTF-8
47 LZMA jest domyślnym i ogólnym algorytmem kompresji formatu 7z
48 stosowanego przez 7-Zip. LZMA zapewnia wysoki stopień kompresji i
49 bardzo szybką dekompresję, więc nadaje się do zastosowań osadzonych.
50
51 Ten pakiet zawiera wersję skrośną dla Win32.
52
53 %package static
54 Summary:        Static LZMA library (cross MinGW32 version)
55 Summary(pl.UTF-8):      Statyczna biblioteka LZMA (wersja skrośna MinGW32)
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58
59 %description static
60 Static LZMA library (cross MinGW32 version).
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka LZMA (wersja skrośna MinGW32).
64
65 %package dll
66 Summary:        LZMA - DLL library for Windows
67 Summary(pl.UTF-8):      LZMA - biblioteka DLL dla Windows
68 Group:          Applications/Emulators
69 Requires:       wine
70
71 %description dll
72 LZMA - DLL library for Windows.
73
74 %description dll -l pl.UTF-8
75 LZMA - biblioteka DLL dla Windows.
76
77 %prep
78 %setup -q -n xz-%{version}
79
80 %build
81 %configure \
82         --target=%{target} \
83         --host=%{target}
84
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 install -d $RPM_BUILD_ROOT%{_dlldir}
94 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
95
96 %if 0%{!?debug:1}
97 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
98 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
99 %endif
100
101 %{__rm} -r $RPM_BUILD_ROOT%{_bindir}/* \
102         $RPM_BUILD_ROOT%{_mandir}/man1 \
103         $RPM_BUILD_ROOT%{_datadir}/doc/xz \
104         $RPM_BUILD_ROOT%{_datadir}/locale
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %files
110 %defattr(644,root,root,755)
111 %doc AUTHORS COPYING README THANKS doc/*.txt
112 %{_libdir}/liblzma.dll.a
113 %{_libdir}/liblzma.la
114 %{_includedir}/lzma
115 %{_includedir}/lzma.h
116 %{_pkgconfigdir}/liblzma.pc
117
118 %files static
119 %defattr(644,root,root,755)
120 %{_libdir}/liblzma.a
121
122 %files dll
123 %defattr(644,root,root,755)
124 %{_dlldir}/liblzma-5.dll
This page took 0.16636 seconds and 3 git commands to generate.