]> git.pld-linux.org Git - packages/crossmingw32-runtime.git/blob - crossmingw32-runtime.spec
- s/kroskompilator/kompilator skrośny/
[packages/crossmingw32-runtime.git] / crossmingw32-runtime.spec
1 Summary:        Mingw32 Binary Utility Development Utilities - runtime libraries
2 Summary(pl):    Zestaw narzêdzi mingw32 - biblioteki uruchomieniowe
3 Name:           crossmingw32-runtime
4 Version:        3.0
5 #%%define       run_date        20010604
6 #%%define       runsrc          mingw-runtime-%{version}-%{run_date}
7 %define runver  %{version}
8 %define runsrc  mingw-runtime-%{runver}
9 Release:        2
10 Epoch:          1
11 License:        Free
12 Group:          Development/Libraries
13 Source0:        http://dl.sourceforge.net/mingw/%{runsrc}-src.tar.gz
14 # Source0-md5:  3231a7d99d78665e0fb83c2f53f9f885
15 Patch0:         %{name}-stdinc.patch
16 Patch1:         %{name}-configure.patch
17 URL:            http://www.mingw.org/
18 BuildRequires:  crossmingw32-binutils
19 BuildRequires:  crossmingw32-gcc
20 BuildRequires:  crossmingw32-w32api
21 Requires:       crossmingw32-binutils >= 2.14.90.0.4.1-2
22 Requires:       crossmingw32-w32api >= 2.3-2
23 Obsoletes:      crossmingw32-platform
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         target          i386-mingw32
27 %define         target_platform i386-pc-mingw32
28 %define         _prefix         /usr/%{target}
29
30 # strip fails on static COFF files
31 %define         no_install_post_strip 1
32
33 %description
34 crossmingw32 is a complete cross-compiling development system for
35 building stand-alone Microsoft Windows applications under Linux using
36 the Mingw32 build libraries. This includes a binutils, gcc with g++
37 and objc, and libstdc++, all cross targeted to i386-mingw32, along
38 with supporting Win32 libraries in 'coff' format from free sources.
39
40 This package contains MinGW32 runtime includes and libraries.
41
42 %description -l pl
43 crossmingw32 jest kompletnym systemem do kompilacji skro¶nej,
44 pozwalaj±cym budowaæ aplikacje MS Windows pod Linuksem u¿ywaj±c
45 bibliotek mingw32. System sk³ada siê z binutils, gcc z g++ i objc,
46 libstdc++ - wszystkie generuj±ce kod dla platformy i386-mingw32, oraz
47 z bibliotek w formacie COFF.
48
49 Ten pakiet zawiera pliki nag³ówkowe i biblioteki uruchomieniowe
50 MinGW32.
51
52 %prep
53 %setup -q -n %{runsrc}
54 %patch0 -p1 -b .wiget
55 %patch1 -p1
56
57 %build
58 %{__autoconf}
59 cd mingwex
60 %{__autoconf}
61 cd ../profile
62 %{__autoconf}
63 cd ..
64 ./configure \
65         --prefix=%{_prefix} \
66         --host=%{target} \
67         --build=%{_target_platform}
68 %{__make} -C mingwex
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         prefix=$RPM_BUILD_ROOT%{_prefix}
76
77 %if %{!?debug:1}0
78 %{target}-strip $RPM_BUILD_ROOT%{_bindir}/*.dll
79 %{target}-strip -g $RPM_BUILD_ROOT%{_libdir}/*.a
80 %endif
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %{_bindir}/*
88 %{_includedir}/*
89 %{_libdir}/*
This page took 0.075884 seconds and 4 git commands to generate.