]> git.pld-linux.org Git - packages/crossmingw32-pixman.git/blob - crossmingw32-pixman.spec
do not require pkgconfig deps either
[packages/crossmingw32-pixman.git] / crossmingw32-pixman.spec
1 Summary:        Pixel manipulation library - cross MinGW32
2 Summary(pl.UTF-8):      Biblioteka operacji na pikselach - wersja skrośna MinGW32
3 Name:           crossmingw32-pixman
4 Version:        0.28.2
5 Release:        3
6 License:        MIT
7 Group:          Development/Libraries
8 Source0:        http://xorg.freedesktop.org/archive/individual/lib/pixman-%{version}.tar.bz2
9 # Source0-md5:  f6e3294c4edb7b6bca8459e604286348
10 URL:            http://xorg.freedesktop.org/
11 BuildRequires:  autoconf >= 2.57
12 BuildRequires:  automake
13 BuildRequires:  crossmingw32-gcc
14 BuildRequires:  libtool
15 BuildRequires:  pkgconfig
16 BuildRequires:  sed >= 4.0
17 Requires:       crossmingw32-runtime
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         no_install_post_strip   1
21
22 %define         target                  i386-mingw32
23 %define         target_platform         i386-pc-mingw32
24
25 %define         _sysprefix              /usr
26 %define         _prefix                 %{_sysprefix}/%{target}
27 %define         _libdir                 %{_prefix}/lib
28 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
29 %define         _dlldir                 /usr/share/wine/windows/system
30 %define         __cc                    %{target}-gcc
31 %define         __cxx                   %{target}-g++
32 %define         __pkgconfig_provides    %{nil}
33 %define         __pkgconfig_requires    %{nil}
34
35 %ifnarch %{ix86}
36 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
37 %define         optflags        -O2
38 %endif
39 # -z options are invalid for mingw linker, most of -f options are Linux-specific
40 %define         filterout_ld    -Wl,-z,.*
41 %define         filterout_c     -f[-a-z0-9=]*
42
43 %description
44 pixman is a pixel manipulation library.
45
46 This package contains the cross version for Win32.
47
48 %description -l pl.UTF-8
49 pixman to biblioteka do operacji na pikselach.
50
51 Ten pakiet zawiera wersję skrośną dla Win32.
52
53 %package static
54 Summary:        Static pixman library (cross MinGW32 version)
55 Summary(pl.UTF-8):      Statyczna biblioteka pixman (wersja skrośna MinGW32)
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58
59 %description static
60 Static pixman library (cross MinGW32 version).
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka pixman (wersja skrośna MinGW32).
64
65 %package dll
66 Summary:        DLL pixman library for Windows
67 Summary(pl.UTF-8):      Biblioteka DLL pixman dla Windows
68 Group:          Applications/Emulators
69 Requires:       wine
70
71 %description dll
72 DLL pixman library for Windows.
73
74 %description dll -l pl.UTF-8
75 Biblioteka DLL pixman dla Windows.
76
77 %prep
78 %setup -q -n pixman-%{version}
79
80 %{__sed} -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac
81
82 %build
83 %{__libtoolize}
84 %{__aclocal}
85 %{__autoconf}
86 %{__autoheader}
87 %{__automake}
88 %configure \
89         --target=%{target} \
90         --host=%{target} \
91         --disable-gtk \
92         --disable-silent-rules
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 sed -i -e 's#<pixman-version.h>#<pixman-1/pixman-version.h>#g' $RPM_BUILD_ROOT%{_includedir}/pixman-1/pixman.h
103
104 install -d $RPM_BUILD_ROOT%{_dlldir}
105 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
106
107 %if 0%{!?debug:1}
108 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
109 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
110 %endif
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %files
116 %defattr(644,root,root,755)
117 %doc COPYING README
118 %{_libdir}/libpixman-1.dll.a
119 %{_libdir}/libpixman-1.la
120 %{_includedir}/pixman-1
121 %{_pkgconfigdir}/pixman-1.pc
122
123 %files static
124 %defattr(644,root,root,755)
125 %{_libdir}/libpixman-1.a
126
127 %files dll
128 %defattr(644,root,root,755)
129 %{_dlldir}/libpixman-1-*.dll
This page took 0.077639 seconds and 3 git commands to generate.