]> git.pld-linux.org Git - packages/crossmingw32-pcre.git/blob - crossmingw32-pcre.spec
- ac version
[packages/crossmingw32-pcre.git] / crossmingw32-pcre.spec
1 %define         realname        pcre
2 Summary:        Perl-Compatible Regular Expression library - Mingw32 cross version
3 Summary(pl.UTF-8):      Biblioteka perlowych wyrażeń regularnych - wersja skrośna dla Mingw32
4 Name:           crossmingw32-%{realname}
5 Version:        7.8
6 Release:        1
7 License:        BSD (see LICENCE)
8 Group:          Development/Libraries
9 Source0:        ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/%{realname}-%{version}.tar.bz2
10 # Source0-md5:  141132d6af14dccc7b08fa797e4fd441
11 URL:            http://www.pcre.org/
12 BuildRequires:  autoconf >= 2.57
13 BuildRequires:  automake
14 BuildRequires:  crossmingw32-gcc-c++
15 BuildRequires:  crossmingw32-w32api
16 BuildRequires:  libtool
17 Requires:       crossmingw32-runtime
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         no_install_post_strip   1
21
22 %define         target          i386-mingw32
23 %define         target_platform i386-pc-mingw32
24
25 %define         _prefix         /usr/%{target}
26 %define         _libdir         %{_prefix}/lib
27 %define         _pkgconfigdir   %{_prefix}/lib/pkgconfig
28 %define         _dlldir         /usr/share/wine/windows/system
29
30 %define         __cc            %{target}-gcc
31 %define         __cxx           %{target}-g++
32
33 %ifnarch %{ix86}
34 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
35 %define         optflags        -O2
36 %endif
37 # -z options are invalid for mingw linker
38 %define         filterout_ld    -Wl,-z,.*
39
40 %description
41 PCRE stands for the Perl Compatible Regular Expression library. It
42 contains routines to match text against regular expressions similar to
43 Perl's. It also contains a POSIX compatibility library.
44
45 %description -l pl.UTF-8
46 PCRE (Perl-Compatible Regular Expression) oznacza bibliotekę wyrażeń
47 regularnych kompatybilnych z perlowymi. Zawiera funkcje dopasowujące
48 tekst do wyrażeń regularnych podobnych do tych znanych z Perla.
49 Zawiera także bibliotekę kompatybilną z POSIX.
50
51 %package static
52 Summary:        Static PCRE libraries (cross mingw32 version)
53 Summary(pl.UTF-8):      Statyczne biblioteki PCRE (wersja skrośna mingw32)
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56
57 %description static
58 Static PCRE libraries (cross mingw32 version).
59
60 %description static -l pl.UTF-8
61 Statyczne biblioteki PCRE (wersja skrośna mingw32).
62
63 %package dll
64 Summary:        %{realname} - DLL libraries for Windows
65 Summary(pl.UTF-8):      %{realname} - biblioteki DLL dla Windows
66 Group:          Applications/Emulators
67 Requires:       wine
68
69 %description dll
70 %{realname} - DLL libraries for Windows.
71
72 %description dll -l pl.UTF-8
73 %{realname} - biblioteki DLL dla Windows.
74
75 %prep
76 %setup -q -n %{realname}-%{version}
77
78 %build
79 %{__libtoolize}
80 %{__aclocal}
81 %{__autoconf}
82 %{__autoheader}
83 %{__automake}
84 %configure \
85         --host=%{target} \
86         --target=%{target} \
87         --enable-unicode-properties \
88         --enable-utf8
89
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 install -d $RPM_BUILD_ROOT%{_dlldir}
99 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
100
101 %if 0%{!?debug:1}
102 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
103 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
104 %endif
105
106 rm -rf $RPM_BUILD_ROOT%{_datadir}/{doc,man}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files
112 %defattr(644,root,root,755)
113 %doc AUTHORS ChangeLog LICENCE NEWS NON-UNIX-USE README
114 %{_libdir}/libpcre.dll.a
115 %{_libdir}/libpcrecpp.dll.a
116 %{_libdir}/libpcreposix.dll.a
117 %{_libdir}/libpcre.la
118 %{_libdir}/libpcrecpp.la
119 %{_libdir}/libpcreposix.la
120 %{_includedir}/pcre*.h
121 %{_pkgconfigdir}/libpcre.pc
122 %{_pkgconfigdir}/libpcrecpp.pc
123
124 %files static
125 %defattr(644,root,root,755)
126 %{_libdir}/libpcre.a
127 %{_libdir}/libpcrecpp.a
128 %{_libdir}/libpcreposix.a
129
130 %files dll
131 %defattr(644,root,root,755)
132 %{_dlldir}/libpcre-*.dll
133 %{_dlldir}/libpcrecpp-*.dll
134 %{_dlldir}/libpcreposix-*.dll
This page took 0.114035 seconds and 3 git commands to generate.