]> git.pld-linux.org Git - packages/crossmingw32-pcre.git/blob - crossmingw32-pcre.spec
- disable debug packages
[packages/crossmingw32-pcre.git] / crossmingw32-pcre.spec
1 %define         realname        pcre
2 Summary:        Perl-Compatible Regular Expression library - MinGW32 cross version
3 Summary(pl.UTF-8):      Biblioteka perlowych wyrażeń regularnych - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        8.45
6 Release:        1
7 License:        BSD (see LICENCE)
8 Group:          Development/Libraries
9 Source0:        https://ftp.pcre.org/pub/pcre/%{realname}-%{version}.tar.bz2
10 # Source0-md5:  4452288e6a0eefb2ab11d36010a1eebb
11 URL:            http://www.pcre.org/
12 BuildRequires:  autoconf >= 2.57
13 BuildRequires:  automake
14 BuildRequires:  crossmingw32-gcc-c++
15 BuildRequires:  crossmingw32-w32api
16 BuildRequires:  libtool >= 2:2
17 Requires:       crossmingw32-runtime
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         no_install_post_strip   1
21 %define         _enable_debug_packages  0
22
23 %define         target          i386-mingw32
24 %define         target_platform i386-pc-mingw32
25
26 %define         _prefix         /usr/%{target}
27 %define         _libdir         %{_prefix}/lib
28 %define         _pkgconfigdir   %{_prefix}/lib/pkgconfig
29 %define         _dlldir         /usr/share/wine/windows/system
30 %define         __cc            %{target}-gcc
31 %define         __cxx           %{target}-g++
32 %define         __pkgconfig_provides    %{nil}
33 %define         __pkgconfig_requires    %{nil}
34
35 %ifnarch %{ix86}
36 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
37 %define         optflags        -O2
38 %endif
39 # -z options are invalid for mingw linker, most of -f options are Linux-specific
40 %define         filterout_ld    -Wl,-z,.*
41 %define         filterout_c     -f[-a-z0-9=]*
42 %define         filterout_cxx   -f[-a-z0-9=]*
43
44 %description
45 PCRE stands for the Perl Compatible Regular Expression library. It
46 contains routines to match text against regular expressions similar to
47 Perl's. It also contains a POSIX compatibility library.
48
49 %description -l pl.UTF-8
50 PCRE (Perl-Compatible Regular Expression) oznacza bibliotekę wyrażeń
51 regularnych kompatybilnych z perlowymi. Zawiera funkcje dopasowujące
52 tekst do wyrażeń regularnych podobnych do tych znanych z Perla.
53 Zawiera także bibliotekę kompatybilną z POSIX.
54
55 %package static
56 Summary:        Static PCRE libraries (cross MinGW32 version)
57 Summary(pl.UTF-8):      Statyczne biblioteki PCRE (wersja skrośna MinGW32)
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60
61 %description static
62 Static PCRE libraries (cross MinGW32 version).
63
64 %description static -l pl.UTF-8
65 Statyczne biblioteki PCRE (wersja skrośna MinGW32).
66
67 %package dll
68 Summary:        %{realname} - DLL libraries for Windows
69 Summary(pl.UTF-8):      %{realname} - biblioteki DLL dla Windows
70 Group:          Applications/Emulators
71 Requires:       wine
72
73 %description dll
74 %{realname} - DLL libraries for Windows.
75
76 %description dll -l pl.UTF-8
77 %{realname} - biblioteki DLL dla Windows.
78
79 %prep
80 %setup -q -n %{realname}-%{version}
81
82 %build
83 %{__libtoolize}
84 %{__aclocal} -I m4
85 %{__autoconf}
86 %{__autoheader}
87 %{__automake}
88 %configure \
89         --host=%{target} \
90         --target=%{target} \
91         --disable-silent-rules \
92         --enable-pcre16 \
93         --enable-unicode-properties \
94         --enable-utf8
95
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 install -d $RPM_BUILD_ROOT%{_dlldir}
105 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
106
107 %if 0%{!?debug:1}
108 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
109 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
110 %endif
111
112 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{doc,man}
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS ChangeLog LICENCE NEWS NON-UNIX-USE README
120 %{_libdir}/libpcre.dll.a
121 %{_libdir}/libpcre16.dll.a
122 %{_libdir}/libpcrecpp.dll.a
123 %{_libdir}/libpcreposix.dll.a
124 %{_libdir}/libpcre.la
125 %{_libdir}/libpcre16.la
126 %{_libdir}/libpcrecpp.la
127 %{_libdir}/libpcreposix.la
128 %{_includedir}/pcre*.h
129 %{_pkgconfigdir}/libpcre.pc
130 %{_pkgconfigdir}/libpcre16.pc
131 %{_pkgconfigdir}/libpcrecpp.pc
132 %{_pkgconfigdir}/libpcreposix.pc
133
134 %files static
135 %defattr(644,root,root,755)
136 %{_libdir}/libpcre.a
137 %{_libdir}/libpcre16.a
138 %{_libdir}/libpcrecpp.a
139 %{_libdir}/libpcreposix.a
140
141 %files dll
142 %defattr(644,root,root,755)
143 %{_dlldir}/libpcre-1.dll
144 %{_dlldir}/libpcre16-0.dll
145 %{_dlldir}/libpcrecpp-0.dll
146 %{_dlldir}/libpcreposix-0.dll
This page took 0.06543 seconds and 3 git commands to generate.