]> git.pld-linux.org Git - packages/crossmingw32-pcre.git/blob - crossmingw32-pcre.spec
- blah
[packages/crossmingw32-pcre.git] / crossmingw32-pcre.spec
1 %define         realname        pcre
2 Summary:        Perl-Compatible Regular Expression library - Mingw32 cross version
3 Summary(pl):    Biblioteka perlowych wyra¿eñ regularnych - wersja skro¶na dla Mingw32
4 Name:           crossmingw32-%{realname}
5 Version:        4.5
6 Release:        1
7 License:        Free to use (see LICENCE)
8 Group:          Libraries
9 Source0:        ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/%{realname}-%{version}.tar.bz2
10 # Source0-md5:  c51bd34197008b128046f0799d2242e4
11 Patch0:         %{name}-shared.patch
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  crossmingw32-gcc
15 BuildRequires:  crossmingw32-w32api
16 BuildRequires:  libtool
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         no_install_post_strip   1
20
21 %define         target          i386-mingw32
22 %define         target_platform i386-pc-mingw32
23 %define         arch            %{_prefix}/%{target}
24 %define         gccarch         %{_prefix}/lib/gcc-lib/%{target}
25 %define         gcclib          %{_prefix}/lib/gcc-lib/%{target}/%{version}
26
27 %define         __cc            %{target}-gcc
28 %define         __cxx           %{target}-g++
29
30 %description
31 PCRE stands for the Perl Compatible Regular Expression library. It
32 contains routines to match text against regular expressions similar to
33 Perl's. It also contains a POSIX compatibility library.
34
35 %description -l pl
36 PCRE (Perl-Compatible Regular Expression) oznacza bibliotekê wyra¿eñ
37 regularnych kompatybilnych z perlowymi. Zawiera funkcje dopasowuj±ce
38 tekst do wyra¿eñ regularnych podobnych do tych znanych z Perla.
39 Zawiera tak¿e bibliotekê kompatybiln± z POSIX.
40
41 %package dll
42 Summary:        %{realname} - DLL library for Windows
43 Summary(pl):    %{realname} - biblioteka DLL dla Windows
44 Group:          Applications/Emulators
45
46 %description dll
47 %{realname} - DLL library for Windows.
48
49 %description dll -l pl
50 %{realname} - biblioteka DLL dla Windows.
51
52 %prep
53 %setup -q -n %{realname}-%{version}
54 %patch0 -p1
55
56 %build
57 CC=%{target}-gcc ; export CC
58 CXX=%{target}-g++ ; export CXX
59 LD=%{target}-ld ; export LD
60 AR=%{target}-ar ; export AR
61 AS=%{target}-as ; export AS
62 CROSS_COMPILE=1 ; export CROSS_COMPILE
63 CPPFLAGS="-I%{arch}/include" ; export CPPFLAGS
64 RANLIB=%{target}-ranlib ; export RANLIB
65 LDSHARED="%{target}-gcc -shared" ; export LDSHARED
66 TARGET="%{target}" ; export TARGET
67
68 %{__libtoolize}
69 %{__aclocal}
70 %{__autoconf}
71 %configure \
72         --enable-utf8 \
73         --disable-shared
74
75 %{__make}
76 %{__make} pcre.dll
77
78 %if 0%{!?debug:1}
79 %{target}-strip .libs/*.dll
80 %{target}-strip -g -R.comment -R.note .libs/*.a
81 %endif
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT%{arch}/{include,lib}
86 install -d $RPM_BUILD_ROOT%{_datadir}/wine/windows/system
87
88 install pcre.h $RPM_BUILD_ROOT%{arch}/include
89 install .libs/libpcre{,.dll}.a $RPM_BUILD_ROOT%{arch}/lib
90 install .libs/pcre.dll $RPM_BUILD_ROOT%{_datadir}/wine/windows/system
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %defattr(644,root,root,755)
97 %{arch}/include/*
98 %{arch}/lib/*
99
100 %files dll
101 %defattr(644,root,root,755)
102 %{_datadir}/wine/windows/system/*
This page took 0.055979 seconds and 3 git commands to generate.