]> git.pld-linux.org Git - packages/crossmingw32-pangomm.git/blob - crossmingw32-pangomm.spec
do not provide pkgconfig deps in system namespace
[packages/crossmingw32-pangomm.git] / crossmingw32-pangomm.spec
1 Summary:        A C++ interface for pango library - cross MinGW32 version
2 Summary(pl.UTF-8):      Interfejs C++ dla biblioteki pango - wersja skrośna MinGW32
3 Name:           crossmingw32-pangomm
4 Version:        2.28.4
5 Release:        2
6 License:        LGPL v2+
7 Group:          Development/Libraries
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/pangomm/2.28/pangomm-%{version}.tar.xz
9 # Source0-md5:  f4fe0905ee56e1ff0205005e61d2a66f
10 URL:            http://www.gtkmm.org/
11 BuildRequires:  autoconf >= 2.59
12 BuildRequires:  automake >= 1:1.11
13 BuildRequires:  crossmingw32-cairomm >= 1.6.3
14 BuildRequires:  crossmingw32-gcc-c++
15 BuildRequires:  crossmingw32-glibmm >= 2.22.0
16 BuildRequires:  crossmingw32-pango >= 1.24.0
17 BuildRequires:  libtool >= 2:2.0
18 BuildRequires:  mm-common >= 0.9.5
19 BuildRequires:  pkgconfig >= 1:0.15
20 BuildRequires:  rpmbuild(macros) >= 1.446
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 Requires:       crossmingw32-cairomm >= 1.6.3
24 Requires:       crossmingw32-glibmm >= 2.22.0
25 Requires:       crossmingw32-pango >= 1.24.0
26 Provides:       crossmingw32-gtkmm-pango
27 Obsoletes:      crossmingw32-gtkmm-pango
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         no_install_post_strip   1
31
32 %define         target                  i386-mingw32
33 %define         target_platform         i386-pc-mingw32
34
35 %define         _sysprefix              /usr
36 %define         _prefix                 %{_sysprefix}/%{target}
37 %define         _libdir                 %{_prefix}/lib
38 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
39 %define         _dlldir                 /usr/share/wine/windows/system
40 %define         __cc                    %{target}-gcc
41 %define         __cxx                   %{target}-g++
42 %define         __pkgconfig_provides    %{nil}
43
44 %ifnarch %{ix86}
45 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
46 %define         optflags        -O2
47 %endif
48 # -z options are invalid for mingw linker
49 %define         filterout_ld    -Wl,-z,.*
50
51 %description
52 A C++ interface for pango library - cross MinGW32 version.
53
54 %description -l pl.UTF-8
55 Interfejs C++ dla biblioteki pango - wersja skrośna MinGW32.
56
57 %package static
58 Summary:        Static pangomm library (cross MinGW32 version)
59 Summary(pl.UTF-8):      Statyczna biblioteka pangomm (wersja skrośna MinGW32)
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Provides:       crossmingw32-gtkmm-pango-static
63 Obsoletes:      crossmingw32-gtkmm-pango-static
64
65 %description static
66 Static pangomm library (cross MinGW32 version).
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka pangomm (wersja skrośna MinGW32).
70
71 %package dll
72 Summary:        DLL pangomm library for Windows
73 Summary(pl.UTF-8):      Biblioteka DLL pangomm dla Windows
74 Group:          Applications/Emulators
75 Requires:       crossmingw32-cairomm-dll >= 1.6.3
76 Requires:       crossmingw32-glibmm-dll >= 2.22.0
77 Requires:       crossmingw32-pango-dll >= 1.24.0
78 Requires:       wine
79 Provides:       crossmingw32-gtkmm-pango-dll
80 Obsoletes:      crossmingw32-gtkmm-pango-dll
81
82 %description dll
83 DLL pangomm library for Windows.
84
85 %description dll -l pl.UTF-8
86 Biblioteka DLL pangomm dla Windows.
87
88 %prep
89 %setup -q -n pangomm-%{version}
90
91 %build
92 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig:%{_npkgconfigdir}
93 %{__libtoolize}
94 %{__aclocal} -I build
95 %{__autoconf}
96 %{__autoheader}
97 %{__automake}
98 %configure \
99         --target=%{target} \
100         --host=%{target} \
101         --disable-documentation \
102         --disable-silent-rules \
103         --enable-static
104
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 install -d $RPM_BUILD_ROOT%{_dlldir}
114 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
115
116 %if 0%{!?debug:1}
117 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
118 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
119 %endif
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog NEWS README
127 %{_libdir}/libpangomm-1.4.dll.a
128 %{_libdir}/libpangomm-1.4.la
129 %{_libdir}/pangomm-1.4
130 %{_includedir}/pangomm-1.4
131 %{_pkgconfigdir}/pangomm-1.4.pc
132
133 %files static
134 %defattr(644,root,root,755)
135 %{_libdir}/libpangomm-1.4.a
136
137 %files dll
138 %defattr(644,root,root,755)
139 %{_dlldir}/libpangomm-1.4-*.dll
This page took 0.273717 seconds and 3 git commands to generate.