]> git.pld-linux.org Git - packages/crossmingw32-pangomm.git/blob - crossmingw32-pangomm.spec
- updated to 2.40.0
[packages/crossmingw32-pangomm.git] / crossmingw32-pangomm.spec
1 Summary:        A C++ interface for pango library - cross MinGW32 version
2 Summary(pl.UTF-8):      Interfejs C++ dla biblioteki pango - wersja skrośna MinGW32
3 Name:           crossmingw32-pangomm
4 Version:        2.40.0
5 Release:        1
6 License:        LGPL v2+
7 Group:          Development/Libraries
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/pangomm/2.40/pangomm-%{version}.tar.xz
9 # Source0-md5:  681fe43bac96e63321406e1b092093d2
10 URL:            http://www.gtkmm.org/
11 BuildRequires:  autoconf >= 2.59
12 BuildRequires:  automake >= 1:1.11
13 BuildRequires:  crossmingw32-cairomm >= 1.12.0
14 BuildRequires:  crossmingw32-gcc-c++ >= 1:4.6
15 BuildRequires:  crossmingw32-glibmm >= 2.48.0
16 BuildRequires:  crossmingw32-pango >= 1.38.0
17 BuildRequires:  libtool >= 2:2.0
18 BuildRequires:  mm-common >= 0.9.8
19 BuildRequires:  pkgconfig >= 1:0.15
20 BuildRequires:  rpmbuild(macros) >= 1.446
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 Requires:       crossmingw32-cairomm >= 1.12.0
24 Requires:       crossmingw32-gcc-c++ >= 1:4.6
25 Requires:       crossmingw32-glibmm >= 2.48.0
26 Requires:       crossmingw32-pango >= 1.38.0
27 Provides:       crossmingw32-gtkmm-pango
28 Obsoletes:      crossmingw32-gtkmm-pango
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         no_install_post_strip   1
32
33 %define         target                  i386-mingw32
34 %define         target_platform         i386-pc-mingw32
35
36 %define         _sysprefix              /usr
37 %define         _prefix                 %{_sysprefix}/%{target}
38 %define         _libdir                 %{_prefix}/lib
39 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
40 %define         _dlldir                 /usr/share/wine/windows/system
41 %define         __cc                    %{target}-gcc
42 %define         __cxx                   %{target}-g++
43 %define         __pkgconfig_provides    %{nil}
44 %define         __pkgconfig_requires    %{nil}
45
46 %define         _ssp_cflags             %{nil}
47 %ifnarch %{ix86}
48 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
49 %define         optflags        -O2
50 %endif
51 # -z options are invalid for mingw linker, most of -f options are Linux-specific
52 %define         filterout_ld    -Wl,-z,.*
53 %define         filterout_c             -f[-a-z0-9=]*
54
55 %description
56 A C++ interface for pango library - cross MinGW32 version.
57
58 %description -l pl.UTF-8
59 Interfejs C++ dla biblioteki pango - wersja skrośna MinGW32.
60
61 %package static
62 Summary:        Static pangomm library (cross MinGW32 version)
63 Summary(pl.UTF-8):      Statyczna biblioteka pangomm (wersja skrośna MinGW32)
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Provides:       crossmingw32-gtkmm-pango-static
67 Obsoletes:      crossmingw32-gtkmm-pango-static
68
69 %description static
70 Static pangomm library (cross MinGW32 version).
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka pangomm (wersja skrośna MinGW32).
74
75 %package dll
76 Summary:        DLL pangomm library for Windows
77 Summary(pl.UTF-8):      Biblioteka DLL pangomm dla Windows
78 Group:          Applications/Emulators
79 Requires:       crossmingw32-cairomm-dll >= 1.12.0
80 Requires:       crossmingw32-glibmm-dll >= 2.48.0
81 Requires:       crossmingw32-pango-dll >= 1.38.0
82 Requires:       wine
83 Provides:       crossmingw32-gtkmm-pango-dll
84 Obsoletes:      crossmingw32-gtkmm-pango-dll
85
86 %description dll
87 DLL pangomm library for Windows.
88
89 %description dll -l pl.UTF-8
90 Biblioteka DLL pangomm dla Windows.
91
92 %prep
93 %setup -q -n pangomm-%{version}
94
95 %build
96 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig:%{_npkgconfigdir}
97 %{__libtoolize}
98 %{__aclocal} -I build
99 %{__autoconf}
100 %{__autoheader}
101 %{__automake}
102 %configure \
103         --target=%{target} \
104         --host=%{target} \
105         --disable-documentation \
106         --disable-silent-rules \
107         --enable-static
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 install -d $RPM_BUILD_ROOT%{_dlldir}
118 %{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
119
120 %if 0%{!?debug:1}
121 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
122 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
123 %endif
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS ChangeLog NEWS README
131 %{_libdir}/libpangomm-1.4.dll.a
132 %{_libdir}/libpangomm-1.4.la
133 %{_libdir}/pangomm-1.4
134 %{_includedir}/pangomm-1.4
135 %{_pkgconfigdir}/pangomm-1.4.pc
136
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/libpangomm-1.4.a
140
141 %files dll
142 %defattr(644,root,root,755)
143 %{_dlldir}/libpangomm-1.4-*.dll
This page took 0.061689 seconds and 3 git commands to generate.