]> git.pld-linux.org Git - packages/crossmingw32-pango.git/blob - crossmingw32-pango.spec
- updated to 1.48.7
[packages/crossmingw32-pango.git] / crossmingw32-pango.spec
1 Summary:        System for layout and rendering of internationalized text - cross MinGW32 version
2 Summary(pl.UTF-8):      System renderowania międzynarodowego tekstu - wersja skrośna dla MinGW32
3 %define         realname   pango
4 Name:           crossmingw32-%{realname}
5 Version:        1.48.7
6 Release:        1
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        https://download.gnome.org/sources/pango/1.48/%{realname}-%{version}.tar.xz
10 # Source0-md5:  01b2902c42313032784e1d1f99b0d9be
11 URL:            https://pango.gnome.org/
12 # cairo-ft cairo-pdf cairo-png cairo-ps cairo-win32
13 BuildRequires:  crossmingw32-cairo >= 1.12.10
14 BuildRequires:  crossmingw32-fontconfig >= 2.12.92
15 BuildRequires:  crossmingw32-freetype >= 2.1.7
16 BuildRequires:  crossmingw32-fribidi >= 0.19.7
17 BuildRequires:  crossmingw32-gcc
18 # when supported by our mingw32
19 #BuildRequires: crossmingw32-glib2 >= 2.68.0
20 BuildRequires:  crossmingw32-glib2 >= 2.62
21 BuildRequires:  crossmingw32-harfbuzz >= 2.6.0
22 BuildRequires:  crossmingw32-w32api >= 5.0.2-6
23 # glib-genmarshal, glib-mkenums
24 BuildRequires:  glib2-devel >= 1:2.68.0
25 BuildRequires:  meson >= 0.55.3
26 BuildRequires:  ninja >= 1.5
27 BuildRequires:  perl-base
28 BuildRequires:  pkgconfig >= 1:0.15
29 BuildRequires:  rpmbuild(macros) >= 1.736
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xz
32 Requires:       crossmingw32-cairo >= 1.12.10
33 Requires:       crossmingw32-fontconfig >= 2.12.92
34 Requires:       crossmingw32-freetype >= 2.1.7
35 Requires:       crossmingw32-fribidi >= 0.19.7
36 #Requires:      crossmingw32-glib2 >= 2.68.0
37 Requires:       crossmingw32-glib2 >= 2.62
38 Requires:       crossmingw32-harfbuzz >= 2.6.0
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         no_install_post_strip   1
42 %define         _enable_debug_packages  0
43
44 %define         target                  i386-mingw32
45 %define         target_platform         i386-pc-mingw32
46
47 %define         _sysprefix              /usr
48 %define         _prefix                 %{_sysprefix}/%{target}
49 %define         _libdir                 %{_prefix}/lib
50 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
51 %define         _dlldir                 /usr/share/wine/windows/system
52 %define         __pkgconfig_provides    %{nil}
53 %define         __pkgconfig_requires    %{nil}
54 # for meson 0.50+, keep __cc/__cxx as host compiler and pass %{target}-* in meson-cross.txt
55
56 %define         _ssp_cflags             %{nil}
57 %ifnarch %{ix86}
58 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
59 %define         optflags        -O2
60 %endif
61 # -z options are invalid for mingw linker, most of -f options are Linux-specific
62 %define         filterout_ld    -Wl,-z,.*
63 %define         filterout_c     -f[-a-z0-9=]*
64
65 %description
66 System for layout and rendering of internationalized text (cross
67 MinGW32 version).
68
69 %description -l pl.UTF-8
70 System obsługi i renderowania międzynarodowego tekstu (wersja skrośna
71 MinGW32).
72
73 %package static
74 Summary:        Static Pango libraries (cross MinGW32 version)
75 Summary(pl.UTF-8):      Statyczne biblioteki Pango (wersja skrośna MinGW32)
76 Group:          Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78
79 %description static
80 Static Pango libraries (cross MinGW32 version).
81
82 %description static -l pl.UTF-8
83 Statyczne biblioteki Pango (wersja skrośna MinGW32).
84
85 %package dll
86 Summary:        DLL pango libraries for Windows
87 Summary(pl.UTF-8):      Biblioteki DLL pango dla Windows
88 Group:          Applications/Emulators
89 Requires:       crossmingw32-cairo-dll >= 1.12.10
90 Requires:       crossmingw32-fontconfig-dll >= 2.12.92
91 Requires:       crossmingw32-freetype-dll >= 2.1.7
92 Requires:       crossmingw32-fribidi-dll >= 0.19.7
93 #Requires:      crossmingw32-glib2-dll >= 2.68.0
94 Requires:       crossmingw32-glib2-dll >= 2.62
95 Requires:       crossmingw32-harfbuzz-dll >= 2.6.0
96 Requires:       wine
97
98 %description dll
99 DLL pango libraries for Windows.
100
101 %description dll -l pl.UTF-8
102 Biblioteki DLL pango dla Windows.
103
104 %prep
105 %setup -q -n %{realname}-%{version}
106
107 # disable unused gi-docgen subproject
108 %{__sed} -i -e '/fallback:.*gi-docgen/d' meson.build
109
110 cat > meson-cross.txt <<'EOF'
111 [host_machine]
112 system = 'windows'
113 cpu_family = 'x86'
114 cpu = 'i386'
115 endian='little'
116 [binaries]
117 c = '%{target}-gcc'
118 cpp = '%{target}-g++'
119 ar = '%{target}-ar'
120 windres = '%{target}-windres'
121 pkgconfig = 'pkg-config'
122 [properties]
123 c_args = ['%(echo %{rpmcflags} | sed -e "s/ \+/ /g;s/ /', '/g")', '-DWINVER=0x0600']
124 EOF
125
126 %build
127 export PKG_CONFIG_LIBDIR=%{_pkgconfigdir}
128 %meson build \
129         --cross-file meson-cross.txt \
130         %{?debug:--debug} \
131         -Dgtk_doc=false \
132         -Dintrospection=disabled
133
134 %ninja_build -C build
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 %ninja_install -C build
140
141 install -d $RPM_BUILD_ROOT%{_dlldir}
142 %{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
143
144 %if 0%{!?debug:1}
145 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
146 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
147 %endif
148
149 %{__rm} $RPM_BUILD_ROOT%{_bindir}/pango-{list,segmentation,view}.exe
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %files
155 %defattr(644,root,root,755)
156 %doc NEWS README.md README.win32 THANKS
157 %{_libdir}/libpango-1.0.dll.a
158 %{_libdir}/libpangocairo-1.0.dll.a
159 %{_libdir}/libpangoft2-1.0.dll.a
160 %{_libdir}/libpangowin32-1.0.dll.a
161 %{_includedir}/pango-1.0
162 %{_pkgconfigdir}/pango.pc
163 %{_pkgconfigdir}/pangocairo.pc
164 %{_pkgconfigdir}/pangofc.pc
165 %{_pkgconfigdir}/pangoft2.pc
166 %{_pkgconfigdir}/pangoot.pc
167 %{_pkgconfigdir}/pangowin32.pc
168
169 %files static
170 %defattr(644,root,root,755)
171 %{_libdir}/libpango-1.0.a
172 %{_libdir}/libpangocairo-1.0.a
173 %{_libdir}/libpangoft2-1.0.a
174 %{_libdir}/libpangowin32-1.0.a
175
176 %files dll
177 %defattr(644,root,root,755)
178 %{_dlldir}/libpango-1.0-0.dll
179 %{_dlldir}/libpangocairo-1.0-0.dll
180 %{_dlldir}/libpangoft2-1.0-0.dll
181 %{_dlldir}/libpangowin32-1.0-0.dll
This page took 0.180794 seconds and 4 git commands to generate.