]> git.pld-linux.org Git - packages/crossmingw32-pango.git/blob - crossmingw32-pango.spec
- updated to 1.34.0
[packages/crossmingw32-pango.git] / crossmingw32-pango.spec
1 Summary:        System for layout and rendering of internationalized text - cross MinGW32 version
2 Summary(pl.UTF-8):      System renderowania międzynarodowego tekstu - wersja skrośna dla MinGW32
3 %define         realname   pango
4 Name:           crossmingw32-%{realname}
5 Version:        1.34.0
6 Release:        1
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/pango/1.34/%{realname}-%{version}.tar.xz
10 # Source0-md5:  eb440fc26b383c0be363e1b952ddc71c
11 URL:            http://www.pango.org/
12 BuildRequires:  autoconf >= 2.59-9
13 BuildRequires:  automake >= 1:1.9
14 BuildRequires:  crossmingw32-cairo >= 1.8.0
15 BuildRequires:  crossmingw32-fontconfig >= 2.10.91
16 BuildRequires:  crossmingw32-freetype >= 2.1.7
17 BuildRequires:  crossmingw32-gcc
18 BuildRequires:  crossmingw32-glib2 >= 2.34.0
19 BuildRequires:  crossmingw32-harfbuzz >= 0.9.9
20 BuildRequires:  libtool >= 1:1.4.2-9
21 BuildRequires:  perl-base
22 BuildRequires:  pkgconfig >= 1:0.15
23 BuildRequires:  rpmbuild(macros) >= 1.197
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  xz
26 Requires:       crossmingw32-cairo >= 1.8.0
27 Requires:       crossmingw32-fontconfig >= 2.10.91
28 Requires:       crossmingw32-freetype >= 2.1.7
29 Requires:       crossmingw32-glib2 >= 2.34.0
30 Requires:       crossmingw32-harfbuzz >= 0.9.9
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         no_install_post_strip   1
34
35 %define         target                  i386-mingw32
36 %define         target_platform         i386-pc-mingw32
37
38 %define         _sysprefix              /usr
39 %define         _prefix                 %{_sysprefix}/%{target}
40 %define         _libdir                 %{_prefix}/lib
41 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
42 %define         _dlldir                 /usr/share/wine/windows/system
43 %define         __cc                    %{target}-gcc
44 %define         __cxx                   %{target}-g++
45
46 %ifnarch %{ix86}
47 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
48 %define         optflags        -O2
49 %endif
50 # -z options are invalid for mingw linker, most of -f options are Linux-specific
51 %define         filterout_ld    -Wl,-z,.*
52 %define         filterout_c     -f[-a-z0-9=]*
53
54 %description
55 System for layout and rendering of internationalized text (cross
56 MinGW32 version).
57
58 %description -l pl.UTF-8
59 System obsługi i renderowania międzynarodowego tekstu (wersja skrośna
60 MinGW32).
61
62 %package dll
63 Summary:        DLL pango libraries for Windows
64 Summary(pl.UTF-8):      Biblioteki DLL pango dla Windows
65 Group:          Applications/Emulators
66 Requires:       crossmingw32-cairo-dll >= 1.8.0
67 Requires:       crossmingw32-fontconfig-dll >= 2.10.91
68 Requires:       crossmingw32-freetype-dll >= 2.1.7
69 Requires:       crossmingw32-glib2-dll >= 2.34.0
70 Requires:       crossmingw32-harfbuzz-dll >= 0.9.9
71 Requires:       wine
72
73 %description dll
74 DLL pango libraries for Windows.
75
76 %description dll -l pl.UTF-8
77 Biblioteki DLL pango dla Windows.
78
79 %prep
80 %setup -q -n %{realname}-%{version}
81
82 %build
83 export PKG_CONFIG_LIBDIR=%{_pkgconfigdir}
84 %{__libtoolize}
85 %{__aclocal}
86 %{__autoheader}
87 %{__autoconf}
88 %{__automake}
89 %configure \
90         --target=%{target} \
91         --host=%{target} \
92         --disable-silent-rules
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 # missing from make install but required by it
100 install -d $RPM_BUILD_ROOT%{_sysconfdir}/pango
101
102 %{__make} -j1 install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 install -d $RPM_BUILD_ROOT%{_dlldir}
106 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
107
108 # omitted from make install
109 for f in pango pangocairo pangoft2 pangowin32 ; do
110         cp -p pango/${f}.def $RPM_BUILD_ROOT%{_libdir}/${f}-1.0.def
111 done
112
113 %if 0%{!?debug:1}
114 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
115 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
116 %endif
117
118 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{gtk-doc,man}
119 # useless (modules loaded through libgmodule)
120 %{__rm} $RPM_BUILD_ROOT%{_libdir}/pango/1.8.0/modules/*.{la,a}
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(644,root,root,755)
127 %doc AUTHORS NEWS README
128 %{_libdir}/libpango-1.0.dll.a
129 %{_libdir}/libpangocairo-1.0.dll.a
130 %{_libdir}/libpangoft2-1.0.dll.a
131 %{_libdir}/libpangowin32-1.0.dll.a
132 %{_libdir}/libpango-1.0.la
133 %{_libdir}/libpangocairo-1.0.la
134 %{_libdir}/libpangoft2-1.0.la
135 %{_libdir}/libpangowin32-1.0.la
136 %{_libdir}/pango-1.0.def
137 %{_libdir}/pangocairo-1.0.def
138 %{_libdir}/pangoft2-1.0.def
139 %{_libdir}/pangowin32-1.0.def
140 %{_includedir}/pango-1.0
141 %{_pkgconfigdir}/pango.pc
142 %{_pkgconfigdir}/pangocairo.pc
143 %{_pkgconfigdir}/pangoft2.pc
144 %{_pkgconfigdir}/pangowin32.pc
145
146 %files dll
147 %defattr(644,root,root,755)
148 %{_dlldir}/libpango-1.0-*.dll
149 %{_dlldir}/libpangocairo-1.0-*.dll
150 %{_dlldir}/libpangoft2-1.0-*.dll
151 %{_dlldir}/libpangowin32-1.0-*.dll
152 %dir %{_libdir}/pango
153 %dir %{_libdir}/pango/1.8.0
154 %dir %{_libdir}/pango/1.8.0/modules
155 %{_libdir}/pango/1.8.0/modules/*.dll
This page took 0.101673 seconds and 3 git commands to generate.