]> git.pld-linux.org Git - packages/crossmingw32-pango.git/blob - crossmingw32-pango.spec
- updated to 1.22.3
[packages/crossmingw32-pango.git] / crossmingw32-pango.spec
1 Summary:        System for layout and rendering of internationalized text - cross Mingw32 version
2 Summary(pl.UTF-8):      System renderowania międzynarodowego tekstu - wersja skrośna dla Mingw32
3 %define         realname   pango
4 Name:           crossmingw32-%{realname}
5 Version:        1.22.3
6 Release:        1
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/pango/1.22/%{realname}-%{version}.tar.bz2
10 # Source0-md5:  8909ddbde2f2e91eb0c79202e1051a84
11 Patch0:         %{realname}-xfonts.patch
12 URL:            http://www.pango.org/
13 BuildRequires:  autoconf >= 2.59-9
14 BuildRequires:  automake >= 1:1.9
15 BuildRequires:  crossmingw32-cairo >= 1.8.0
16 BuildRequires:  crossmingw32-fontconfig >= 2.4.0
17 BuildRequires:  crossmingw32-freetype >= 2.1.7
18 BuildRequires:  crossmingw32-gcc
19 BuildRequires:  crossmingw32-glib2 >= 2.18.0
20 BuildRequires:  libtool >= 1:1.4.2-9
21 BuildRequires:  perl-base
22 BuildRequires:  pkgconfig >= 1:0.15
23 BuildRequires:  rpmbuild(macros) >= 1.197
24 Requires:       crossmingw32-cairo >= 1.8.0
25 Requires:       crossmingw32-fontconfig >= 2.4.0
26 Requires:       crossmingw32-freetype >= 2.1.7
27 Requires:       crossmingw32-glib2 >= 2.18.0
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         no_install_post_strip   1
31
32 %define         target                  i386-mingw32
33 %define         target_platform         i386-pc-mingw32
34
35 %define         _sysprefix              /usr
36 %define         _prefix                 %{_sysprefix}/%{target}
37 %define         _libdir                 %{_prefix}/lib
38 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
39 %define         _dlldir                 /usr/share/wine/windows/system
40 %define         __cc                    %{target}-gcc
41 %define         __cxx                   %{target}-g++
42
43 %ifnarch %{ix86}
44 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
45 %define         optflags        -O2
46 %endif
47 # -z options are invalid for mingw linker
48 %define         filterout_ld    -Wl,-z,.*
49
50 %description
51 System for layout and rendering of internationalized text (cross
52 mingw32 version).
53
54 %description -l pl.UTF-8
55 System obsługi i renderowania międzynarodowego tekstu (wersja skrośna
56 mingw32).
57
58 %package dll
59 Summary:        DLL pango libraries for Windows
60 Summary(pl.UTF-8):      Biblioteki DLL pango dla Windows
61 Group:          Applications/Emulators
62 Requires:       crossmingw32-cairo-dll >= 1.8.0
63 Requires:       crossmingw32-fontconfig-dll >= 2.4.0
64 Requires:       crossmingw32-freetype-dll >= 2.1.7
65 Requires:       crossmingw32-glib2-dll >= 2.18.0
66 Requires:       wine
67
68 %description dll
69 DLL pango libraries for Windows.
70
71 %description dll -l pl.UTF-8
72 Biblioteki DLL pango dla Windows.
73
74 %prep
75 %setup -q -n %{realname}-%{version}
76 %patch0 -p1
77
78 %build
79 export PKG_CONFIG_LIBDIR=%{_pkgconfigdir}
80 %{__libtoolize}
81 %{__aclocal}
82 %{__autoheader}
83 %{__autoconf}
84 %{__automake}
85 %configure \
86         --target=%{target} \
87         --host=%{target}
88
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 # missing from make install but required by it
95 install -d $RPM_BUILD_ROOT%{_sysconfdir}/pango
96
97 %{__make} -j1 install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 install -d $RPM_BUILD_ROOT%{_dlldir}
101 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
102
103 %if 0%{!?debug:1}
104 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
105 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
106 %endif
107
108 rm -rf $RPM_BUILD_ROOT%{_datadir}/{gtk-doc,man}
109 # useless (modules loaded through libgmodule)
110 rm -f $RPM_BUILD_ROOT%{_libdir}/pango/1.6.0/modules/*.{la,a}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %files
116 %defattr(644,root,root,755)
117 %doc AUTHORS NEWS README
118 %{_libdir}/libpango-1.0.dll.a
119 %{_libdir}/libpangocairo-1.0.dll.a
120 %{_libdir}/libpangoft2-1.0.dll.a
121 %{_libdir}/libpangowin32-1.0.dll.a
122 %{_libdir}/libpango-1.0.la
123 %{_libdir}/libpangocairo-1.0.la
124 %{_libdir}/libpangoft2-1.0.la
125 %{_libdir}/libpangowin32-1.0.la
126 %{_libdir}/pango-1.0.def
127 %{_libdir}/pangocairo-1.0.def
128 %{_libdir}/pangoft2-1.0.def
129 %{_libdir}/pangowin32-1.0.def
130 %{_includedir}/pango-1.0
131 %{_pkgconfigdir}/pango.pc
132 %{_pkgconfigdir}/pangocairo.pc
133 %{_pkgconfigdir}/pangoft2.pc
134 %{_pkgconfigdir}/pangowin32.pc
135
136 %files dll
137 %defattr(644,root,root,755)
138 %{_dlldir}/libpango-1.0-*.dll
139 %{_dlldir}/libpangocairo-1.0-*.dll
140 %{_dlldir}/libpangoft2-1.0-*.dll
141 %{_dlldir}/libpangowin32-1.0-*.dll
This page took 0.216953 seconds and 3 git commands to generate.