]> git.pld-linux.org Git - packages/crossmingw32-pango.git/blob - crossmingw32-pango.spec
- updated to 1.40.1
[packages/crossmingw32-pango.git] / crossmingw32-pango.spec
1 Summary:        System for layout and rendering of internationalized text - cross MinGW32 version
2 Summary(pl.UTF-8):      System renderowania międzynarodowego tekstu - wersja skrośna dla MinGW32
3 %define         realname   pango
4 Name:           crossmingw32-%{realname}
5 Version:        1.40.1
6 Release:        1
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/pango/1.40/%{realname}-%{version}.tar.xz
10 # Source0-md5:  6fc88c6529890d6c8e03074d57a3eceb
11 URL:            http://www.pango.org/
12 BuildRequires:  autoconf >= 2.59-9
13 BuildRequires:  automake >= 1:1.9
14 # cairo-ft cairo-pdf cairo-png cairo-ps cairo-win32
15 BuildRequires:  crossmingw32-cairo >= 1.12.10
16 BuildRequires:  crossmingw32-fontconfig >= 2.10.91
17 BuildRequires:  crossmingw32-freetype >= 2.1.7
18 BuildRequires:  crossmingw32-gcc
19 BuildRequires:  crossmingw32-glib2 >= 2.34.0
20 BuildRequires:  crossmingw32-harfbuzz >= 0.9.30
21 BuildRequires:  libtool >= 1:1.4.2-9
22 BuildRequires:  perl-base
23 BuildRequires:  pkgconfig >= 1:0.15
24 BuildRequires:  rpmbuild(macros) >= 1.197
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  xz
27 Requires:       crossmingw32-cairo >= 1.12.10
28 Requires:       crossmingw32-fontconfig >= 2.10.91
29 Requires:       crossmingw32-freetype >= 2.1.7
30 Requires:       crossmingw32-glib2 >= 2.34.0
31 Requires:       crossmingw32-harfbuzz >= 0.9.30
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         no_install_post_strip   1
35
36 %define         target                  i386-mingw32
37 %define         target_platform         i386-pc-mingw32
38
39 %define         _sysprefix              /usr
40 %define         _prefix                 %{_sysprefix}/%{target}
41 %define         _libdir                 %{_prefix}/lib
42 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
43 %define         _dlldir                 /usr/share/wine/windows/system
44 %define         __cc                    %{target}-gcc
45 %define         __cxx                   %{target}-g++
46 %define         __pkgconfig_provides    %{nil}
47 %define         __pkgconfig_requires    %{nil}
48
49 %define         _ssp_cflags             %{nil}
50 %ifnarch %{ix86}
51 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
52 %define         optflags        -O2
53 %endif
54 # -z options are invalid for mingw linker, most of -f options are Linux-specific
55 %define         filterout_ld    -Wl,-z,.*
56 %define         filterout_c     -f[-a-z0-9=]*
57
58 %description
59 System for layout and rendering of internationalized text (cross
60 MinGW32 version).
61
62 %description -l pl.UTF-8
63 System obsługi i renderowania międzynarodowego tekstu (wersja skrośna
64 MinGW32).
65
66 %package dll
67 Summary:        DLL pango libraries for Windows
68 Summary(pl.UTF-8):      Biblioteki DLL pango dla Windows
69 Group:          Applications/Emulators
70 Requires:       crossmingw32-cairo-dll >= 1.12.10
71 Requires:       crossmingw32-fontconfig-dll >= 2.10.91
72 Requires:       crossmingw32-freetype-dll >= 2.1.7
73 Requires:       crossmingw32-glib2-dll >= 2.34.0
74 Requires:       crossmingw32-harfbuzz-dll >= 0.9.30
75 Requires:       wine
76
77 %description dll
78 DLL pango libraries for Windows.
79
80 %description dll -l pl.UTF-8
81 Biblioteki DLL pango dla Windows.
82
83 %prep
84 %setup -q -n %{realname}-%{version}
85
86 %build
87 export PKG_CONFIG_LIBDIR=%{_pkgconfigdir}
88 %{__libtoolize}
89 %{__aclocal}
90 %{__autoheader}
91 %{__autoconf}
92 %{__automake}
93 %configure \
94         --target=%{target} \
95         --host=%{target} \
96         --disable-silent-rules
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} -j1 install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 install -d $RPM_BUILD_ROOT%{_dlldir}
107 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
108
109 # omitted from make install
110 for f in pango pangocairo pangoft2 pangowin32 ; do
111         cp -p pango/${f}.def $RPM_BUILD_ROOT%{_libdir}/${f}-1.0.def
112 done
113
114 %if 0%{!?debug:1}
115 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
116 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
117 %endif
118
119 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{gtk-doc,man}
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files
125 %defattr(644,root,root,755)
126 %doc AUTHORS NEWS README
127 %{_libdir}/libpango-1.0.dll.a
128 %{_libdir}/libpangocairo-1.0.dll.a
129 %{_libdir}/libpangoft2-1.0.dll.a
130 %{_libdir}/libpangowin32-1.0.dll.a
131 %{_libdir}/libpango-1.0.la
132 %{_libdir}/libpangocairo-1.0.la
133 %{_libdir}/libpangoft2-1.0.la
134 %{_libdir}/libpangowin32-1.0.la
135 %{_libdir}/pango-1.0.def
136 %{_libdir}/pangocairo-1.0.def
137 %{_libdir}/pangoft2-1.0.def
138 %{_libdir}/pangowin32-1.0.def
139 %{_includedir}/pango-1.0
140 %{_pkgconfigdir}/pango.pc
141 %{_pkgconfigdir}/pangocairo.pc
142 %{_pkgconfigdir}/pangoft2.pc
143 %{_pkgconfigdir}/pangowin32.pc
144
145 %files dll
146 %defattr(644,root,root,755)
147 %{_dlldir}/libpango-1.0-*.dll
148 %{_dlldir}/libpangocairo-1.0-*.dll
149 %{_dlldir}/libpangoft2-1.0-*.dll
150 %{_dlldir}/libpangowin32-1.0-*.dll
This page took 0.225013 seconds and 3 git commands to generate.