]> git.pld-linux.org Git - packages/crossmingw32-pango.git/blob - crossmingw32-pango.spec
- updated to 1.30.1
[packages/crossmingw32-pango.git] / crossmingw32-pango.spec
1 Summary:        System for layout and rendering of internationalized text - cross MinGW32 version
2 Summary(pl.UTF-8):      System renderowania międzynarodowego tekstu - wersja skrośna dla MinGW32
3 %define         realname   pango
4 Name:           crossmingw32-%{realname}
5 Version:        1.30.1
6 Release:        1
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/pango/1.30/%{realname}-%{version}.tar.xz
10 # Source0-md5:  ec3c1f236ee9bd4a982a5f46fcaff7b9
11 Patch0:         %{realname}-xfonts.patch
12 URL:            http://www.pango.org/
13 BuildRequires:  autoconf >= 2.59-9
14 BuildRequires:  automake >= 1:1.9
15 BuildRequires:  crossmingw32-cairo >= 1.8.0
16 BuildRequires:  crossmingw32-fontconfig >= 2.5.0
17 BuildRequires:  crossmingw32-freetype >= 2.1.7
18 BuildRequires:  crossmingw32-gcc
19 # opentype code uses C++ (but no STL)
20 BuildRequires:  crossmingw32-gcc-c++
21 BuildRequires:  crossmingw32-glib2 >= 2.32.0
22 BuildRequires:  libtool >= 1:1.4.2-9
23 BuildRequires:  perl-base
24 BuildRequires:  pkgconfig >= 1:0.15
25 BuildRequires:  rpmbuild(macros) >= 1.197
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 Requires:       crossmingw32-cairo >= 1.8.0
29 Requires:       crossmingw32-fontconfig >= 2.5.0
30 Requires:       crossmingw32-freetype >= 2.1.7
31 Requires:       crossmingw32-glib2 >= 2.32.0
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         no_install_post_strip   1
35
36 %define         target                  i386-mingw32
37 %define         target_platform         i386-pc-mingw32
38
39 %define         _sysprefix              /usr
40 %define         _prefix                 %{_sysprefix}/%{target}
41 %define         _libdir                 %{_prefix}/lib
42 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
43 %define         _dlldir                 /usr/share/wine/windows/system
44 %define         __cc                    %{target}-gcc
45 %define         __cxx                   %{target}-g++
46
47 %ifnarch %{ix86}
48 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
49 %define         optflags        -O2
50 %endif
51 # -z options are invalid for mingw linker
52 %define         filterout_ld    -Wl,-z,.*
53
54 %description
55 System for layout and rendering of internationalized text (cross
56 MinGW32 version).
57
58 %description -l pl.UTF-8
59 System obsługi i renderowania międzynarodowego tekstu (wersja skrośna
60 MinGW32).
61
62 %package dll
63 Summary:        DLL pango libraries for Windows
64 Summary(pl.UTF-8):      Biblioteki DLL pango dla Windows
65 Group:          Applications/Emulators
66 Requires:       crossmingw32-cairo-dll >= 1.8.0
67 Requires:       crossmingw32-fontconfig-dll >= 2.5.0
68 Requires:       crossmingw32-freetype-dll >= 2.1.7
69 Requires:       crossmingw32-glib2-dll >= 2.32.0
70 Requires:       wine
71
72 %description dll
73 DLL pango libraries for Windows.
74
75 %description dll -l pl.UTF-8
76 Biblioteki DLL pango dla Windows.
77
78 %prep
79 %setup -q -n %{realname}-%{version}
80 %patch0 -p1
81
82 %build
83 export PKG_CONFIG_LIBDIR=%{_pkgconfigdir}
84 %{__libtoolize}
85 %{__aclocal}
86 %{__autoheader}
87 %{__autoconf}
88 %{__automake}
89 %configure \
90         --target=%{target} \
91         --host=%{target} \
92         --disable-silent-rules
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 # missing from make install but required by it
100 install -d $RPM_BUILD_ROOT%{_sysconfdir}/pango
101
102 %{__make} -j1 install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 install -d $RPM_BUILD_ROOT%{_dlldir}
106 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
107
108 %if 0%{!?debug:1}
109 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
110 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
111 %endif
112
113 rm -rf $RPM_BUILD_ROOT%{_datadir}/{gtk-doc,man}
114 # useless (modules loaded through libgmodule)
115 rm -f $RPM_BUILD_ROOT%{_libdir}/pango/1.6.0/modules/*.{la,a}
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files
121 %defattr(644,root,root,755)
122 %doc AUTHORS NEWS README
123 %{_libdir}/libpango-1.0.dll.a
124 %{_libdir}/libpangocairo-1.0.dll.a
125 %{_libdir}/libpangoft2-1.0.dll.a
126 %{_libdir}/libpangowin32-1.0.dll.a
127 %{_libdir}/libpango-1.0.la
128 %{_libdir}/libpangocairo-1.0.la
129 %{_libdir}/libpangoft2-1.0.la
130 %{_libdir}/libpangowin32-1.0.la
131 %{_libdir}/pango-1.0.def
132 %{_libdir}/pangocairo-1.0.def
133 %{_libdir}/pangoft2-1.0.def
134 %{_libdir}/pangowin32-1.0.def
135 %{_includedir}/pango-1.0
136 %{_pkgconfigdir}/pango.pc
137 %{_pkgconfigdir}/pangocairo.pc
138 %{_pkgconfigdir}/pangoft2.pc
139 %{_pkgconfigdir}/pangowin32.pc
140
141 %files dll
142 %defattr(644,root,root,755)
143 %{_dlldir}/libpango-1.0-*.dll
144 %{_dlldir}/libpangocairo-1.0-*.dll
145 %{_dlldir}/libpangoft2-1.0-*.dll
146 %{_dlldir}/libpangowin32-1.0-*.dll
147 %dir %{_libdir}/pango
148 %dir %{_libdir}/pango/1.6.0
149 %dir %{_libdir}/pango/1.6.0/modules
150 %{_libdir}/pango/1.6.0/modules/*.dll
This page took 0.033109 seconds and 3 git commands to generate.