]> git.pld-linux.org Git - packages/crossmingw32-pango.git/blob - crossmingw32-pango.spec
- added x32 patch, release 2
[packages/crossmingw32-pango.git] / crossmingw32-pango.spec
1 Summary:        System for layout and rendering of internationalized text - cross MinGW32 version
2 Summary(pl.UTF-8):      System renderowania międzynarodowego tekstu - wersja skrośna dla MinGW32
3 %define         realname   pango
4 Name:           crossmingw32-%{realname}
5 Version:        1.50.0
6 Release:        2
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        https://download.gnome.org/sources/pango/1.50/%{realname}-%{version}.tar.xz
10 # Source0-md5:  726a7c7b6faf34006d2b5aa0dd8dc1d5
11 Patch0:         pango-x32.patch
12 URL:            https://pango.gnome.org/
13 # cairo-ft cairo-pdf cairo-png cairo-ps cairo-win32
14 BuildRequires:  crossmingw32-cairo >= 1.12.10
15 BuildRequires:  crossmingw32-fontconfig >= 2.13.0
16 BuildRequires:  crossmingw32-freetype >= 2.1.7
17 BuildRequires:  crossmingw32-fribidi >= 1.0.6
18 BuildRequires:  crossmingw32-gcc
19 # when supported by our mingw32
20 #BuildRequires: crossmingw32-glib2 >= 2.68.0
21 BuildRequires:  crossmingw32-glib2 >= 2.62
22 BuildRequires:  crossmingw32-harfbuzz >= 2.6.0
23 BuildRequires:  crossmingw32-w32api >= 5.0.2-6
24 # glib-genmarshal, glib-mkenums
25 BuildRequires:  glib2-devel >= 1:2.68.0
26 BuildRequires:  meson >= 0.55.3
27 BuildRequires:  ninja >= 1.5
28 BuildRequires:  perl-base
29 BuildRequires:  pkgconfig >= 1:0.15
30 BuildRequires:  rpmbuild(macros) >= 1.736
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  xz
33 Requires:       crossmingw32-cairo >= 1.12.10
34 Requires:       crossmingw32-fontconfig >= 2.13.0
35 Requires:       crossmingw32-freetype >= 2.1.7
36 Requires:       crossmingw32-fribidi >= 1.0.6
37 #Requires:      crossmingw32-glib2 >= 2.68.0
38 Requires:       crossmingw32-glib2 >= 2.62
39 Requires:       crossmingw32-harfbuzz >= 2.6.0
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         no_install_post_strip   1
43 %define         _enable_debug_packages  0
44
45 %define         target                  i386-mingw32
46 %define         target_platform         i386-pc-mingw32
47
48 %define         _sysprefix              /usr
49 %define         _prefix                 %{_sysprefix}/%{target}
50 %define         _libdir                 %{_prefix}/lib
51 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
52 %define         _dlldir                 /usr/share/wine/windows/system
53 %define         __pkgconfig_provides    %{nil}
54 %define         __pkgconfig_requires    %{nil}
55 # for meson 0.50+, keep __cc/__cxx as host compiler and pass %{target}-* in meson-cross.txt
56
57 %define         _ssp_cflags             %{nil}
58 %ifnarch %{ix86}
59 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
60 %define         optflags        -O2
61 %endif
62 # -z options are invalid for mingw linker, most of -f options are Linux-specific
63 %define         filterout_ld    -Wl,-z,.*
64 %define         filterout_c     -f[-a-z0-9=]*
65
66 %description
67 System for layout and rendering of internationalized text (cross
68 MinGW32 version).
69
70 %description -l pl.UTF-8
71 System obsługi i renderowania międzynarodowego tekstu (wersja skrośna
72 MinGW32).
73
74 %package static
75 Summary:        Static Pango libraries (cross MinGW32 version)
76 Summary(pl.UTF-8):      Statyczne biblioteki Pango (wersja skrośna MinGW32)
77 Group:          Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79
80 %description static
81 Static Pango libraries (cross MinGW32 version).
82
83 %description static -l pl.UTF-8
84 Statyczne biblioteki Pango (wersja skrośna MinGW32).
85
86 %package dll
87 Summary:        DLL pango libraries for Windows
88 Summary(pl.UTF-8):      Biblioteki DLL pango dla Windows
89 Group:          Applications/Emulators
90 Requires:       crossmingw32-cairo-dll >= 1.12.10
91 Requires:       crossmingw32-fontconfig-dll >= 2.13.0
92 Requires:       crossmingw32-freetype-dll >= 2.1.7
93 Requires:       crossmingw32-fribidi-dll >= 1.0.6
94 #Requires:      crossmingw32-glib2-dll >= 2.68.0
95 Requires:       crossmingw32-glib2-dll >= 2.62
96 Requires:       crossmingw32-harfbuzz-dll >= 2.6.0
97 Requires:       wine
98
99 %description dll
100 DLL pango libraries for Windows.
101
102 %description dll -l pl.UTF-8
103 Biblioteki DLL pango dla Windows.
104
105 %prep
106 %setup -q -n %{realname}-%{version}
107 %patch0 -p1
108
109 # disable unused gi-docgen subproject
110 %{__sed} -i -e '/fallback:.*gi-docgen/d' meson.build
111
112 cat > meson-cross.txt <<'EOF'
113 [host_machine]
114 system = 'windows'
115 cpu_family = 'x86'
116 cpu = 'i386'
117 endian='little'
118 [binaries]
119 c = '%{target}-gcc'
120 cpp = '%{target}-g++'
121 ar = '%{target}-ar'
122 windres = '%{target}-windres'
123 pkgconfig = 'pkg-config'
124 [properties]
125 c_args = ['%(echo %{rpmcflags} | sed -e "s/ \+/ /g;s/ /', '/g")', '-DWINVER=0x0600']
126 EOF
127
128 %build
129 export PKG_CONFIG_LIBDIR=%{_pkgconfigdir}
130 %meson build \
131         --cross-file meson-cross.txt \
132         %{?debug:--debug} \
133         -Dgtk_doc=false \
134         -Dintrospection=disabled
135
136 %ninja_build -C build
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %ninja_install -C build
142
143 install -d $RPM_BUILD_ROOT%{_dlldir}
144 %{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
145
146 %if 0%{!?debug:1}
147 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
148 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
149 %endif
150
151 %{__rm} $RPM_BUILD_ROOT%{_bindir}/pango-{list,segmentation,view}.exe
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %files
157 %defattr(644,root,root,755)
158 %doc NEWS README.md README.win32 THANKS
159 %{_libdir}/libpango-1.0.dll.a
160 %{_libdir}/libpangocairo-1.0.dll.a
161 %{_libdir}/libpangoft2-1.0.dll.a
162 %{_libdir}/libpangowin32-1.0.dll.a
163 %{_includedir}/pango-1.0
164 %{_pkgconfigdir}/pango.pc
165 %{_pkgconfigdir}/pangocairo.pc
166 %{_pkgconfigdir}/pangofc.pc
167 %{_pkgconfigdir}/pangoft2.pc
168 %{_pkgconfigdir}/pangoot.pc
169 %{_pkgconfigdir}/pangowin32.pc
170
171 %files static
172 %defattr(644,root,root,755)
173 %{_libdir}/libpango-1.0.a
174 %{_libdir}/libpangocairo-1.0.a
175 %{_libdir}/libpangoft2-1.0.a
176 %{_libdir}/libpangowin32-1.0.a
177
178 %files dll
179 %defattr(644,root,root,755)
180 %{_dlldir}/libpango-1.0-0.dll
181 %{_dlldir}/libpangocairo-1.0-0.dll
182 %{_dlldir}/libpangoft2-1.0-0.dll
183 %{_dlldir}/libpangowin32-1.0-0.dll
This page took 0.070989 seconds and 3 git commands to generate.