]> git.pld-linux.org Git - packages/crossmingw32-libwebp.git/blob - crossmingw32-libwebp.spec
- updated to 1.4.0
[packages/crossmingw32-libwebp.git] / crossmingw32-libwebp.spec
1 Summary:        WebP image codec libraries - cross MinGW32 version
2 Summary(pl.UTF-8):      Biblioteki do kodeka obrazów WebP - wersja skrośna MinGW32
3 Name:           crossmingw32-libwebp
4 Version:        1.4.0
5 Release:        1
6 License:        BSD
7 Group:          Development/Libraries
8 #Source0Download: http://downloads.webmproject.org/releases/webp/index.html
9 Source0:        http://downloads.webmproject.org/releases/webp/libwebp-%{version}.tar.gz
10 # Source0-md5:  07daaa13bef03b7be07f11977b159cb8
11 URL:            https://developers.google.com/speed/webp/
12 BuildRequires:  autoconf >= 2.60
13 BuildRequires:  automake
14 BuildRequires:  crossmingw32-gcc
15 BuildRequires:  libtool >= 2:2.2
16 BuildRequires:  rpmbuild(macros) >= 1.197
17 BuildRequires:  sed >= 4.0
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         no_install_post_strip   1
21 %define         _enable_debug_packages  0
22
23 %define         target                  i386-mingw32
24 %define         target_platform         i386-pc-mingw32
25
26 %define         _sysprefix              /usr
27 %define         _prefix                 %{_sysprefix}/%{target}
28 %define         _libdir                 %{_prefix}/lib
29 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
30 %define         _dlldir                 /usr/share/wine/windows/system
31 %define         __cc                    %{target}-gcc
32 %define         __cxx                   %{target}-g++
33 %define         __pkgconfig_provides    %{nil}
34 %define         __pkgconfig_requires    %{nil}
35
36 %ifnarch %{ix86}
37 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
38 %define         optflags        -O2
39 %endif
40 # -z options are invalid for mingw linker, most of -f options are Linux-specific
41 %define         filterout_ld    -Wl,-z,.*
42 %define         filterout_c     -f[-a-z0-9=]*
43
44 %description
45 WebP image codec libraries.
46
47 This package contains the cross version for Win32.
48
49 %description -l pl.UTF-8
50 Biblioteki kodeka obrazów WebP.
51
52 Ten pakiet zawiera wersję skrośną dla Win32.
53
54 %package static
55 Summary:        Static WebP libraries (cross MinGW32 version)
56 Summary(pl.UTF-8):      Statyczne biblioteki WebP (wersja skrośna MinGW32)
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59
60 %description static
61 Static WebP libraries (cross MinGW32 version).
62
63 %description static -l pl.UTF-8
64 Statyczne biblioteki WebP (wersja skrośna MinGW32).
65
66 %package dll
67 Summary:        DLL WebP libraries for Windows
68 Summary(pl.UTF-8):      Biblioteki DLL WebP dla Windows
69 Group:          Applications/Emulators
70 Requires:       wine
71
72 %description dll
73 DLL WebP libraries for Windows.
74
75 %description dll -l pl.UTF-8
76 Biblioteki DLL WebP dla Windows.
77
78 %prep
79 %setup -q -n libwebp-%{version}
80
81 sed -i -e 's/libwebp_la_LDFLAGS.*/& -no-undefined/' src/Makefile.am
82
83 %build
84 %{__libtoolize}
85 %{__aclocal} -I m4
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90         --target=%{target} \
91         --host=%{target} \
92         --disable-silent-rules \
93         --enable-libwebpdemux \
94         --enable-libwebpmux
95
96 # only chosen dirs to get just the library, no utils
97 %{__make} -C sharpyuv
98 %{__make} -C src
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} -C sharpyuv install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 %{__make} -C src install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 install -d $RPM_BUILD_ROOT%{_dlldir}
110 %{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
111
112 %if 0%{!?debug:1}
113 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
114 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
115 %endif
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files
121 %defattr(644,root,root,755)
122 %doc AUTHORS COPYING ChangeLog NEWS PATENTS README.md
123 %{_libdir}/libsharpyuv.dll.a
124 %{_libdir}/libsharpyuv.la
125 %{_libdir}/libwebp.dll.a
126 %{_libdir}/libwebp.la
127 %{_libdir}/libwebpdemux.dll.a
128 %{_libdir}/libwebpdemux.la
129 %{_libdir}/libwebpmux.dll.a
130 %{_libdir}/libwebpmux.la
131 %{_includedir}/webp
132 %{_pkgconfigdir}/libsharpyuv.pc
133 %{_pkgconfigdir}/libwebp.pc
134 %{_pkgconfigdir}/libwebpdemux.pc
135 %{_pkgconfigdir}/libwebpmux.pc
136
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/libsharpyuv.a
140 %{_libdir}/libwebp.a
141 %{_libdir}/libwebpdemux.a
142 %{_libdir}/libwebpmux.a
143
144 %files dll
145 %defattr(644,root,root,755)
146 %{_dlldir}/libsharpyuv-0.dll
147 %{_dlldir}/libwebp-7.dll
148 %{_dlldir}/libwebpmux-3.dll
149 %{_dlldir}/libwebpdemux-2.dll
This page took 0.174481 seconds and 4 git commands to generate.