]> git.pld-linux.org Git - packages/crossmingw32-libvorbis.git/blob - crossmingw32-libvorbis.spec
- updated to 1.3.2
[packages/crossmingw32-libvorbis.git] / crossmingw32-libvorbis.spec
1 %define         realname        libvorbis
2 Summary:        The Vorbis General Audio Compression Codec - MinGW32 cross version
3 Summary(pl.UTF-8):      Kodek kompresji audio - Vorbis - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        1.3.2
6 Release:        1
7 License:        BSD
8 Group:          Libraries
9 Source0:        http://downloads.xiph.org/releases/vorbis/%{realname}-%{version}.tar.xz
10 # Source0-md5:  3067484a544115257beec616a696c5b3
11 Patch0:         %{realname}-ac_fixes.patch
12 Patch1:         %{realname}-make.patch
13 URL:            http://www.vorbis.com/
14 BuildRequires:  autoconf >= 2.50
15 BuildRequires:  automake >= 1:1.6
16 BuildRequires:  crossmingw32-gcc >= 3.0
17 BuildRequires:  crossmingw32-libogg >= 1.0
18 BuildRequires:  crossmingw32-w32api
19 BuildRequires:  libtool
20 BuildRequires:  pkgconfig >= 1:0.15
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 Requires:       crossmingw32-libogg >= 1.0
24 Requires:       crossmingw32-runtime
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         no_install_post_strip   1
28
29 %define         target                  i386-mingw32
30 %define         target_platform         %{target}
31
32 %define         _sysprefix              /usr
33 %define         _prefix                 %{_sysprefix}/%{target}
34 %define         _libdir                 %{_prefix}/lib
35 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
36 %define         _dlldir                 /usr/share/wine/windows/system
37 %define         __cc                    %{target}-gcc
38 %define         __cxx                   %{target}-g++
39
40 %ifnarch %{ix86}
41 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
42 %define         optflags        -O2
43 %endif
44 # -z options are invalid for mingw linker
45 %define         filterout_ld    -Wl,-z,.*
46
47 %description
48 Ogg Vorbis is a fully open, non-proprietary, patent-and-royalty-free,
49 general-purpose compressed audio format for audio and music at fixed
50 and variable bitrates from 16 to 128 kbps/channel.
51
52 This package contains the cross version for Win32.
53
54 %description -l pl.UTF-8
55 Ogg Vorbis jest całkowicie otwartym, nie będącym niczyją własnością,
56 wolnym od patentów, ogólnego przeznaczenia kodekiem audio i muzyki o
57 stałej i zmiennej bitrate od 16 do 128 kbps/kanał.
58
59 Ten pakiet zawiera wersję skrośną dla Win32.
60
61 %package static
62 Summary:        Static libvorbis library (cross MinGW32 version)
63 Summary(pl.UTF-8):      Statyczna biblioteka libvorbis (wersja skrośna MinGW32)
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66
67 %description static
68 Static libvorbis library (cross MinGW32 version).
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka libvorbis (wersja skrośna MinGW32).
72
73 %package dll
74 Summary:        DLL libvorbis library for Windows
75 Summary(pl.UTF-8):      Biblioteka DLL libvorbis dla Windows
76 Group:          Applications/Emulators
77 Requires:       crossmingw32-libogg-dll >= 1.0
78 Requires:       wine
79
80 %description dll
81 DLL libvorbis library for Windows.
82
83 %description dll -l pl.UTF-8
84 Biblioteka DLL libvorbis dla Windows.
85
86 %prep
87 %setup -q -n %{realname}-%{version}
88 %patch0 -p1
89 %patch1 -p1
90
91 %build
92 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
93 %{__libtoolize}
94 %{__aclocal} -I m4
95 %{__autoconf}
96 %{__autoheader}
97 %{__automake}
98 %configure \
99         OBJDUMP=%{target}-objdump \
100         --host=%{target} \
101         --target=%{target}
102
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 install -d $RPM_BUILD_ROOT%{_dlldir}
112 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
113
114 %if 0%{!?debug:1}
115 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
116 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
117 %endif
118
119 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{aclocal,doc}
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files
125 %defattr(644,root,root,755)
126 %doc AUTHORS CHANGES COPYING README
127 %{_libdir}/libvorbis.dll.a
128 %{_libdir}/libvorbisenc.dll.a
129 %{_libdir}/libvorbisfile.dll.a
130 %{_libdir}/libvorbis.la
131 %{_libdir}/libvorbisenc.la
132 %{_libdir}/libvorbisfile.la
133 %{_includedir}/vorbis
134 %{_pkgconfigdir}/vorbis.pc
135 %{_pkgconfigdir}/vorbisenc.pc
136 %{_pkgconfigdir}/vorbisfile.pc
137
138 %files static
139 %defattr(644,root,root,755)
140 %{_libdir}/libvorbis.a
141 %{_libdir}/libvorbisenc.a
142 %{_libdir}/libvorbisfile.a
143
144 %files dll
145 %defattr(644,root,root,755)
146 %{_dlldir}/libvorbis-*.dll
147 %{_dlldir}/libvorbisenc-*.dll
148 %{_dlldir}/libvorbisfile-*.dll
This page took 0.058608 seconds and 3 git commands to generate.