]> git.pld-linux.org Git - packages/crossmingw32-libvorbis.git/blob - crossmingw32-libvorbis.spec
- updated to 1.3.1
[packages/crossmingw32-libvorbis.git] / crossmingw32-libvorbis.spec
1 %define         realname        libvorbis
2 Summary:        The Vorbis General Audio Compression Codec - Mingw32 cross version
3 Summary(pl.UTF-8):      Kodek kompresji audio - Vorbis - wersja skrośna dla Mingw32
4 Name:           crossmingw32-%{realname}
5 Version:        1.3.1
6 Release:        1
7 License:        BSD
8 Group:          Libraries
9 Source0:        http://downloads.xiph.org/releases/vorbis/%{realname}-%{version}.tar.bz2
10 # Source0-md5:  90b1eb86e6d57694ffdfc2e4d8c7a64e
11 Patch0:         %{realname}-ac_fixes.patch
12 Patch1:         %{realname}-make.patch
13 URL:            http://www.vorbis.com/
14 BuildRequires:  crossmingw32-gcc >= 3.0
15 BuildRequires:  crossmingw32-libogg >= 1.0
16 BuildRequires:  crossmingw32-w32api
17 BuildRequires:  pkgconfig >= 1:0.15
18 Requires:       crossmingw32-libogg >= 1.0
19 Requires:       crossmingw32-runtime
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         no_install_post_strip   1
23
24 %define         target                  i386-mingw32
25 %define         target_platform         %{target}
26
27 %define         _sysprefix              /usr
28 %define         _prefix                 %{_sysprefix}/%{target}
29 %define         _libdir                 %{_prefix}/lib
30 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
31 %define         _dlldir                 /usr/share/wine/windows/system
32 %define         __cc                    %{target}-gcc
33 %define         __cxx                   %{target}-g++
34
35 %ifnarch %{ix86}
36 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
37 %define         optflags        -O2
38 %endif
39 # -z options are invalid for mingw linker
40 %define         filterout_ld    -Wl,-z,.*
41
42 %description
43 Ogg Vorbis is a fully open, non-proprietary, patent-and-royalty-free,
44 general-purpose compressed audio format for audio and music at fixed
45 and variable bitrates from 16 to 128 kbps/channel.
46
47 This package contains the cross version for Win32.
48
49 %description -l pl.UTF-8
50 Ogg Vorbis jest całkowicie otwartym, nie będącym niczyją własnością,
51 wolnym od patentów, ogólnego przeznaczenia kodekiem audio i muzyki o
52 stałej i zmiennej bitrate od 16 do 128 kbps/kanał.
53
54 Ten pakiet zawiera wersję skrośną dla Win32.
55
56 %package static
57 Summary:        Static libvorbis library (cross mingw32 version)
58 Summary(pl.UTF-8):      Statyczna biblioteka libvorbis (wersja skrośna mingw32)
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61
62 %description static
63 Static libvorbis library (cross mingw32 version).
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka libvorbis (wersja skrośna mingw32).
67
68 %package dll
69 Summary:        DLL libvorbis library for Windows
70 Summary(pl.UTF-8):      Biblioteka DLL libvorbis dla Windows
71 Group:          Applications/Emulators
72 Requires:       crossmingw32-libogg-dll >= 1.0
73 Requires:       wine
74
75 %description dll
76 DLL libvorbis library for Windows.
77
78 %description dll -l pl.UTF-8
79 Biblioteka DLL libvorbis dla Windows.
80
81 %prep
82 %setup -q -n %{realname}-%{version}
83 %patch0 -p1
84 %patch1 -p1
85
86 %build
87 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
88 %{__libtoolize}
89 %{__aclocal} -I m4
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93 %configure \
94         OBJDUMP=%{target}-objdump \
95         --host=%{target} \
96         --target=%{target}
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 install -d $RPM_BUILD_ROOT%{_dlldir}
107 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
108
109 %if 0%{!?debug:1}
110 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
111 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
112 %endif
113
114 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{aclocal,doc}
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %files
120 %defattr(644,root,root,755)
121 %doc AUTHORS CHANGES COPYING README
122 %{_libdir}/libvorbis.dll.a
123 %{_libdir}/libvorbisenc.dll.a
124 %{_libdir}/libvorbisfile.dll.a
125 %{_libdir}/libvorbis.la
126 %{_libdir}/libvorbisenc.la
127 %{_libdir}/libvorbisfile.la
128 %{_includedir}/vorbis
129 %{_pkgconfigdir}/vorbis.pc
130 %{_pkgconfigdir}/vorbisenc.pc
131 %{_pkgconfigdir}/vorbisfile.pc
132
133 %files static
134 %defattr(644,root,root,755)
135 %{_libdir}/libvorbis.a
136 %{_libdir}/libvorbisenc.a
137 %{_libdir}/libvorbisfile.a
138
139 %files dll
140 %defattr(644,root,root,755)
141 %{_dlldir}/libvorbis-*.dll
142 %{_dlldir}/libvorbisenc-*.dll
143 %{_dlldir}/libvorbisfile-*.dll
This page took 0.135377 seconds and 3 git commands to generate.