]> git.pld-linux.org Git - packages/crossmingw32-libsigc++.git/blob - crossmingw32-libsigc++.spec
- updated to 2.2.2
[packages/crossmingw32-libsigc++.git] / crossmingw32-libsigc++.spec
1 Summary:        The Typesafe Signal Framework for C++ - Mingw32 cross version
2 Summary(pl.UTF-8):      Środowisko sygnałów z kontrolą typów dla C++ - wersja skrośna dla Mingw32
3 %define         realname        libsigc++
4 Name:           crossmingw32-%{realname}
5 Version:        2.2.2
6 Release:        1
7 License:        LGPL v2.1+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.2/%{realname}-%{version}.tar.bz2
10 # Source0-md5:  962493fd6b26425f21504c3416c4efa1
11 URL:            http://libsigc.sourceforge.net/
12 BuildRequires:  autoconf >= 2.59
13 BuildRequires:  automake >= 1.9
14 BuildRequires:  crossmingw32-gcc-c++
15 BuildRequires:  libtool
16 BuildRequires:  m4
17 BuildRequires:  perl-base
18 Requires:       crossmingw32-runtime
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         no_install_post_strip   1
22
23 %define         target                  i386-mingw32
24 %define         target_platform         i386-pc-mingw32
25
26 %define         _sysprefix              /usr
27 %define         _prefix                 %{_sysprefix}/%{target}
28 %define         _libdir                 %{_prefix}/lib
29 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
30 %define         _dlldir                 /usr/share/wine/windows/system
31 %define         __cc                    %{target}-gcc
32 %define         __cxx                   %{target}-g++
33
34 %description
35 This library implements a full callback system for use in widget
36 libraries, abstract interfaces, and general programming. Originally
37 part of the Gtk-- widget set, libsigc++ is now a seperate library to
38 provide for more general use. It is the most complete library of its
39 kind with the ablity to connect an abstract callback to a class
40 method, function, or function object. It contains adaptor classes for
41 connection of dissimilar callbacks and has an ease of use unmatched by
42 other C++ callback libraries.
43
44 This package contains cross Mingw32 version.
45
46 %description -l pl.UTF-8
47 Ta biblioteka jest implementacją pełnego systemu callbacków do
48 używania w bibliotekach widgetów, interfejsach abstrakcyjnych i
49 ogólnym programowaniu. Oryginalnie była to część zestawu widgetów
50 Gtk--, ale jest teraz oddzielną biblioteką ogólniejszego
51 przeznaczenia. Jest to kompletna biblioteka tego typu z możliwością
52 łączenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
53 obiektami funkcji. Zawiera klasy adapterów do łączenia różnych
54 callbacków.
55
56 Ten pakiet zawiera wersję skrośną Mingw32.
57
58 %package static
59 Summary:        Static libsigc++ library (cross mingw32 version)
60 Summary(pl.UTF-8):      Statyczna biblioteka libsigc++ (wersja skrośna mingw32)
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63
64 %description static
65 Static libsigc++ library (cross mingw32 version).
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka libsigc++ (wersja skrośna mingw32).
69
70 %package dll
71 Summary:        DLL libsigc++ library for Windows
72 Summary(pl.UTF-8):      Biblioteka DLL libsigc++ dla Windows
73 Group:          Applications/Emulators
74 Requires:       wine
75
76 %description dll
77 DLL libsigc++ library for Windows.
78
79 %description dll -l pl.UTF-8
80 Biblioteka DLL libsigc++ dla Windows.
81
82 %prep
83 %setup -q -n %{realname}-%{version}
84
85 %build
86 %{__libtoolize}
87 %{__aclocal} -I scripts
88 %{__autoconf}
89 %{__automake}
90 %configure \
91         --target=%{target} \
92         --host=%{target} \
93         --enable-shared \
94         --enable-static
95
96 %{__make} all
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 install -d $RPM_BUILD_ROOT%{_dlldir}
105 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
106
107 %if 0%{!?debug:1}
108 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
109 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
110 %endif
111
112 rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS ChangeLog NEWS README TODO
120 %{_libdir}/libsigc-2.0.dll.a
121 %{_libdir}/libsigc-2.0.la
122 %{_libdir}/sigc++-2.0
123 %{_includedir}/sigc++-2.0
124 %{_pkgconfigdir}/sigc++-2.0.pc
125
126 %files static
127 %defattr(644,root,root,755)
128 %{_libdir}/libsigc-2.0.a
129
130 %files dll
131 %defattr(644,root,root,755)
132 %{_dlldir}/libsigc-2.0-*.dll
This page took 0.548573 seconds and 3 git commands to generate.