]> git.pld-linux.org Git - packages/crossmingw32-libogg.git/blob - crossmingw32-libogg.spec
- unified MinGW32 caps
[packages/crossmingw32-libogg.git] / crossmingw32-libogg.spec
1 %define         realname        libogg
2 Summary:        Ogg Bitstream Library - MinGW32 cross version
3 Summary(pl.UTF-8):      Biblioteka obsługi strumieni bitowych Ogg - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        1.2.0
6 Release:        1
7 License:        BSD
8 Group:          Development/Libraries
9 Source0:        http://downloads.xiph.org/releases/ogg/%{realname}-%{version}.tar.gz
10 # Source0-md5:  c95b73759acfc30712beef6ce4e88efa
11 Patch0:         %{realname}-ac_fixes.patch
12 URL:            http://www.xiph.org/ogg/
13 BuildRequires:  crossmingw32-gcc
14 BuildRequires:  crossmingw32-w32api
15 Requires:       crossmingw32-runtime
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         no_install_post_strip   1
19
20 %define         target                  i386-mingw32
21 %define         target_platform         %{target}
22
23 %define         _sysprefix              /usr
24 %define         _prefix                 %{_sysprefix}/%{target}
25 %define         _libdir                 %{_prefix}/lib
26 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
27 %define         _dlldir                 /usr/share/wine/windows/system
28 %define         __cc                    %{target}-gcc
29 %define         __cxx                   %{target}-g++
30
31 %ifnarch %{ix86}
32 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
33 %define         optflags        -O2
34 %endif
35 # -z options are invalid for mingw linker
36 %define         filterout_ld    -Wl,-z,.*
37
38 %description
39 Libogg is a library for manipulating Ogg bitstreams. It handles both
40 making Ogg bitstreams and getting packets from Ogg bitstreams.
41
42 This package contains the cross version for Win32.
43
44 %description -l pl.UTF-8
45 Libogg jest biblioteką do manipulacji strumieniami bitowymi Ogg.
46 Obsługuje ona zarówno tworzenie strumieni jak i uzyskiwanie pakietów
47 ze strumieni.
48
49 Ten pakiet zawiera wersję skrośną dla Win32.
50
51 %package static
52 Summary:        Static libogg library (cross MinGW32 version)
53 Summary(pl.UTF-8):      Statyczna biblioteka libogg (wersja skrośna MinGW32)
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56
57 %description static
58 Static libogg library (cross MinGW32 version).
59
60 %description static -l pl.UTF-8
61 Statyczna biblioteka libogg (wersja skrośna MinGW32).
62
63 %package dll
64 Summary:        DLL libogg library for Windows
65 Summary(pl.UTF-8):      Biblioteka DLL libogg dla Windows
66 Group:          Applications/Emulators
67 Requires:       wine
68
69 %description dll
70 DLL libogg library for Windows.
71
72 %description dll -l pl.UTF-8
73 Biblioteka DLL libogg dla Windows.
74
75 %prep
76 %setup -q -n %{realname}-%{version}
77 %patch0 -p1
78
79 %build
80 %configure \
81         --host=%{target} \
82         --target=%{target}
83
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 install -d $RPM_BUILD_ROOT%{_dlldir}
93 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
94
95 %if 0%{!?debug:1}
96 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
97 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
98 %endif
99
100 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{aclocal,doc}
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %files
106 %defattr(644,root,root,755)
107 %doc AUTHORS CHANGES COPYING README
108 %{_libdir}/libogg.dll.a
109 %{_libdir}/libogg.la
110 %{_includedir}/ogg
111 %{_pkgconfigdir}/ogg.pc
112
113 %files static
114 %defattr(644,root,root,755)
115 %{_libdir}/libogg.a
116
117 %files dll
118 %defattr(644,root,root,755)
119 %{_dlldir}/libogg-*.dll
This page took 0.079694 seconds and 3 git commands to generate.