]> git.pld-linux.org Git - packages/crossmingw32-libffi.git/blob - crossmingw32-libffi.spec
- updated to 3.3, disable debug packages
[packages/crossmingw32-libffi.git] / crossmingw32-libffi.spec
1 Summary:        Foreign Function Interface library (cross MinGW32 version)
2 Summary(pl.UTF-8):      Biblioteka Foreign Function Interface (wersja skrośna MinGW32)
3 Name:           crossmingw32-libffi
4 Version:        3.3
5 Release:        1
6 License:        MIT-like
7 Group:          Libraries
8 Source0:        ftp://sourceware.org/pub/libffi/libffi-%{version}.tar.gz
9 # Source0-md5:  6313289e32f1d38a9df4770b014a2ca7
10 URL:            http://www.sourceware.org/libffi/
11 BuildRequires:  texinfo
12 Requires:       crossmingw32-runtime
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         no_install_post_strip   1
16 %define         _enable_debug_packages  0
17
18 %define         target                  i386-mingw32
19 %define         target_platform         i386-pc-mingw32
20
21 %define         _sysprefix              /usr
22 %define         _prefix                 %{_sysprefix}/%{target}
23 %define         _libdir                 %{_prefix}/lib
24 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
25 %define         _dlldir                 /usr/share/wine/windows/system
26 %define         __cc                    %{target}-gcc
27 %define         __pkgconfig_provides    %{nil}
28 %define         __pkgconfig_requires    %{nil}
29
30 %ifnarch %{ix86}
31 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
32 %define         optflags        -O2
33 %endif
34 # -z options are invalid for mingw linker, most of -f options are Linux-specific
35 %define         filterout_ld    -Wl,-z,.*
36 %define         filterout_c     -f[-a-z0-9=]*
37
38 %description
39 The libffi library provides a portable, high level programming
40 interface to various calling conventions. This allows a programmer to
41 call any function specified by a call interface description at
42 run-time.
43
44 Ffi stands for Foreign Function Interface. A foreign function
45 interface is the popular name for the interface that allows code
46 written in one language to call code written in another language. The
47 libffi library really only provides the lowest, machine dependent
48 layer of a fully featured foreign function interface. A layer must
49 exist above libffi that handles type conversions for values passed
50 between the two languages.
51
52 This package contains the cross version for MinGW32.
53
54 %description -l pl.UTF-8
55 Biblioteka libffi dostarcza przenośny, wysokopoziomowy interfejs do
56 różnych konwencji wywołań funkcji. Pozwala to programiście wywołać
57 dowolną funkcję podaną przez opis interfejsu wywołania w czasie
58 działania programu.
59
60 FFI to skrót od Foreign Function Interface, czyli interfejsu do obcych
61 funkcji. Jest to potoczna nazwa interfejsu pozwalającego programowi
62 napisanemu w jednym języku wywoływać kod napisany w innym języku.
63 Biblioteka libffi daje tylko najniższą, zależną od maszyny warstwę
64 pełnego interfejsu. Potrzebne są wyższe warstwy do obsługi konwersji
65 typów dla wartości przekazywanych pomiędzy różnymi językami.
66
67 Ten pakiet zawiera wersję skrośną dla MinGW32.
68
69 %package static
70 Summary:        Static libffi library (cross MinGW32 version)
71 Summary(pl.UTF-8):      Statyczna biblioteka libffi (wersja skrośna MinGW32)
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74
75 %description static
76 Static libffi library (cross MinGW32 version).
77
78 %description static -l pl.UTF-8
79 Statyczna biblioteka libffi (wersja skrośna MinGW32).
80
81 %package dll
82 Summary:        Foreign Function Interface DLL library for Windows
83 Summary(pl.UTF-8):      Biblioteka DLL Foreign Function Interface dla Windows
84 Group:          Applications/Emulators
85 Requires:       wine
86
87 %description dll
88 Foreign Function Interface DLL library for Windows.
89
90 %description dll -l pl.UTF-8
91 Biblioteka DLL Foreign Function Interface dla Windows.
92
93 %prep
94 %setup -q -n libffi-%{version}
95
96 %build
97 %configure \
98         --target=%{target} \
99         --host=%{target}
100
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 install -d $RPM_BUILD_ROOT%{_dlldir}
110 %{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
111
112 %if 0%{!?debug:1}
113 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
114 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
115 %endif
116
117 %{__rm} -r $RPM_BUILD_ROOT{%{_mandir},%{_infodir}}
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 %defattr(644,root,root,755)
124 %doc ChangeLog* LICENSE README.md
125 %{_libdir}/libffi.dll.a
126 %{_libdir}/libffi.la
127 %{_includedir}/ffi.h
128 %{_includedir}/ffitarget.h
129 %{_pkgconfigdir}/libffi.pc
130
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/libffi.a
134
135 %files dll
136 %defattr(644,root,root,755)
137 %{_dlldir}/libffi-7.dll
This page took 0.075568 seconds and 4 git commands to generate.