]> git.pld-linux.org Git - packages/crossmingw32-libffi.git/blob - crossmingw32-libffi.spec
- updated to 3.0.12
[packages/crossmingw32-libffi.git] / crossmingw32-libffi.spec
1 Summary:        Foreign Function Interface library (cross MinGW32 version)
2 Summary(pl.UTF-8):      Biblioteka Foreign Function Interface (wersja skrośna MinGW32)
3 Name:           crossmingw32-libffi
4 Version:        3.0.12
5 Release:        1
6 License:        MIT-like
7 Group:          Libraries
8 Source0:        ftp://sourceware.org/pub/libffi/libffi-%{version}.tar.gz
9 # Source0-md5:  da984c6756170d50f47925bb333cda71
10 URL:            http://sources.redhat.com/libffi/
11 BuildRequires:  texinfo
12 Requires:       crossmingw32-runtime
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         no_install_post_strip   1
16
17 %define         target                  i386-mingw32
18 %define         target_platform         i386-pc-mingw32
19
20 %define         _sysprefix              /usr
21 %define         _prefix                 %{_sysprefix}/%{target}
22 %define         _libdir                 %{_prefix}/lib
23 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
24 %define         _dlldir                 /usr/share/wine/windows/system
25 %define         __cc                    %{target}-gcc
26
27 %ifnarch %{ix86}
28 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
29 %define         optflags        -O2
30 %endif
31 # -z options are invalid for mingw linker, most of -f options are Linux-specific
32 %define         filterout_ld    -Wl,-z,.*
33 %define         filterout_c     -f[-a-z0-9=]*
34
35 %description
36 The libffi library provides a portable, high level programming
37 interface to various calling conventions. This allows a programmer to
38 call any function specified by a call interface description at
39 run-time.
40
41 Ffi stands for Foreign Function Interface. A foreign function
42 interface is the popular name for the interface that allows code
43 written in one language to call code written in another language. The
44 libffi library really only provides the lowest, machine dependent
45 layer of a fully featured foreign function interface. A layer must
46 exist above libffi that handles type conversions for values passed
47 between the two languages.
48
49 This package contains the cross version for MinGW32.
50
51 %description -l pl.UTF-8
52 Biblioteka libffi dostarcza przenośny, wysokopoziomowy interfejs do
53 różnych konwencji wywołań funkcji. Pozwala to programiście wywołać
54 dowolną funkcję podaną przez opis interfejsu wywołania w czasie
55 działania programu.
56
57 FFI to skrót od Foreign Function Interface, czyli interfejsu do obcych
58 funkcji. Jest to potoczna nazwa interfejsu pozwalającego programowi
59 napisanemu w jednym języku wywoływać kod napisany w innym języku.
60 Biblioteka libffi daje tylko najniższą, zależną od maszyny warstwę
61 pełnego interfejsu. Potrzebne są wyższe warstwy do obsługi konwersji
62 typów dla wartości przekazywanych pomiędzy różnymi językami.
63
64 Ten pakiet zawiera wersję skrośną dla MinGW32.
65
66 %package static
67 Summary:        Static libffi library (cross MinGW32 version)
68 Summary(pl.UTF-8):      Statyczna biblioteka libffi (wersja skrośna MinGW32)
69 Group:          Development/Libraries
70 Requires:       %{name} = %{version}-%{release}
71
72 %description static
73 Static libffi library (cross MinGW32 version).
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka libffi (wersja skrośna MinGW32).
77
78 %package dll
79 Summary:        Foreign Function Interface DLL library for Windows
80 Summary(pl.UTF-8):      Biblioteka DLL Foreign Function Interface dla Windows
81 Group:          Applications/Emulators
82 Requires:       wine
83
84 %description dll
85 Foreign Function Interface DLL library for Windows.
86
87 %description dll -l pl.UTF-8
88 Biblioteka DLL Foreign Function Interface dla Windows.
89
90 %prep
91 %setup -q -n libffi-%{version}
92
93 %build
94 %configure \
95         --target=%{target} \
96         --host=%{target}
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 install -d $RPM_BUILD_ROOT%{_dlldir}
107 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
108
109 %if 0%{!?debug:1}
110 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
111 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
112 %endif
113
114 %{__rm} -r $RPM_BUILD_ROOT{%{_mandir},%{_infodir}}
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %files
120 %defattr(644,root,root,755)
121 %doc ChangeLog* LICENSE README
122 %{_libdir}/libffi.dll.a
123 %{_libdir}/libffi.la
124 %{_libdir}/libffi-%{version}
125 %{_pkgconfigdir}/libffi.pc
126
127 %files static
128 %defattr(644,root,root,755)
129 %{_libdir}/libffi.a
130
131 %files dll
132 %defattr(644,root,root,755)
133 %{_dlldir}/libffi-6.dll
This page took 0.062478 seconds and 4 git commands to generate.