]> git.pld-linux.org Git - packages/crossmingw32-libffi.git/blob - crossmingw32-libffi.spec
- updated to 3.0.11
[packages/crossmingw32-libffi.git] / crossmingw32-libffi.spec
1 Summary:        Foreign Function Interface library (cross MinGW32 version)
2 Summary(pl.UTF-8):      Biblioteka Foreign Function Interface (wersja skrośna MinGW32)
3 Name:           crossmingw32-libffi
4 Version:        3.0.11
5 Release:        1
6 License:        MIT-like
7 Group:          Libraries
8 Source0:        ftp://sourceware.org/pub/libffi/libffi-%{version}.tar.gz
9 # Source0-md5:  f69b9693227d976835b4857b1ba7d0e3
10 URL:            http://sources.redhat.com/libffi/
11 BuildRequires:  texinfo
12 Requires:       crossmingw32-runtime
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         no_install_post_strip   1
16
17 %define         target                  i386-mingw32
18 %define         target_platform         i386-pc-mingw32
19
20 %define         _sysprefix              /usr
21 %define         _prefix                 %{_sysprefix}/%{target}
22 %define         _libdir                 %{_prefix}/lib
23 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
24 %define         _dlldir                 /usr/share/wine/windows/system
25 %define         __cc                    %{target}-gcc
26
27 %ifnarch %{ix86}
28 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
29 %define         optflags        -O2
30 %endif
31 # -z options are invalid for mingw linker
32 %define         filterout_ld    -Wl,-z,.*
33
34 %description
35 The libffi library provides a portable, high level programming
36 interface to various calling conventions. This allows a programmer to
37 call any function specified by a call interface description at
38 run-time.
39
40 Ffi stands for Foreign Function Interface. A foreign function
41 interface is the popular name for the interface that allows code
42 written in one language to call code written in another language. The
43 libffi library really only provides the lowest, machine dependent
44 layer of a fully featured foreign function interface. A layer must
45 exist above libffi that handles type conversions for values passed
46 between the two languages.
47
48 This package contains the cross version for MinGW32.
49
50 %description -l pl.UTF-8
51 Biblioteka libffi dostarcza przenośny, wysokopoziomowy interfejs do
52 różnych konwencji wywołań funkcji. Pozwala to programiście wywołać
53 dowolną funkcję podaną przez opis interfejsu wywołania w czasie
54 działania programu.
55
56 FFI to skrót od Foreign Function Interface, czyli interfejsu do obcych
57 funkcji. Jest to potoczna nazwa interfejsu pozwalającego programowi
58 napisanemu w jednym języku wywoływać kod napisany w innym języku.
59 Biblioteka libffi daje tylko najniższą, zależną od maszyny warstwę
60 pełnego interfejsu. Potrzebne są wyższe warstwy do obsługi konwersji
61 typów dla wartości przekazywanych pomiędzy różnymi językami.
62
63 Ten pakiet zawiera wersję skrośną dla MinGW32.
64
65 %package static
66 Summary:        Static libffi library (cross MinGW32 version)
67 Summary(pl.UTF-8):      Statyczna biblioteka libffi (wersja skrośna MinGW32)
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70
71 %description static
72 Static libffi library (cross MinGW32 version).
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka libffi (wersja skrośna MinGW32).
76
77 %package dll
78 Summary:        Foreign Function Interface DLL library for Windows
79 Summary(pl.UTF-8):      Biblioteka DLL Foreign Function Interface dla Windows
80 Group:          Applications/Emulators
81 Requires:       wine
82
83 %description dll
84 Foreign Function Interface DLL library for Windows.
85
86 %description dll -l pl.UTF-8
87 Biblioteka DLL Foreign Function Interface dla Windows.
88
89 %prep
90 %setup -q -n libffi-%{version}
91
92 %build
93 %configure \
94         --target=%{target} \
95         --host=%{target}
96
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 install -d $RPM_BUILD_ROOT%{_dlldir}
106 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
107
108 %if 0%{!?debug:1}
109 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
110 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
111 %endif
112
113 %{__rm} -r $RPM_BUILD_ROOT{%{_mandir},%{_infodir}}
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files
119 %defattr(644,root,root,755)
120 %doc ChangeLog* LICENSE README
121 %{_libdir}/libffi.dll.a
122 %{_libdir}/libffi.la
123 %{_libdir}/libffi-%{version}
124 %{_pkgconfigdir}/libffi.pc
125
126 %files static
127 %defattr(644,root,root,755)
128 %{_libdir}/libffi.a
129
130 %files dll
131 %defattr(644,root,root,755)
132 %{_dlldir}/libffi-6.dll
This page took 0.039408 seconds and 4 git commands to generate.