]> git.pld-linux.org Git - packages/crossmingw32-harfbuzz.git/blob - crossmingw32-harfbuzz.spec
- updated to 0.9.17
[packages/crossmingw32-harfbuzz.git] / crossmingw32-harfbuzz.spec
1 Summary:        HarfBuzz - internationalized text shaping library - MinGW32 cross version
2 Summary(pl.UTF-8):      Rasteryzer fontów TrueType - wersja skrośna dla MinGW32
3 Name:           crossmingw32-harfbuzz
4 Version:        0.9.17
5 Release:        1
6 License:        MIT
7 Group:          Development/Libraries
8 Source0:        http://www.freedesktop.org/software/harfbuzz/release/harfbuzz-%{version}.tar.bz2
9 # Source0-md5:  c48827713e93539dc7285f9e86ffbdc5
10 Patch0:         harfbuzz-mingw32.patch
11 URL:            http://www.freedesktop.org/wiki/HarfBuzz
12 BuildRequires:  crossmingw32-cairo >= 1.8.0
13 BuildRequires:  crossmingw32-freetype >= 2.3.8
14 BuildRequires:  crossmingw32-glib2 >= 2.16
15 BuildRequires:  crossmingw32-gcc-c++
16 BuildRequires:  pkgconfig >= 1:0.20
17 Requires:       crossmingw32-cairo >= 1.8.0
18 Requires:       crossmingw32-freetype >= 2.3.8
19 Requires:       crossmingw32-glib2 >= 2.16
20 Requires:       crossmingw32-gcc-c++
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 # see <harfbuzz/internal/ftserv.h>, the real horror
24 %define         specflags       -fno-strict-aliasing
25
26 %define         no_install_post_strip   1
27
28 %define         target                  i386-mingw32
29 %define         target_platform         i386-pc-mingw32
30
31 %define         _sysprefix              /usr
32 %define         _prefix                 %{_sysprefix}/%{target}
33 %define         _libdir                 %{_prefix}/lib
34 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
35 %define         _dlldir                 /usr/share/wine/windows/system
36 %define         __cc                    %{target}-gcc
37 %define         __cxx                   %{target}-g++
38 %define         __pkgconfig_provides    %{nil}
39 %define         __pkgconfig_requires    %{nil}
40
41 %ifnarch %{ix86}
42 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
43 %define         optflags        -O2
44 %endif
45 # -z options are invalid for mingw linker, most of -f options are Linux-specific
46 %define         filterout_ld    -Wl,-z,.*
47 %define         filterout_c     -f[-a-z0-9=]*
48 %define         filterout_cxx   -f[-a-z0-9=]*
49
50 %description
51 Internationalized OpenType text layout and rendering library.
52
53 This package contains the cross version for Win32.
54
55 %description -l pl.UTF-8
56 Biblioteka rozmieszczająca i rysująca tekst z fontów OpenType,
57 obsługująca wiele języków.
58
59 Ten pakiet zawiera wersję skrośną dla Win32.
60
61 %package static
62 Summary:        Static harfbuzz library (cross MinGW32 version)
63 Summary(pl.UTF-8):      Statyczna biblioteka harfbuzz (wersja skrośna MinGW32)
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66
67 %description static
68 Static harfbuzz library (cross MinGW32 version).
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka harfbuzz (wersja skrośna MinGW32).
72
73 %package dll
74 Summary:        DLL harfbuzz library for Windows
75 Summary(pl.UTF-8):      Biblioteka DLL harfbuzz dla Windows
76 Group:          Applications/Emulators
77 Requires:       crossmingw32-cairo-dll >= 1.8.0
78 Requires:       crossmingw32-freetype-dll >= 2.3.8
79 Requires:       crossmingw32-glib2-dll >= 2.16
80 Requires:       wine
81
82 %description dll
83 DLL harfbuzz library for Windows.
84
85 %description dll -l pl.UTF-8
86 Biblioteka DLL harfbuzz dla Windows.
87
88 %prep
89 %setup -q -n harfbuzz-%{version}
90 %patch0 -p1
91
92 %build
93 export PKG_CONFIG_LIBDIR=%{_pkgconfigdir}
94 %configure \
95         ICU_CONFIG=/none \
96         --target=%{target} \
97         --build=i686-pc-linux-gnu \
98         --host=%{target} \
99         --disable-silent-rules \
100         --enable-static
101
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 # parallel install broken (hb-version.h both in pkginclude_HEADERS and
108 # nodist_pkginclude_HEADERS)
109 %{__make} -j1 install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 install -d $RPM_BUILD_ROOT%{_dlldir}
113 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
114
115 %if 0%{!?debug:1}
116 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
117 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
118 %endif
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files
124 %defattr(644,root,root,755)
125 %doc COPYING ChangeLog README TODO
126 %{_libdir}/libharfbuzz.dll.a
127 %{_libdir}/libharfbuzz.la
128 %{_includedir}/harfbuzz
129 %{_pkgconfigdir}/harfbuzz.pc
130
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/libharfbuzz.a
134
135 %files dll
136 %defattr(644,root,root,755)
137 %{_dlldir}/libharfbuzz-*.dll
This page took 0.194616 seconds and 4 git commands to generate.