]> git.pld-linux.org Git - packages/crossmingw32-harfbuzz.git/blob - crossmingw32-harfbuzz.spec
do not provide pkgconfig deps in system namespace
[packages/crossmingw32-harfbuzz.git] / crossmingw32-harfbuzz.spec
1 Summary:        HarfBuzz - internationalized text shaping library - MinGW32 cross version
2 Summary(pl.UTF-8):      Rasteryzer fontów TrueType - wersja skrośna dla MinGW32
3 Name:           crossmingw32-harfbuzz
4 Version:        0.9.15
5 Release:        2
6 License:        MIT
7 Group:          Development/Libraries
8 Source0:        http://www.freedesktop.org/software/harfbuzz/release/harfbuzz-%{version}.tar.bz2
9 # Source0-md5:  f6075024947eb445dd3bec587b1753d1
10 Patch0:         harfbuzz-mingw32.patch
11 URL:            http://www.freedesktop.org/wiki/HarfBuzz
12 BuildRequires:  crossmingw32-cairo >= 1.8.0
13 BuildRequires:  crossmingw32-freetype >= 2.3.8
14 BuildRequires:  crossmingw32-glib2 >= 2.16
15 BuildRequires:  crossmingw32-gcc-c++
16 BuildRequires:  pkgconfig >= 1:0.20
17 Requires:       crossmingw32-cairo >= 1.8.0
18 Requires:       crossmingw32-freetype >= 2.3.8
19 Requires:       crossmingw32-glib2 >= 2.16
20 Requires:       crossmingw32-gcc-c++
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 # see <harfbuzz/internal/ftserv.h>, the real horror
24 %define         specflags       -fno-strict-aliasing
25
26 %define         no_install_post_strip   1
27
28 %define         target                  i386-mingw32
29 %define         target_platform         i386-pc-mingw32
30
31 %define         _sysprefix              /usr
32 %define         _prefix                 %{_sysprefix}/%{target}
33 %define         _libdir                 %{_prefix}/lib
34 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
35 %define         _dlldir                 /usr/share/wine/windows/system
36 %define         __cc                    %{target}-gcc
37 %define         __cxx                   %{target}-g++
38 %define         __pkgconfig_provides    %{nil}
39
40 %ifnarch %{ix86}
41 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
42 %define         optflags        -O2
43 %endif
44 # -z options are invalid for mingw linker, most of -f options are Linux-specific
45 %define         filterout_ld    -Wl,-z,.*
46 %define         filterout_c     -f[-a-z0-9=]*
47 %define         filterout_cxx   -f[-a-z0-9=]*
48
49 %description
50 Internationalized OpenType text layout and rendering library.
51
52 This package contains the cross version for Win32.
53
54 %description -l pl.UTF-8
55 Biblioteka rozmieszczająca i rysująca tekst z fontów OpenType,
56 obsługująca wiele języków.
57
58 Ten pakiet zawiera wersję skrośną dla Win32.
59
60 %package static
61 Summary:        Static harfbuzz library (cross MinGW32 version)
62 Summary(pl.UTF-8):      Statyczna biblioteka harfbuzz (wersja skrośna MinGW32)
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65
66 %description static
67 Static harfbuzz library (cross MinGW32 version).
68
69 %description static -l pl.UTF-8
70 Statyczna biblioteka harfbuzz (wersja skrośna MinGW32).
71
72 %package dll
73 Summary:        DLL harfbuzz library for Windows
74 Summary(pl.UTF-8):      Biblioteka DLL harfbuzz dla Windows
75 Group:          Applications/Emulators
76 Requires:       crossmingw32-cairo-dll >= 1.8.0
77 Requires:       crossmingw32-freetype-dll >= 2.3.8
78 Requires:       crossmingw32-glib2-dll >= 2.16
79 Requires:       wine
80
81 %description dll
82 DLL harfbuzz library for Windows.
83
84 %description dll -l pl.UTF-8
85 Biblioteka DLL harfbuzz dla Windows.
86
87 %prep
88 %setup -q -n harfbuzz-%{version}
89 %patch0 -p1
90
91 %build
92 export PKG_CONFIG_LIBDIR=%{_pkgconfigdir}
93 %configure \
94         ICU_CONFIG=/none \
95         --target=%{target} \
96         --build=i686-pc-linux-gnu \
97         --host=%{target} \
98         --disable-silent-rules \
99         --enable-static
100
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 # parallel install broken (hb-version.h both in pkginclude_HEADERS and
107 # nodist_pkginclude_HEADERS)
108 %{__make} -j1 install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 install -d $RPM_BUILD_ROOT%{_dlldir}
112 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
113
114 %if 0%{!?debug:1}
115 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
116 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
117 %endif
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 %defattr(644,root,root,755)
124 %doc COPYING ChangeLog README TODO
125 %{_libdir}/libharfbuzz.dll.a
126 %{_libdir}/libharfbuzz.la
127 %{_includedir}/harfbuzz
128 %{_pkgconfigdir}/harfbuzz.pc
129
130 %files static
131 %defattr(644,root,root,755)
132 %{_libdir}/libharfbuzz.a
133
134 %files dll
135 %defattr(644,root,root,755)
136 %{_dlldir}/libharfbuzz-*.dll
This page took 0.057964 seconds and 3 git commands to generate.