]> git.pld-linux.org Git - packages/crossmingw32-harfbuzz.git/blob - crossmingw32-harfbuzz.spec
- updated to 0.9.24
[packages/crossmingw32-harfbuzz.git] / crossmingw32-harfbuzz.spec
1 Summary:        HarfBuzz - internationalized text shaping library - MinGW32 cross version
2 Summary(pl.UTF-8):      Rasteryzer fontów TrueType - wersja skrośna dla MinGW32
3 Name:           crossmingw32-harfbuzz
4 Version:        0.9.24
5 Release:        1
6 License:        MIT
7 Group:          Development/Libraries
8 Source0:        http://www.freedesktop.org/software/harfbuzz/release/harfbuzz-%{version}.tar.bz2
9 # Source0-md5:  9da7f9dd901ed9e093a033118ac663f4
10 Patch0:         harfbuzz-mingw32.patch
11 URL:            http://www.freedesktop.org/wiki/HarfBuzz
12 BuildRequires:  autoconf >= 2.64
13 BuildRequires:  automake >= 1:1.11.1
14 BuildRequires:  crossmingw32-cairo >= 1.8.0
15 BuildRequires:  crossmingw32-freetype >= 2.3.8
16 BuildRequires:  crossmingw32-glib2 >= 2.16
17 BuildRequires:  crossmingw32-gcc-c++
18 BuildRequires:  libtool >= 2:2.2
19 BuildRequires:  pkgconfig >= 1:0.20
20 Requires:       crossmingw32-cairo >= 1.8.0
21 Requires:       crossmingw32-freetype >= 2.3.8
22 Requires:       crossmingw32-glib2 >= 2.16
23 Requires:       crossmingw32-gcc-c++
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 # see <harfbuzz/internal/ftserv.h>, the real horror
27 %define         specflags       -fno-strict-aliasing
28
29 %define         no_install_post_strip   1
30
31 %define         target                  i386-mingw32
32 %define         target_platform         i386-pc-mingw32
33
34 %define         _sysprefix              /usr
35 %define         _prefix                 %{_sysprefix}/%{target}
36 %define         _libdir                 %{_prefix}/lib
37 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
38 %define         _dlldir                 /usr/share/wine/windows/system
39 %define         __cc                    %{target}-gcc
40 %define         __cxx                   %{target}-g++
41 %define         __pkgconfig_provides    %{nil}
42 %define         __pkgconfig_requires    %{nil}
43
44 %ifnarch %{ix86}
45 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
46 %define         optflags        -O2
47 %endif
48 # -z options are invalid for mingw linker, most of -f options are Linux-specific
49 %define         filterout_ld    -Wl,-z,.*
50 %define         filterout_c     -f[-a-z0-9=]*
51 %define         filterout_cxx   -f[-a-z0-9=]*
52
53 %description
54 Internationalized OpenType text layout and rendering library.
55
56 This package contains the cross version for Win32.
57
58 %description -l pl.UTF-8
59 Biblioteka rozmieszczająca i rysująca tekst z fontów OpenType,
60 obsługująca wiele języków.
61
62 Ten pakiet zawiera wersję skrośną dla Win32.
63
64 %package static
65 Summary:        Static harfbuzz library (cross MinGW32 version)
66 Summary(pl.UTF-8):      Statyczna biblioteka harfbuzz (wersja skrośna MinGW32)
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69
70 %description static
71 Static harfbuzz library (cross MinGW32 version).
72
73 %description static -l pl.UTF-8
74 Statyczna biblioteka harfbuzz (wersja skrośna MinGW32).
75
76 %package dll
77 Summary:        DLL harfbuzz library for Windows
78 Summary(pl.UTF-8):      Biblioteka DLL harfbuzz dla Windows
79 Group:          Applications/Emulators
80 Requires:       crossmingw32-cairo-dll >= 1.8.0
81 Requires:       crossmingw32-freetype-dll >= 2.3.8
82 Requires:       crossmingw32-glib2-dll >= 2.16
83 Requires:       wine
84
85 %description dll
86 DLL harfbuzz library for Windows.
87
88 %description dll -l pl.UTF-8
89 Biblioteka DLL harfbuzz dla Windows.
90
91 %prep
92 %setup -q -n harfbuzz-%{version}
93 %patch0 -p1
94
95 %build
96 %{__libtoolize}
97 %{__aclocal} -I m4
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 export PKG_CONFIG_LIBDIR=%{_pkgconfigdir}
102 %configure \
103         --target=%{target} \
104         --build=i686-pc-linux-gnu \
105         --host=%{target} \
106         --disable-gtk-doc \
107         --disable-silent-rules \
108         --enable-static \
109         --with-cairo \
110         --with-freetype \
111         --with-glib \
112         --without-graphite2 \
113         --with-html-dir=%{_gtkdocdir} \
114         --without-icu \
115         --with-uniscribe
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 install -d $RPM_BUILD_ROOT%{_dlldir}
126 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
127
128 %if 0%{!?debug:1}
129 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
130 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
131 %endif
132
133 %{__rm} -rf $RPM_BUILD_ROOT%{_gtkdocdir}
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %files
139 %defattr(644,root,root,755)
140 %doc COPYING ChangeLog README TODO
141 %{_libdir}/libharfbuzz.dll.a
142 %{_libdir}/libharfbuzz.la
143 %{_includedir}/harfbuzz
144 %{_pkgconfigdir}/harfbuzz.pc
145
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/libharfbuzz.a
149
150 %files dll
151 %defattr(644,root,root,755)
152 %{_dlldir}/libharfbuzz-*.dll
This page took 0.102435 seconds and 3 git commands to generate.