]> git.pld-linux.org Git - packages/crossmingw32-harfbuzz.git/blob - crossmingw32-harfbuzz.spec
- updated to 0.9.15
[packages/crossmingw32-harfbuzz.git] / crossmingw32-harfbuzz.spec
1 Summary:        HarfBuzz - internationalized text shaping library - MinGW32 cross version
2 Summary(pl.UTF-8):      Rasteryzer fontów TrueType - wersja skrośna dla MinGW32
3 Name:           crossmingw32-harfbuzz
4 Version:        0.9.15
5 Release:        1
6 License:        MIT
7 Group:          Development/Libraries
8 Source0:        http://www.freedesktop.org/software/harfbuzz/release/harfbuzz-%{version}.tar.bz2
9 # Source0-md5:  f6075024947eb445dd3bec587b1753d1
10 Patch0:         harfbuzz-mingw32.patch
11 URL:            http://www.freedesktop.org/wiki/HarfBuzz
12 BuildRequires:  crossmingw32-cairo >= 1.8.0
13 BuildRequires:  crossmingw32-freetype >= 2.3.8
14 BuildRequires:  crossmingw32-glib2 >= 2.16
15 BuildRequires:  crossmingw32-gcc-c++
16 BuildRequires:  pkgconfig >= 1:0.20
17 Requires:       crossmingw32-cairo >= 1.8.0
18 Requires:       crossmingw32-freetype >= 2.3.8
19 Requires:       crossmingw32-glib2 >= 2.16
20 Requires:       crossmingw32-gcc-c++
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 # see <harfbuzz/internal/ftserv.h>, the real horror
24 %define         specflags       -fno-strict-aliasing
25
26 %define         no_install_post_strip   1
27
28 %define         target                  i386-mingw32
29 %define         target_platform         i386-pc-mingw32
30
31 %define         _sysprefix              /usr
32 %define         _prefix                 %{_sysprefix}/%{target}
33 %define         _libdir                 %{_prefix}/lib
34 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
35 %define         _dlldir                 /usr/share/wine/windows/system
36 %define         __cc                    %{target}-gcc
37 %define         __cxx                   %{target}-g++
38
39 %ifnarch %{ix86}
40 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
41 %define         optflags        -O2
42 %endif
43 # -z options are invalid for mingw linker, most of -f options are Linux-specific
44 %define         filterout_ld    -Wl,-z,.*
45 %define         filterout_c     -f[-a-z0-9=]*
46 %define         filterout_cxx   -f[-a-z0-9=]*
47
48 %description
49 Internationalized OpenType text layout and rendering library.
50
51 This package contains the cross version for Win32.
52
53 %description -l pl.UTF-8
54 Biblioteka rozmieszczająca i rysująca tekst z fontów OpenType,
55 obsługująca wiele języków.
56
57 Ten pakiet zawiera wersję skrośną dla Win32.
58
59 %package static
60 Summary:        Static harfbuzz library (cross MinGW32 version)
61 Summary(pl.UTF-8):      Statyczna biblioteka harfbuzz (wersja skrośna MinGW32)
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64
65 %description static
66 Static harfbuzz library (cross MinGW32 version).
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka harfbuzz (wersja skrośna MinGW32).
70
71 %package dll
72 Summary:        DLL harfbuzz library for Windows
73 Summary(pl.UTF-8):      Biblioteka DLL harfbuzz dla Windows
74 Group:          Applications/Emulators
75 Requires:       crossmingw32-cairo-dll >= 1.8.0
76 Requires:       crossmingw32-freetype-dll >= 2.3.8
77 Requires:       crossmingw32-glib2-dll >= 2.16
78 Requires:       wine
79
80 %description dll
81 DLL harfbuzz library for Windows.
82
83 %description dll -l pl.UTF-8
84 Biblioteka DLL harfbuzz dla Windows.
85
86 %prep
87 %setup -q -n harfbuzz-%{version}
88 %patch0 -p1
89
90 %build
91 export PKG_CONFIG_LIBDIR=%{_pkgconfigdir}
92 %configure \
93         ICU_CONFIG=/none \
94         --target=%{target} \
95         --build=i686-pc-linux-gnu \
96         --host=%{target} \
97         --disable-silent-rules \
98         --enable-static
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 # parallel install broken (hb-version.h both in pkginclude_HEADERS and
106 # nodist_pkginclude_HEADERS)
107 %{__make} -j1 install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 install -d $RPM_BUILD_ROOT%{_dlldir}
111 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
112
113 %if 0%{!?debug:1}
114 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
115 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
116 %endif
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files
122 %defattr(644,root,root,755)
123 %doc COPYING ChangeLog README TODO
124 %{_libdir}/libharfbuzz.dll.a
125 %{_libdir}/libharfbuzz.la
126 %{_includedir}/harfbuzz
127 %{_pkgconfigdir}/harfbuzz.pc
128
129 %files static
130 %defattr(644,root,root,755)
131 %{_libdir}/libharfbuzz.a
132
133 %files dll
134 %defattr(644,root,root,755)
135 %{_dlldir}/libharfbuzz-*.dll
This page took 0.03248 seconds and 3 git commands to generate.