]> git.pld-linux.org Git - packages/crossmingw32-gtkmm.git/blob - crossmingw32-gtkmm.spec
- updated filterout_ defines
[packages/crossmingw32-gtkmm.git] / crossmingw32-gtkmm.spec
1 Summary:        A C++ interface for the GTK+ (a GUI library for X) - cross MinGW32 version
2 Summary(pl.UTF-8):      Wrapper C++ dla GTK+ - skrośna wersja MinGW32
3 %define         realname   gtkmm
4 Name:           crossmingw32-%{realname}
5 Version:        2.24.3
6 Release:        1
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtkmm/2.24/%{realname}-%{version}.tar.xz
10 # Source0-md5:  42fc5a3feeb33ea59b7660200e2a5465
11 URL:            http://www.gtkmm.org/
12 BuildRequires:  autoconf >= 2.59
13 BuildRequires:  automake >= 1:1.9
14 BuildRequires:  crossmingw32-atkmm >= 2.22.2
15 BuildRequires:  crossmingw32-cairomm >= 1.6.3
16 BuildRequires:  crossmingw32-gcc-c++ >= 3.3.1
17 BuildRequires:  crossmingw32-glibmm >= 2.28.0
18 BuildRequires:  crossmingw32-gtk+2 >= 2.20.0
19 BuildRequires:  crossmingw32-pangomm >= 2.28.0
20 BuildRequires:  libtool >= 2:1.5
21 BuildRequires:  mm-common >= 0.9.5
22 BuildRequires:  perl-base >= 1:5.6.0
23 BuildRequires:  pkgconfig >= 1:0.15
24 BuildRequires:  rpmbuild(macros) >= 1.446
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  xz
27 Requires:       crossmingw32-atkmm >= 2.22.2
28 Requires:       crossmingw32-cairomm >= 1.6.3
29 Requires:       crossmingw32-gtk+2 >= 2.20.0
30 Requires:       crossmingw32-pangomm >= 2.28.0
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         no_install_post_strip   1
34
35 %define         target                  i386-mingw32
36 %define         target_platform         i386-pc-mingw32
37
38 %define         _sysprefix              /usr
39 %define         _prefix                 %{_sysprefix}/%{target}
40 %define         _libdir                 %{_prefix}/lib
41 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
42 %define         _dlldir                 /usr/share/wine/windows/system
43 %define         __cc                    %{target}-gcc
44 %define         __cxx                   %{target}-g++
45
46 %ifnarch %{ix86}
47 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
48 %define         optflags        -O2
49 %endif
50 # -z options are invalid for mingw linker, most of -f options are Linux-specific
51 %define         filterout_ld    -Wl,-z,.*
52 %define         filterout_c     -f[-a-z0-9=]*
53 %define         filterout_cxx   -f[-a-z0-9=]*
54
55 %description
56 This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
57 library. The interface provides a convenient interface for C++
58 programmers to create GUIs with GTK+'s flexible object-oriented
59 framework. Features include type safe callbacks, widgets that are
60 extensible using inheritance and over 110 classes that can be freely
61 combined to quickly create complex user interfaces.
62
63 This package contains the cross version for Win32.
64
65 %description -l pl.UTF-8
66 gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
67 służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
68 także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
69
70 Ten pakiet zawiera wersję skrośną dla Win32.
71
72 %package static
73 Summary:        Static gtkmm libraries (cross MinGW32 version)
74 Summary(pl.UTF-8):      Statyczne biblioteki gtkmm (wersja skrośna MinGW32)
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77
78 %description static
79 Static gtkmm libraries (cross MinGW32 version).
80
81 %description static -l pl.UTF-8
82 Statyczne biblioteki gtkmm (wersja skrośna MinGW32).
83
84 %package dll
85 Summary:        DLL gtkmm libraries for Windows
86 Summary(pl.UTF-8):      Biblioteki DLL gtkmm dla Windows
87 Group:          Applications/Emulators
88 Requires:       crossmingw32-atkmm-dll >= 2.22.2
89 Requires:       crossmingw32-cairomm-dll >= 1.6.3
90 Requires:       crossmingw32-glibmm-dll >= 2.28.0
91 Requires:       crossmingw32-gtk+2-dll >= 2.20.0
92 Requires:       crossmingw32-pangomm-dll >= 2.28.0
93 Requires:       wine
94
95 %description dll
96 DLL gtkmm libraries for Windows.
97
98 %description dll -l pl.UTF-8
99 Biblioteki DLL gtkmm dla Windows.
100
101 %prep
102 %setup -q -n %{realname}-%{version}
103
104 %build
105 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig:%{_npkgconfigdir}
106 %{__libtoolize}
107 %{__aclocal} -I build
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         --targe=%{target} \
113         --host=%{target} \
114         --disable-documentation \
115         --enable-static
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 install -d $RPM_BUILD_ROOT%{_dlldir}
126 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
127
128 %if 0%{!?debug:1}
129 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
130 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
131 %endif
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %files
137 %defattr(644,root,root,755)
138 %doc AUTHORS ChangeLog NEWS PORTING README
139 %{_libdir}/libgdkmm-2.4.dll.a
140 %{_libdir}/libgtkmm-2.4.dll.a
141 %{_libdir}/libgdkmm-2.4.la
142 %{_libdir}/libgtkmm-2.4.la
143 %{_libdir}/gdkmm-2.4
144 %{_libdir}/gtkmm-2.4
145 %{_includedir}/gdkmm-2.4
146 %{_includedir}/gtkmm-2.4
147 %{_pkgconfigdir}/gdkmm-2.4.pc
148 %{_pkgconfigdir}/gtkmm-2.4.pc
149
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/libgdkmm-2.4.a
153 %{_libdir}/libgtkmm-2.4.a
154
155 %files dll
156 %defattr(644,root,root,755)
157 %{_dlldir}/libgdkmm-2.4-*.dll
158 %{_dlldir}/libgtkmm-2.4-*.dll
This page took 0.048664 seconds and 3 git commands to generate.