]> git.pld-linux.org Git - packages/crossmingw32-gtkmm.git/blob - crossmingw32-gtkmm.spec
do not provide pkgconfig deps in system namespace
[packages/crossmingw32-gtkmm.git] / crossmingw32-gtkmm.spec
1 Summary:        A C++ interface for the GTK+ (a GUI library for X) - cross MinGW32 version
2 Summary(pl.UTF-8):      Wrapper C++ dla GTK+ - skrośna wersja MinGW32
3 %define         realname   gtkmm
4 Name:           crossmingw32-%{realname}
5 Version:        2.24.3
6 Release:        2
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtkmm/2.24/%{realname}-%{version}.tar.xz
10 # Source0-md5:  42fc5a3feeb33ea59b7660200e2a5465
11 URL:            http://www.gtkmm.org/
12 BuildRequires:  autoconf >= 2.59
13 BuildRequires:  automake >= 1:1.9
14 BuildRequires:  crossmingw32-atkmm >= 2.22.2
15 BuildRequires:  crossmingw32-cairomm >= 1.6.3
16 BuildRequires:  crossmingw32-gcc-c++ >= 3.3.1
17 BuildRequires:  crossmingw32-glibmm >= 2.28.0
18 BuildRequires:  crossmingw32-gtk+2 >= 2.20.0
19 BuildRequires:  crossmingw32-pangomm >= 2.28.0
20 BuildRequires:  libtool >= 2:1.5
21 BuildRequires:  mm-common >= 0.9.5
22 BuildRequires:  perl-base >= 1:5.6.0
23 BuildRequires:  pkgconfig >= 1:0.15
24 BuildRequires:  rpmbuild(macros) >= 1.446
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  xz
27 Requires:       crossmingw32-atkmm >= 2.22.2
28 Requires:       crossmingw32-cairomm >= 1.6.3
29 Requires:       crossmingw32-gtk+2 >= 2.20.0
30 Requires:       crossmingw32-pangomm >= 2.28.0
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         no_install_post_strip   1
34
35 %define         target                  i386-mingw32
36 %define         target_platform         i386-pc-mingw32
37
38 %define         _sysprefix              /usr
39 %define         _prefix                 %{_sysprefix}/%{target}
40 %define         _libdir                 %{_prefix}/lib
41 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
42 %define         _dlldir                 /usr/share/wine/windows/system
43 %define         __cc                    %{target}-gcc
44 %define         __cxx                   %{target}-g++
45 %define         __pkgconfig_provides    %{nil}
46
47 %ifnarch %{ix86}
48 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
49 %define         optflags        -O2
50 %endif
51 # -z options are invalid for mingw linker, most of -f options are Linux-specific
52 %define         filterout_ld    -Wl,-z,.*
53 %define         filterout_c     -f[-a-z0-9=]*
54 %define         filterout_cxx   -f[-a-z0-9=]*
55
56 %description
57 This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
58 library. The interface provides a convenient interface for C++
59 programmers to create GUIs with GTK+'s flexible object-oriented
60 framework. Features include type safe callbacks, widgets that are
61 extensible using inheritance and over 110 classes that can be freely
62 combined to quickly create complex user interfaces.
63
64 This package contains the cross version for Win32.
65
66 %description -l pl.UTF-8
67 gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
68 służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
69 także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
70
71 Ten pakiet zawiera wersję skrośną dla Win32.
72
73 %package static
74 Summary:        Static gtkmm libraries (cross MinGW32 version)
75 Summary(pl.UTF-8):      Statyczne biblioteki gtkmm (wersja skrośna MinGW32)
76 Group:          Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78
79 %description static
80 Static gtkmm libraries (cross MinGW32 version).
81
82 %description static -l pl.UTF-8
83 Statyczne biblioteki gtkmm (wersja skrośna MinGW32).
84
85 %package dll
86 Summary:        DLL gtkmm libraries for Windows
87 Summary(pl.UTF-8):      Biblioteki DLL gtkmm dla Windows
88 Group:          Applications/Emulators
89 Requires:       crossmingw32-atkmm-dll >= 2.22.2
90 Requires:       crossmingw32-cairomm-dll >= 1.6.3
91 Requires:       crossmingw32-glibmm-dll >= 2.28.0
92 Requires:       crossmingw32-gtk+2-dll >= 2.20.0
93 Requires:       crossmingw32-pangomm-dll >= 2.28.0
94 Requires:       wine
95
96 %description dll
97 DLL gtkmm libraries for Windows.
98
99 %description dll -l pl.UTF-8
100 Biblioteki DLL gtkmm dla Windows.
101
102 %prep
103 %setup -q -n %{realname}-%{version}
104
105 %build
106 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig:%{_npkgconfigdir}
107 %{__libtoolize}
108 %{__aclocal} -I build
109 %{__autoconf}
110 %{__autoheader}
111 %{__automake}
112 %configure \
113         --targe=%{target} \
114         --host=%{target} \
115         --disable-documentation \
116         --enable-static
117
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 install -d $RPM_BUILD_ROOT%{_dlldir}
127 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
128
129 %if 0%{!?debug:1}
130 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
131 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
132 %endif
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %files
138 %defattr(644,root,root,755)
139 %doc AUTHORS ChangeLog NEWS PORTING README
140 %{_libdir}/libgdkmm-2.4.dll.a
141 %{_libdir}/libgtkmm-2.4.dll.a
142 %{_libdir}/libgdkmm-2.4.la
143 %{_libdir}/libgtkmm-2.4.la
144 %{_libdir}/gdkmm-2.4
145 %{_libdir}/gtkmm-2.4
146 %{_includedir}/gdkmm-2.4
147 %{_includedir}/gtkmm-2.4
148 %{_pkgconfigdir}/gdkmm-2.4.pc
149 %{_pkgconfigdir}/gtkmm-2.4.pc
150
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/libgdkmm-2.4.a
154 %{_libdir}/libgtkmm-2.4.a
155
156 %files dll
157 %defattr(644,root,root,755)
158 %{_dlldir}/libgdkmm-2.4-*.dll
159 %{_dlldir}/libgtkmm-2.4-*.dll
This page took 0.060456 seconds and 3 git commands to generate.