]> git.pld-linux.org Git - packages/crossmingw32-gtk+2.git/blob - crossmingw32-gtk+2.spec
- updated to 2.24.21
[packages/crossmingw32-gtk+2.git] / crossmingw32-gtk+2.spec
1 Summary:        The GIMP Toolkit - MinGW32 cross version
2 Summary(pl.UTF-8):      GIMP Toolkit - wersja skrośna dla MinGW32
3 Name:           crossmingw32-gtk+2
4 Version:        2.24.21
5 Release:        1
6 License:        LGPL v2+
7 Group:          Development/Libraries
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtk+/2.24/gtk+-%{version}.tar.xz
9 # Source0-md5:  d7ba702e76236237f2667f3def591fe7
10 URL:            http://www.gtk.org/
11 BuildRequires:  autoconf >= 2.62
12 BuildRequires:  automake >= 1:1.7
13 BuildRequires:  crossmingw32-atk >= 1.30.0
14 BuildRequires:  crossmingw32-cairo >= 1.6
15 BuildRequires:  crossmingw32-gcc
16 BuildRequires:  crossmingw32-gdk-pixbuf2 >= 2.22.0
17 BuildRequires:  crossmingw32-glib2 >= 2.28.0
18 BuildRequires:  crossmingw32-pango >= 1.28.0
19 BuildRequires:  gtk-doc >= 1.17
20 BuildRequires:  libtool
21 BuildRequires:  pkgconfig >= 1:0.15
22 BuildRequires:  tar >= 1:1.22
23 BuildRequires:  xz
24 Requires:       crossmingw32-atk >= 1.30.0
25 Requires:       crossmingw32-cairo >= 1.6
26 Requires:       crossmingw32-gdk-pixbuf2 >= 2.22.0
27 Requires:       crossmingw32-glib2 >= 2.28.0
28 Requires:       crossmingw32-pango >= 1.28.0
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         abivers 2.10.0
32
33 %define         no_install_post_strip   1
34
35 %define         target                  i386-mingw32
36 %define         target_platform         i386-pc-mingw32
37
38 %define         _sysprefix              /usr
39 %define         _prefix                 %{_sysprefix}/%{target}
40 %define         _libdir                 %{_prefix}/lib
41 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
42 %define         _dlldir                 /usr/share/wine/windows/system
43 %define         __cc                    %{target}-gcc
44 %define         __cxx                   %{target}-g++
45 %define         __pkgconfig_provides    %{nil}
46 %define         __pkgconfig_requires    %{nil}
47
48 %define         _ssp_cflags             %{nil}
49 %ifnarch %{ix86}
50 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
51 %define         optflags        -O2
52 %endif
53 # -z options are invalid for mingw linker, most of -f options are Linux-specific
54 %define         filterout_ld    -Wl,-z,.*
55 %define         filterout_c     -f[-a-z0-9=]*
56
57 %description
58 GTK+, which stands for the GIMP ToolKit, is a library for creating
59 graphical user interfaces for the X Window System. It is designed to
60 be small, efficient, and flexible. GTK+ is written in C with a very
61 object-oriented approach. GDK (part of GTK+) is a drawing toolkit
62 which provides a thin layer over Xlib to help automate things like
63 dealing with different color depths, and GTK is a widget set for
64 creating user interfaces.
65
66 This package contains the cross version for Win32.
67
68 %description -l pl.UTF-8
69 GTK+, która to biblioteka stała się podstawą programu GIMP, zawiera
70 funkcje do tworzenia graficznego interfejsu użytkownika pod X Window.
71 Była tworzona z założeniem żeby była mała, efektywna i wygodna. GTK+
72 jest napisane w C z podejściem zorientowanym bardzo obiektowo. GDK
73 (część GTK+) jest warstwą pośrednią pomiędzy Xlib a właściwym GTK
74 zapewniającą pracę niezależnie od głębi koloru (ilości bitów na
75 piksel). GTK (druga część GTK+) jest natomiast już zbiorem różnego
76 rodzaju kontrolek służących do tworzenia interfejsu użytkownika.
77
78 Ten pakiet zawiera wersję skrośną dla Win32.
79
80 %package dll
81 Summary:        DLL GTK+ libraries for Windows
82 Summary(pl.UTF-8):      Biblioteki DLL GTK+ dla Windows
83 Group:          Applications/Emulators
84 Requires:       crossmingw32-atk-dll >= 1.30.0
85 Requires:       crossmingw32-cairo-dll >= 1.6
86 Requires:       crossmingw32-gdk-pixbuf2-dll >= 2.22.0
87 Requires:       crossmingw32-glib2-dll >= 2.28.0
88 Requires:       crossmingw32-pango-dll >= 1.28.0
89 Requires:       wine
90
91 %description dll
92 DLL GTK+ libraries for Windows.
93
94 %description dll -l pl.UTF-8
95 Biblioteki DLL GTK+ dla Windows.
96
97 %prep
98 %setup -q -n gtk+-%{version}
99
100 %build
101 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
102 %{__libtoolize}
103 %{__aclocal}
104 %{__autoconf}
105 %{__autoheader}
106 %{__automake}
107 # starting with 2.24.14 gtk+ uses Windows 5.0 features
108 CPPFLAGS="%{rpmcppflags} -DWINVER=0x0500"
109 %configure \
110         --target=%{target} \
111         --host=%{target} \
112         --disable-cups \
113         --disable-gtk-doc \
114         --disable-man \
115         --disable-xkb \
116         --with-gdktarget=win32 \
117         --without-x \
118         --without-xinput
119
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 # .def installation is not parallel-compliant
126 %{__make} -j1 install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 install -d $RPM_BUILD_ROOT%{_dlldir}
130 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
131
132 %if 0%{!?debug:1}
133 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
134 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
135 %endif
136
137 # remove unsupported locale scheme
138 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{aclocal,gtk-2.0,gtk-doc,locale,themes}
139 # shut up check-files (static modules and *.la for modules)
140 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.{a,la}
141 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/2.*/*/*.{a,la}
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files
147 %defattr(644,root,root,755)
148 %{_libdir}/libgailutil.dll.a
149 %{_libdir}/libgdk-win32-2.0.dll.a
150 %{_libdir}/libgtk-win32-2.0.dll.a
151 %{_libdir}/libgailutil.la
152 %{_libdir}/libgdk-win32-2.0.la
153 %{_libdir}/libgtk-win32-2.0.la
154 %{_libdir}/gailutil.def
155 %{_libdir}/gdk-win32-2.0.def
156 %{_libdir}/gtk-win32-2.0.def
157 %dir %{_libdir}/gtk-2.0
158 %{_libdir}/gtk-2.0/include
159 %{_includedir}/gail-1.0
160 %{_includedir}/gtk-2.0
161 %{_pkgconfigdir}/gail.pc
162 %{_pkgconfigdir}/gdk-2.0.pc
163 %{_pkgconfigdir}/gdk-win32-2.0.pc
164 %{_pkgconfigdir}/gtk+-2.0.pc
165 %{_pkgconfigdir}/gtk+-win32-2.0.pc
166
167 %files dll
168 %defattr(644,root,root,755)
169 %{_dlldir}/libgailutil-*.dll
170 %{_dlldir}/libgdk-win32-2.0-*.dll
171 %{_dlldir}/libgtk-win32-2.0-*.dll
172 %dir %{_libdir}/gtk-2.0
173 %dir %{_libdir}/gtk-2.0/2.10.0
174 %dir %{_libdir}/gtk-2.0/2.10.0/engines
175 %{_libdir}/gtk-2.0/2.10.0/engines/libpixmap.dll
176 %{_libdir}/gtk-2.0/2.10.0/engines/libwimp.dll
177 %dir %{_libdir}/gtk-2.0/2.10.0/immodules
178 %{_libdir}/gtk-2.0/2.10.0/immodules/im-*.dll
179 %dir %{_libdir}/gtk-2.0/modules
180 %{_libdir}/gtk-2.0/modules/libgail.dll
This page took 0.071554 seconds and 3 git commands to generate.