]> git.pld-linux.org Git - packages/crossmingw32-gtk+2.git/blob - crossmingw32-gtk+2.spec
- updated to 2.24.33 (final GTK+ 2.x release)
[packages/crossmingw32-gtk+2.git] / crossmingw32-gtk+2.spec
1 Summary:        The GIMP Toolkit - MinGW32 cross version
2 Summary(pl.UTF-8):      GIMP Toolkit - wersja skrośna dla MinGW32
3 Name:           crossmingw32-gtk+2
4 Version:        2.24.31
5 Release:        2
6 License:        LGPL v2+
7 Group:          Development/Libraries
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtk+/2.24/gtk+-%{version}.tar.xz
9 # Source0-md5:  526a1008586094a2cbb4592fd3f9ee10
10 URL:            http://www.gtk.org/
11 BuildRequires:  autoconf >= 2.62
12 BuildRequires:  automake >= 1:1.7
13 BuildRequires:  crossmingw32-atk >= 1.30.0
14 BuildRequires:  crossmingw32-cairo >= 1.6
15 BuildRequires:  crossmingw32-gcc
16 BuildRequires:  crossmingw32-gdk-pixbuf2 >= 2.22.0
17 BuildRequires:  crossmingw32-glib2 >= 2.28.0
18 BuildRequires:  crossmingw32-pango >= 1.28.0
19 BuildRequires:  gtk-doc >= 1.17
20 BuildRequires:  libtool
21 BuildRequires:  pkgconfig >= 1:0.15
22 BuildRequires:  sed >= 4.0
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 Requires:       crossmingw32-atk >= 1.30.0
26 Requires:       crossmingw32-cairo >= 1.6
27 Requires:       crossmingw32-gdk-pixbuf2 >= 2.22.0
28 Requires:       crossmingw32-glib2 >= 2.28.0
29 Requires:       crossmingw32-pango >= 1.28.0
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         abivers 2.10.0
33
34 %define         no_install_post_strip   1
35
36 %define         target                  i386-mingw32
37 %define         target_platform         i386-pc-mingw32
38
39 %define         _sysprefix              /usr
40 %define         _prefix                 %{_sysprefix}/%{target}
41 %define         _libdir                 %{_prefix}/lib
42 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
43 %define         _dlldir                 /usr/share/wine/windows/system
44 %define         __cc                    %{target}-gcc
45 %define         __cxx                   %{target}-g++
46 %define         __pkgconfig_provides    %{nil}
47 %define         __pkgconfig_requires    %{nil}
48
49 %define         _ssp_cflags             %{nil}
50 %ifnarch %{ix86}
51 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
52 %define         optflags        -O2
53 %endif
54 # -z options are invalid for mingw linker, most of -f options are Linux-specific
55 %define         filterout_ld    -Wl,-z,.*
56 %define         filterout_c     -f[-a-z0-9=]*
57
58 %description
59 GTK+, which stands for the GIMP ToolKit, is a library for creating
60 graphical user interfaces for the X Window System. It is designed to
61 be small, efficient, and flexible. GTK+ is written in C with a very
62 object-oriented approach. GDK (part of GTK+) is a drawing toolkit
63 which provides a thin layer over Xlib to help automate things like
64 dealing with different color depths, and GTK is a widget set for
65 creating user interfaces.
66
67 This package contains the cross version for Win32.
68
69 %description -l pl.UTF-8
70 GTK+, która to biblioteka stała się podstawą programu GIMP, zawiera
71 funkcje do tworzenia graficznego interfejsu użytkownika pod X Window.
72 Była tworzona z założeniem żeby była mała, efektywna i wygodna. GTK+
73 jest napisane w C z podejściem zorientowanym bardzo obiektowo. GDK
74 (część GTK+) jest warstwą pośrednią pomiędzy Xlib a właściwym GTK
75 zapewniającą pracę niezależnie od głębi koloru (ilości bitów na
76 piksel). GTK (druga część GTK+) jest natomiast już zbiorem różnego
77 rodzaju kontrolek służących do tworzenia interfejsu użytkownika.
78
79 Ten pakiet zawiera wersję skrośną dla Win32.
80
81 %package dll
82 Summary:        DLL GTK+ libraries for Windows
83 Summary(pl.UTF-8):      Biblioteki DLL GTK+ dla Windows
84 Group:          Applications/Emulators
85 Requires:       crossmingw32-atk-dll >= 1.30.0
86 Requires:       crossmingw32-cairo-dll >= 1.6
87 Requires:       crossmingw32-gdk-pixbuf2-dll >= 2.22.0
88 Requires:       crossmingw32-glib2-dll >= 2.28.0
89 Requires:       crossmingw32-pango-dll >= 1.28.0
90 Requires:       wine
91
92 %description dll
93 DLL GTK+ libraries for Windows.
94
95 %description dll -l pl.UTF-8
96 Biblioteki DLL GTK+ dla Windows.
97
98 %prep
99 %setup -q -n gtk+-%{version}
100
101 # avoid rebuilding builtin stock icons cache
102 # (requires native gtk-update-icon-cache >= 2.24.24 < 3.0)
103 touch gtk/stamp-icons gtk/gtkbuiltincache.h
104
105 # -Wl, makes recent libtools pass it as linker flag before any objects,
106 # which is incompatible with as-needed; use plain -luuid with pass_all
107 # hack below
108 %{__sed} -i -e 's@-Wl,-luuid@-luuid@' configure.ac
109
110 %build
111 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
112 %{__libtoolize}
113 %{__aclocal}
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117 # starting with 2.24.14 gtk+ uses Windows 5.0 features
118 CPPFLAGS="%{rpmcppflags} -DWINVER=0x0500"
119 %configure \
120         --target=%{target} \
121         --host=%{target} \
122         --disable-cups \
123         --disable-gtk-doc \
124         --disable-man \
125         --disable-xkb \
126         --with-gdktarget=win32 \
127         --without-x \
128         --without-xinput
129
130 # by default mingw32 libtool doesn't allow to embed static libraries
131 # in shared libraries (only import libraries are allowed); override this
132 # to allow static libuuid
133 %{__sed} -i -e 's/^\(deplibs_check_method\)=.*/\1="pass_all"/' libtool
134 # avoid -luuid in shared linking
135 %{__sed} -i -e 's/ -luuid//;$aLibs.private: -luuid' gdk*.pc
136
137 %{__make}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141
142 # .def installation is not parallel-compliant
143 %{__make} -j1 install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 # avoid -luuid in shared linking
147 %{__sed} -i -e 's/ -luuid//' $RPM_BUILD_ROOT%{_libdir}/lib*.la
148
149 install -d $RPM_BUILD_ROOT%{_dlldir}
150 %{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
151
152 %if 0%{!?debug:1}
153 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
154 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
155 %endif
156
157 # remove unsupported locale scheme
158 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{aclocal,gtk-2.0,gtk-doc,locale,themes}
159 # shut up check-files (static modules and *.la for modules)
160 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.{a,la}
161 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/2.*/*/*.{a,la}
162
163 %clean
164 rm -rf $RPM_BUILD_ROOT
165
166 %files
167 %defattr(644,root,root,755)
168 %{_libdir}/libgailutil.dll.a
169 %{_libdir}/libgdk-win32-2.0.dll.a
170 %{_libdir}/libgtk-win32-2.0.dll.a
171 %{_libdir}/libgailutil.la
172 %{_libdir}/libgdk-win32-2.0.la
173 %{_libdir}/libgtk-win32-2.0.la
174 %{_libdir}/gailutil.def
175 %{_libdir}/gdk-win32-2.0.def
176 %{_libdir}/gtk-win32-2.0.def
177 %dir %{_libdir}/gtk-2.0
178 %{_libdir}/gtk-2.0/include
179 %{_includedir}/gail-1.0
180 %{_includedir}/gtk-2.0
181 %{_pkgconfigdir}/gail.pc
182 %{_pkgconfigdir}/gdk-2.0.pc
183 %{_pkgconfigdir}/gdk-win32-2.0.pc
184 %{_pkgconfigdir}/gtk+-2.0.pc
185 %{_pkgconfigdir}/gtk+-win32-2.0.pc
186
187 %files dll
188 %defattr(644,root,root,755)
189 %{_dlldir}/libgailutil-*.dll
190 %{_dlldir}/libgdk-win32-2.0-*.dll
191 %{_dlldir}/libgtk-win32-2.0-*.dll
192 %dir %{_libdir}/gtk-2.0
193 %dir %{_libdir}/gtk-2.0/2.10.0
194 %dir %{_libdir}/gtk-2.0/2.10.0/engines
195 %{_libdir}/gtk-2.0/2.10.0/engines/libpixmap.dll
196 %{_libdir}/gtk-2.0/2.10.0/engines/libwimp.dll
197 %dir %{_libdir}/gtk-2.0/2.10.0/immodules
198 %{_libdir}/gtk-2.0/2.10.0/immodules/im-*.dll
199 %dir %{_libdir}/gtk-2.0/modules
200 %{_libdir}/gtk-2.0/modules/libgail.dll
This page took 0.132257 seconds and 3 git commands to generate.