]> git.pld-linux.org Git - packages/crossmingw32-gcc.git/blame - crossmingw32-gcc.spec
- use arch*dir macros, pass bugurl and pkgversion
[packages/crossmingw32-gcc.git] / crossmingw32-gcc.spec
CommitLineData
a3bdc2a1 1#
2# Conditional build:
6ccf21dc
JB
3%bcond_with bootstrap # bootstrap build (using binary w32api/mingwrt, no gomp)
4%bcond_without gomp # OpenMP libraries
a3bdc2a1 5#
6ccf21dc
JB
6%if %{with bootstrap}
7%undefine with_gomp
8%endif
8c4c66e6
JB
9Summary: Cross MinGW32 GNU binary utility development utilities - gcc
10Summary(es.UTF-8): Utilitarios para desarrollo de binarios de la GNU - MinGW32 gcc
11Summary(fr.UTF-8): Utilitaires de développement binaire de GNU - MinGW32 gcc
12Summary(pl.UTF-8): Skrośne narzędzia programistyczne GNU dla MinGW32 - gcc
13Summary(pt_BR.UTF-8): Utilitários para desenvolvimento de binários da GNU - MinGW32 gcc
14Summary(tr.UTF-8): GNU geliştirme araçları - MinGW32 gcc
b336056d 15Name: crossmingw32-gcc
da54ab64 16Version: 6.4.0
14b9b67e 17Release: 1
d3f237e2 18Epoch: 1
acb9fe67 19License: GPL v3+
d3f237e2 20Group: Development/Languages
da54ab64
JB
21Source0: https://ftp.gnu.org/gnu/gcc/gcc-%{version}/gcc-%{version}.tar.xz
22# Source0-md5: 11ba51a0cfb8471927f387c8895fe232
ba1fe36b
JB
23%define mingw32_ver 4.0.3
24Source1: http://downloads.sourceforge.net/mingw/mingwrt-%{mingw32_ver}-1-mingw32-dev.tar.lzma
25# Source1-md5: c2c9aa82e0cb47abac01760525684858
6ccf21dc 26Source2: gcc-optimize-la.pl
14b9b67e 27# svn diff -x --ignore-eol-style --force svn://gcc.gnu.org/svn/gcc/tags/gcc_5_4_0_release svn://gcc.gnu.org/svn/gcc/branches/gcc-5-branch > gcc-branch.diff
83afd976 28Patch100: gcc-branch.diff
da54ab64 29# Patch100-md5: 1d4bc26154e47de7d727d6767215e776
83afd976
ŁK
30Patch0: %{name}-buildsystem1.patch
31Patch1: %{name}-buildsystem2.patch
32Patch2: %{name}-lfs.patch
14b9b67e 33Patch3: gcc-mingw32.patch
da54ab64 34Patch4: gcc-build-libvtv.patch
6ccf21dc 35URL: http://gcc.gnu.org/
669fa8b1 36BuildRequires: autoconf >= 2.64
14b9b67e 37BuildRequires: automake >= 1:1.11.1
d12aabe0 38BuildRequires: bison
14b9b67e 39BuildRequires: crossmingw32-binutils >= 2.23
6ccf21dc
JB
40%{?with_gomp:BuildRequires: crossmingw32-pthreads-w32}
41%if %{without bootstrap}
42BuildRequires: crossmingw32-runtime >= 3.5
43BuildRequires: crossmingw32-w32api >= 3.1
44%endif
14b9b67e
JB
45BuildRequires: flex >= 2.5.4
46BuildRequires: gettext-tools >= 0.14.5
47BuildRequires: gmp-devel >= 4.3.2
da54ab64 48BuildRequires: isl-devel >= 0.15
14b9b67e 49BuildRequires: libmpc-devel >= 0.8.1
da54ab64 50BuildRequires: libstdc++-devel
14b9b67e 51BuildRequires: mpfr-devel >= 2.4.2
207a380a 52BuildRequires: perl-tools-pod
73ff33c1 53BuildRequires: tar >= 1:1.22
da54ab64 54BuildRequires: texinfo >= 4.7
73ff33c1 55BuildRequires: xz
da54ab64 56BuildRequires: zlib-devel
14b9b67e
JB
57BuildConflicts: pdksh < 5.2.14-50
58Requires: crossmingw32-binutils >= 2.23
6ab368b0 59Requires: gcc-dirs
14b9b67e 60Requires: gmp >= 4.3.2
da54ab64 61Requires: isl >= 0.15
14b9b67e
JB
62Requires: libmpc >= 0.8.1
63Requires: mpfr >= 2.4.2
b336056d
JB
64BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
d3f237e2 66%define target i386-mingw32
8f1d5c0c 67%define sysprefix /usr
77399965
JB
68%define archprefix %{sysprefix}/%{target}
69%define archbindir %{archprefix}/bin
70%define archincludedir %{archprefix}/include
71%define archlibdir %{archprefix}/lib
73ff33c1
JB
72%define gccarchdir %{_libdir}/gcc/%{target}
73%define gcclibdir %{gccarchdir}/%{version}
74%define _dlldir /usr/share/wine/windows/system
dee9b92f 75
5b936a1d 76%define _noautostrip .*/lib.*\\.a
b336056d 77
66f480ce
JP
78%define _enable_debug_packages 0
79
45ff11c2
JR
80# functions with printf format attribute but with special parser and also
81# receiving non constant format strings
82%define Werror_cflags %{nil}
42fa9439 83%define _ssp_cflags %{nil}
c07647a9
JB
84# -fPIC is not valid for target platform
85%define filterout_c -fPIC
42fa9439 86
b336056d
JB
87%description
88crossmingw32 is a complete cross-compiling development system for
89building stand-alone Microsoft Windows applications under Linux using
8c4c66e6 90the MinGW32 build libraries. This includes a binutils, gcc with g++
b336056d
JB
91and objc, and libstdc++, all cross targeted to i386-mingw32, along
92with supporting Win32 libraries in 'coff' format from free sources.
93
d3f237e2 94This package contains cross targeted gcc.
b336056d 95
4a6c89d0 96%description -l de.UTF-8
97Dieses Paket enthält einen Cross-gcc, der es erlaubt, auf einem
98anderem Rechner Code für Win32 zu generieren.
9dd4c848 99
4a6c89d0 100%description -l pl.UTF-8
101crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
102pozwalającym budować aplikacje MS Windows pod Linuksem używając
8c4c66e6 103bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
4a6c89d0 104libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
2e5b9011 105z bibliotek w formacie COFF.
d790a8ba 106
4a6c89d0 107Ten pakiet zawiera gcc generujące skrośnie kod dla Win32.
d790a8ba 108
73ff33c1
JB
109%package -n crossmingw32-libgcc-dll
110Summary: libgcc DLL library for Windows
111Summary(pl.UTF-8): Biblioteka DLL libgcc dla Windows
112Group: Applications/Emulators
113Requires: wine
114
115%description -n crossmingw32-libgcc-dll
116libgcc DLL library for Windows.
117
118%description -n crossmingw32-libgcc-dll -l pl.UTF-8
119Biblioteka DLL libgcc dla Windows.
120
14b9b67e
JB
121%package -n crossmingw32-libatomic
122Summary: The GNU Atomic library - cross MinGW32 version
123Summary(pl.UTF-8): Biblioteka GNU Atomic - wersja skrośna MinGW32
124License: GPL v3+ with GCC Runtime Library Exception v3.1
125Group: Development/Libraries
126Requires: %{name} = %{epoch}:%{version}-%{release}
127
128%description -n crossmingw32-libatomic
129This package contains cross MinGW32 version of the GNU Atomic library
130which is a GCC support library for atomic operations not supported by
131hardware.
132
133%description -n crossmingw32-libatomic -l pl.UTF-8
134Ten pakiet zawiera wersję skrośną MinGW32 biblioteki GNU Atomic,
135będącej biblioteką GCC, wspierającej operacje atomowe na sprzęcie ich
136nie obsługującym.
137
138%package -n crossmingw32-libatomic-static
139Summary: The GNU Atomic static library - cross MinGW32 version
140Summary(pl.UTF-8): Statyczna biblioteka GNU Atomic - wersja skrośna MinGW32
141License: GPL v3+ with GCC Runtime Library Exception v3.1
142Group: Development/Libraries
143Requires: crossmingw32-libatomic = %{epoch}:%{version}-%{release}
144
145%description -n crossmingw32-libatomic-static
146The GNU Atomic static library - cross MinGW32 version.
147
148%description -n crossmingw32-libatomic-static
149Statyczna biblioteka GNU Atomic - wersja skrośna MinGW32.
150
151%package -n crossmingw32-libatomic-dll
152Summary: DLL GNU Atomic library for Windows
153Summary(pl.UTF-8): Biblioteka DLL GNU Atomic dla Windows
154License: GPL v3+ with GCC Runtime Library Exception v3.1
155Group: Applications/Emulators
156Requires: wine
157
158%description -n crossmingw32-libatomic-dll
159DLL GNU Atomic library for Windows.
160
161%description -n crossmingw32-libatomic-dll -l pl.UTF-8
162Biblioteka DLL GNU Atomic dla Windows.
163
6ccf21dc
JB
164%package -n crossmingw32-libgomp
165Summary: GNU OpenMP library - cross MinGW32 version
166Summary(pl.UTF-8): Biblioteka GNU OpenMP - wersja skrośna MinGW32
167License: GPL v3+ with GCC Runtime Library Exception v3.1
168Group: Development/Libraries
169Requires: %{name} = %{epoch}:%{version}-%{release}
170
171%description -n crossmingw32-libgomp
172This package contains cross MinGW32 version of GNU OpenMP library.
173
174%description -n crossmingw32-libgomp -l pl.UTF-8
175Ten pakiet zawiera wersję skrośną MinGW32 biblioteki GNU OpenMP.
176
177%package -n crossmingw32-libgomp-static
178Summary: Static GNU OpenMP library - cross MinGW32 version
179Summary(pl.UTF-8): Statyczna biblioteka GNU OpenMP - wersja skrośna MinGW32
180License: GPL v3+ with GCC Runtime Library Exception v3.1
181Group: Development/Libraries
182Requires: crossmingw32-libgomp = %{epoch}:%{version}-%{release}
183
184%description -n crossmingw32-libgomp-static
185Static GNU OpenMP library - cross MinGW32 version.
186
187%description -n crossmingw32-libgomp-static -l pl.UTF-8
188Statyczna biblioteka GNU OpenMP - wersja skrośna MinGW32.
189
190%package -n crossmingw32-libgomp-dll
191Summary: DLL GNU OpenMP library for Windows
192Summary(pl.UTF-8): Biblioteka DLL GNU OpenMP dla Windows
193License: GPL v3+ with GCC Runtime Library Exception v3.1
14b9b67e 194Group: Applications/Emulators
6ccf21dc 195Requires: crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
e49d4dab 196Requires: crossmingw32-pthreads-w32-dll
6ccf21dc
JB
197
198%description -n crossmingw32-libgomp-dll
199DLL GNU OpenMP library for Windows.
200
201%description -n crossmingw32-libgomp-dll -l pl.UTF-8
202Biblioteka DLL GNU OpenMP dla Windows.
203
14b9b67e
JB
204%package -n crossmingw32-libvtv
205Summary: The Virtual Table Verification library - cross MinGW32 version
206Summary(pl.UTF-8): Biblioteka Virtual Table Verification do weryfikacji tablicy wirtualnej - wersja skrośna MinGW32
207License: GPL v3+ with GCC Runtime Library Exception v3.1
208Group: Development/Libraries
209URL: https://gcc.gnu.org/wiki/vtv
210Requires: %{name} = %{epoch}:%{version}-%{release}
211
212%description -n crossmingw32-libvtv
213This package contains cross MinGW32 version of the Virtual Table
214Verification library which is used for -fvtable-verify=...
215instrumented programs.
216
217%description -n crossmingw32-libvtv -l pl.UTF-8
218Ten pakiet zawiera wersję skrośną MinGW32 biblioteki Virtual Table
219Verification, służącej do weryfikacji tablicy wirtualnej w programach
220kompilowanych z opcją -fvtable-verify=....
221
222%package -n crossmingw32-libvtv-static
223Summary: The Virtual Table Verification static library - cross MinGW32 version
224Summary(pl.UTF-8): Statyczna biblioteka Virtual Table Verification - wersja skrośna MinGW32
225License: GPL v3+ with GCC Runtime Library Exception v3.1
226Group: Development/Libraries
227URL: https://gcc.gnu.org/wiki/vtv
228Requires: crossmingw32-libvtv = %{epoch}:%{version}-%{release}
229
230%description -n crossmingw32-libvtv-static
231The Virtual Table Verification static library - cross MinGW32 version.
232
233%description -n crossmingw32-libvtv-static -l pl.UTF-8
234Statyczna biblioteka Virtual Table Verification - wersja skrośna
235MinGW32.
236
237%package -n crossmingw32-libvtv-dll
238Summary: DLL Virtual Table Verification libraries for Windows
239Summary(pl.UTF-8): Biblioteki DLL Virtual Table Verification dla Windows
240License: GPL v3+ with GCC Runtime Library Exception v3.1
241Group: Applications/Emulators
242URL: https://gcc.gnu.org/wiki/vtv
243Requires: crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
244
245%description -n crossmingw32-libvtv-dll
246DLL Virtual Table Verification libraries for Windows.
247
248%description -n crossmingw32-libvtv-dll -l pl.UTF-8
249Biblioteki DLL Virtual Table Verification dla Windows.
250
d3f237e2 251%package c++
8c4c66e6
JB
252Summary: MinGW32 binary utility development utilities - g++
253Summary(pl.UTF-8): Zestaw narzędzi MinGW32 - g++
d3f237e2 254Group: Development/Languages
cae974d4 255Requires: %{name} = %{epoch}:%{version}-%{release}
b336056d 256
d3f237e2
JB
257%description c++
258crossmingw32 is a complete cross-compiling development system for
259building stand-alone Microsoft Windows applications under Linux using
8c4c66e6 260the MinGW32 build libraries. This includes a binutils, gcc with g++
d3f237e2
JB
261and objc, and libstdc++, all cross targeted to i386-mingw32, along
262with supporting Win32 libraries in 'coff' format from free sources.
263
264This package contains cross targeted g++ and (static) libstdc++.
265
4a6c89d0 266%description c++ -l pl.UTF-8
267crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
268pozwalającym budować aplikacje MS Windows pod Linuksem używając
8c4c66e6 269bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
4a6c89d0 270libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
2e5b9011 271z bibliotek w formacie COFF.
d790a8ba 272
4a6c89d0 273Ten pakiet zawiera g++ generujące kod pod Win32 oraz bibliotekę
d790a8ba
JB
274libstdc++.
275
73ff33c1
JB
276%package -n crossmingw32-libstdc++-static
277Summary: Static standard C++ library - cross MinGW32 version
278Summary(pl.UTF-8): Statyczna biblioteka standardowa C++ - wersja skrośna MinGW32
279Group: Development/Libraries
280Requires: %{name}-c++ = %{epoch}:%{version}-%{release}
281
282%description -n crossmingw32-libstdc++-static
283Static standard C++ library - cross MinGW32 version.
284
285%description -n crossmingw32-libstdc++-static -l pl.UTF-8
286Statyczna biblioteka standardowa C++ - wersja skrośna MinGW32.
287
288%package -n crossmingw32-libstdc++-dll
289Summary: libstdc++ DLL library for Windows
290Summary(pl.UTF-8): Biblioteka DLL libstdc++ dla Windows
291Group: Applications/Emulators
292Requires: crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
293Requires: wine
294
295%description -n crossmingw32-libstdc++-dll
296libstdc++ DLL library for Windows.
297
298%description -n crossmingw32-libstdc++-dll -l pl.UTF-8
299Biblioteka DLL libstdc++ dla Windows.
300
d3f237e2 301%package objc
8c4c66e6
JB
302Summary: MinGW32 binary utility development utilities - objc
303Summary(pl.UTF-8): Zestaw narzędzi MinGW32 - objc
d3f237e2 304Group: Development/Languages
cae974d4 305Requires: %{name} = %{epoch}:%{version}-%{release}
d3f237e2
JB
306
307%description objc
308crossmingw32 is a complete cross-compiling development system for
309building stand-alone Microsoft Windows applications under Linux using
8c4c66e6 310the MinGW32 build libraries. This includes a binutils, gcc with g++
d3f237e2
JB
311and objc, and libstdc++, all cross targeted to i386-mingw32, along
312with supporting Win32 libraries in 'coff' format from free sources.
313
37948e2b 314This package contains cross targeted objc compiler.
d3f237e2 315
4a6c89d0 316%description objc -l pl.UTF-8
317crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
318pozwalającym budować aplikacje MS Windows pod Linuksem używając
8c4c66e6 319bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
4a6c89d0 320libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
2e5b9011 321z bibliotek w formacie COFF.
d790a8ba 322
4a6c89d0 323Ten pakiet zawiera kompilator objc generujący kod pod Win32.
d790a8ba 324
14b9b67e
JB
325%package objc++
326Summary: MinGW32 binary utility development utilities - objc++
327Summary(pl.UTF-8): Zestaw narzędzi MinGW32 - objc++
328Group: Development/Languages
329Requires: %{name}-objc = %{epoch}:%{version}-%{release}
330
331%description objc++
332crossmingw32 is a complete cross-compiling development system for
333building stand-alone Microsoft Windows applications under Linux using
334the MinGW32 build libraries. This includes a binutils, gcc with g++
335and objc, and libstdc++, all cross targeted to i386-mingw32, along
336with supporting Win32 libraries in 'coff' format from free sources.
337
338This package contains Objective C++ support.
339
340%description objc++ -l pl.UTF-8
341crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
342pozwalającym budować aplikacje MS Windows pod Linuksem używając
343bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
344libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
345z bibliotek w formacie COFF.
346
347Ten pakiet zawiera obsługę języka Objective C++.
348
8f1d5c0c
JB
349%package -n crossmingw32-libobjc-static
350Summary: Static Objective C library - cross MinGW32 version
351Summary(pl.UTF-8): Statyczna biblioteka Objective C - wersja skrośna MinGW32
352Group: Development/Libraries
353Requires: %{name}-objc = %{epoch}:%{version}-%{release}
354
355%description -n crossmingw32-libobjc-static
356Static Objective C library - cross MinGW32 version.
357
358%description -n crossmingw32-libobjc-static -l pl.UTF-8
359Statyczna biblioteka Objective C - wersja skrośna MinGW32.
360
361%package -n crossmingw32-libobjc-dll
362Summary: libobjc DLL library for Windows
363Summary(pl.UTF-8): Biblioteka DLL libobjc dla Windows
364Group: Applications/Emulators
365Requires: crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
366Requires: wine
367
368%description -n crossmingw32-libobjc-dll
369libobjc DLL library for Windows.
370
371%description -n crossmingw32-libobjc-dll -l pl.UTF-8
372Biblioteka DLL libobjc dla Windows.
373
52a544a1 374%package fortran
8c4c66e6
JB
375Summary: MinGW32 binary utility development utilities - Fortran
376Summary(pl.UTF-8): Zestaw narzędzi MinGW32 - Fortran
d3f237e2 377Group: Development/Languages
cae974d4 378Requires: %{name} = %{epoch}:%{version}-%{release}
ed6b55ce 379Requires: crossmingw32-libquadmath = %{epoch}:%{version}-%{release}
37948e2b 380Obsoletes: crossmingw32-gcc-g77
d3f237e2 381
52a544a1 382%description fortran
d3f237e2
JB
383crossmingw32 is a complete cross-compiling development system for
384building stand-alone Microsoft Windows applications under Linux using
8c4c66e6 385the MinGW32 build libraries. This includes a binutils, gcc with g++
d3f237e2
JB
386and objc, and libstdc++, all cross targeted to i386-mingw32, along
387with supporting Win32 libraries in 'coff' format from free sources.
388
37948e2b 389This package contains cross targeted Fortran compiler.
d3f237e2 390
4a6c89d0 391%description fortran -l pl.UTF-8
392crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
393pozwalającym budować aplikacje MS Windows pod Linuksem używając
8c4c66e6 394bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
4a6c89d0 395libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
2e5b9011 396z bibliotek w formacie COFF.
d790a8ba 397
4a6c89d0 398Ten pakiet zawiera kompilator Fortranu generujący kod pod Win32.
d790a8ba 399
0d9cd0a8
JB
400%package -n crossmingw32-libgfortran-static
401Summary: Static Fortran library - cross MinGW32 version
6a795f6e 402Summary(pl.UTF-8): Statyczna biblioteka Fortranu - wersja skrośna MinGW32
0d9cd0a8
JB
403Group: Development/Libraries
404Requires: %{name}-fortran = %{epoch}:%{version}-%{release}
405
406%description -n crossmingw32-libgfortran-static
407Static Fortran library - cross MinGW32 version.
408
409%description -n crossmingw32-libgfortran-static -l pl.UTF-8
6a795f6e 410Statyczna biblioteka Fortranu - wersja skrośna MinGW32.
0d9cd0a8
JB
411
412%package -n crossmingw32-libgfortran-dll
413Summary: libgfortran DLL library for Windows
414Summary(pl.UTF-8): Biblioteka DLL libgfortran dla Windows
415Group: Applications/Emulators
b07ce80e 416Requires: crossmingw32-libquadmath-dll
0d9cd0a8
JB
417
418%description -n crossmingw32-libgfortran-dll
419libgfortran DLL library for Windows.
420
421%description -n crossmingw32-libgfortran-dll -l pl.UTF-8
422Biblioteka DLL libgfortran dla Windows.
423
b07ce80e
JB
424%package -n crossmingw32-libquadmath
425Summary: GCC __float128 support library - cross MinGW32 version
426Summary(pl.UTF-8): Biblioteka do obsługi typu __float128 - wersja skrośna MinGW32
427License: GPL v2+ with linking exception
428Group: Development/Libraries
429Requires: %{name} = %{epoch}:%{version}-%{release}
430
431%description -n crossmingw32-libquadmath
432This package contains cross MinGW32 version of GCC support library
433which is needed for __float128 math support and for Fortran REAL*16
434support.
435
436%description -n crossmingw32-libquadmath -l pl.UTF-8
437Ten pakiet zawiera wersję skrośną MinGW32 biblioteki GCC do obsługi
438operacji matematycznych na zmiennych typu __float128 oraz typu REAL*16
439w Fortranie.
440
441%package -n crossmingw32-libquadmath-static
442Summary: Static GCC __float128 support library - cross MinGW32 version
443Summary(pl.UTF-8): Biblioteka statyczna GCC do obsługi typu __float128 - wersja skrośna MinGW32
444License: GPL v2+ with linking exception
445Group: Development/Libraries
446Requires: crossmingw32-libquadmath = %{epoch}:%{version}-%{release}
447
448%description -n crossmingw32-libquadmath-static
449Static GCC __float128 support library - cross MinGW32 version.
450
451%description -n crossmingw32-libquadmath-static -l pl.UTF-8
452Biblioteka statyczna GCC do obsługi typu __float128 - wersja skrośna
453MinGW32.
454
455%package -n crossmingw32-libquadmath-dll
456Summary: DLL GCC __float128 support library for Windows
457Summary(pl.UTF-8): Biblioteka DLL GCC do obsługi typu __float128 dla Windows
458License: GPL v2+ with linking exception
459Group: Applications/Emulators
460Requires: wine
461
462%description -n crossmingw32-libquadmath-dll
463DLL GCC __float128 support library for Windows.
464
465%description -n crossmingw32-libquadmath-dll -l pl.UTF-8
466Biblioteka DLL GCC do obsługi typu __float128 dla Windows.
467
d3f237e2 468%package java
8c4c66e6
JB
469Summary: MinGW32 binary utility development utilities - Java
470Summary(pl.UTF-8): Zestaw narzędzi MinGW32 - Java
d3f237e2 471Group: Development/Languages
cae974d4 472Requires: %{name} = %{epoch}:%{version}-%{release}
d3f237e2
JB
473
474%description java
475crossmingw32 is a complete cross-compiling development system for
476building stand-alone Microsoft Windows applications under Linux using
8c4c66e6 477the MinGW32 build libraries. This includes a binutils, gcc with g++
d3f237e2
JB
478and objc, and libstdc++, all cross targeted to i386-mingw32, along
479with supporting Win32 libraries in 'coff' format from free sources.
480
37948e2b 481This package contains cross targeted Java compiler.
d3f237e2 482
4a6c89d0 483%description java -l pl.UTF-8
4a6c89d0 484crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
485pozwalającym budować aplikacje MS Windows pod Linuksem używając
8c4c66e6 486bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
4a6c89d0 487libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
2e5b9011 488z bibliotek w formacie COFF.
d790a8ba 489
4a6c89d0 490Ten pakiet zawiera kompilator Javy generujący kod pod Win32.
d790a8ba 491
d3f237e2 492%prep
dee9b92f 493%setup -q -n gcc-%{version}
83afd976
ŁK
494%patch100 -p0
495%patch0 -p1
496%patch2 -p1
14b9b67e 497%patch3 -p1
da54ab64 498%patch4 -p1
83afd976 499
b399bc1a 500%if %{with bootstrap}
ba1fe36b
JB
501# note: "winsup" dir is special, handled by gcc's configure
502install -d winsup/mingw
503tar xf %{SOURCE1} -C winsup/mingw
b399bc1a 504%endif
83afd976
ŁK
505
506# override snapshot version.
507echo %{version} > gcc/BASE-VER
508echo "release" > gcc/DEV-PHASE
b336056d
JB
509
510%build
da54ab64
JB
511cd libvtv
512%{__aclocal} -I .. -I ../config
513%{__autoconf}
514%{__automake}
515cd ..
516
73ff33c1 517rm -rf builddir && install -d builddir && cd builddir
b399bc1a 518%if %{with bootstrap}
73ff33c1 519install -d %{target}/winsup
73ff33c1 520ln -sf ../../../winsup/mingw/lib %{target}/winsup/mingw
ba1fe36b 521ln -sf ../../../winsup/mingw/include %{target}/winsup/w32api
73ff33c1 522WINSUPDIR=$(cd ..; pwd)/winsup
b399bc1a
AF
523%endif
524
da54ab64 525# note: libbacktrace requires at least i486 now
83afd976 526CC="%{__cc}" \
b4c37c30 527CFLAGS="%{rpmcflags}" \
83afd976 528CXXFLAGS="%{rpmcxxflags}" \
b4c37c30 529TEXCONFIG=false \
da54ab64
JB
530CFLAGS_FOR_TARGET="-O2 -march=i486" \
531CXXFLAGS_FOR_TARGET="-O2 -march=i486" \
b336056d 532../configure \
8f1d5c0c 533 --prefix=%{sysprefix} \
77399965 534 --bindir=%{archbindir} \
73ff33c1 535 --libdir=%{_libdir} \
77399965 536 --includedir=%{archincludedir} \
a7ca5423 537 --libexecdir=%{_libdir} \
b336056d
JB
538 --infodir=%{_infodir} \
539 --mandir=%{_mandir} \
77399965
JB
540 --with-bugurl="http://bugs.pld-linux.org" \
541 --with-build-time-tools=%{archbindir} \
542 %{!?with_bootstrap:--with-headers=%{archincludedir}} \
543 --with-libs=%{!?with_bootstrap:%{archlibdir}}%{?with_bootstrap:${WINSUPDIR}/mingw/lib} \
14b9b67e 544 --with-demangler-in-ld \
83afd976
ŁK
545 --with-dwarf2 \
546 --with-gnu-as \
547 --with-gnu-ld \
83afd976 548 --with-long-double-128 \
77399965 549 --with-pkgversion="PLD-Linux" \
14b9b67e
JB
550 --enable-c99 \
551 --enable-fully-dynamic-string \
6ccf21dc 552 --disable-isl-version-check \
14b9b67e 553 --enable-languages="c,c++,fortran,java,objc,obj-c++" \
14b9b67e
JB
554 --disable-libcc1 \
555 --enable-libgomp%{!?with_gomp:=no} \
556 --disable-libssp \
83afd976 557 --enable-libstdcxx-allocator=new \
14b9b67e 558 --enable-linker-build-id \
6ccf21dc 559 --enable-long-long \
14b9b67e 560 --enable-lto \
6ccf21dc 561 --disable-multilib \
0dcd3a97 562 --disable-nls \
da54ab64 563 --enable-shared \
83afd976 564 --disable-sjlj-exceptions \
6ccf21dc 565 --disable-symvers \
da54ab64 566 --enable-threads \
14b9b67e
JB
567 --enable-version-specific-runtime-libs \
568 --disable-werror \
83afd976 569 --disable-win32-registry \
b336056d
JB
570 --target=%{target}
571
83afd976
ŁK
572cd ..
573%{__make} -C builddir all-host
574patch -p1 <%{PATCH1}
575%{__make} -C builddir
b336056d
JB
576
577%install
b336056d 578rm -rf $RPM_BUILD_ROOT
73ff33c1 579install -d $RPM_BUILD_ROOT%{_bindir}
b336056d 580
83afd976 581%{__make} -C builddir install \
d12aabe0 582 DESTDIR=$RPM_BUILD_ROOT
b336056d 583
14b9b67e 584%{__mv} $RPM_BUILD_ROOT%{gcclibdir}/include-fixed/{limits,syslimits}.h $RPM_BUILD_ROOT%{gcclibdir}/include
73ff33c1
JB
585%{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/include-fixed
586%{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/install-tools
d12aabe0 587
82f2d40f 588# these must be symlinks: gcclibdir is calculated relatively to real binary path
77399965
JB
589ln -sf %{archbindir}/%{target}-gcc $RPM_BUILD_ROOT%{_bindir}/%{target}-gcc
590ln -sf %{archbindir}/%{target}-g++ $RPM_BUILD_ROOT%{_bindir}/%{target}-g++
591ln -sf %{archbindir}/%{target}-cpp $RPM_BUILD_ROOT%{_bindir}/%{target}-cpp
592ln -sf %{archbindir}/%{target}-gcov $RPM_BUILD_ROOT%{_bindir}/%{target}-gcov
593ln -sf %{archbindir}/%{target}-gcov-dump $RPM_BUILD_ROOT%{_bindir}/%{target}-gcov-dump
594ln -sf %{archbindir}/%{target}-gcov-tool $RPM_BUILD_ROOT%{_bindir}/%{target}-gcov-tool
595ln -sf %{archbindir}/%{target}-gcj $RPM_BUILD_ROOT%{_bindir}/%{target}-gcj
596ln -sf %{archbindir}/%{target}-jcf-dump $RPM_BUILD_ROOT%{_bindir}/%{target}-jcf-dump
597ln -sf %{archbindir}/%{target}-gfortran $RPM_BUILD_ROOT%{_bindir}/%{target}-gfortran
83afd976 598
73ff33c1
JB
599# DLLs
600install -d $RPM_BUILD_ROOT%{_dlldir}
14b9b67e
JB
601%{__mv} $RPM_BUILD_ROOT%{gccarchdir}/*.dll $RPM_BUILD_ROOT%{_dlldir}
602%{__mv} $RPM_BUILD_ROOT%{gcclibdir}/*.dll $RPM_BUILD_ROOT%{_dlldir}
8f1d5c0c
JB
603if [ ! -f $RPM_BUILD_ROOT%{_dlldir}/libgcc_s_dw2-1.dll ]; then
604 echo "libgcc DLL not installed?"
605 install builddir/i386-mingw32/libgcc/shlib/libgcc_s_dw2-1.dll $RPM_BUILD_ROOT%{_dlldir}
606fi
d12aabe0 607
73ff33c1
JB
608%if 0%{!?debug:1}
609%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
d33f98c7 610%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{gcclibdir}/lib*.a
73ff33c1 611%endif
83afd976 612
6ccf21dc 613# avoid -L poisoning in *.la
da54ab64 614for f in libatomic.la libcaf_single.la libgfortran.la libobjc.la libquadmath.la %{?with_gomp:libgomp.la} ; do
6ccf21dc
JB
615 file="$RPM_BUILD_ROOT%{gcclibdir}/$f"
616 %{__perl} %{SOURCE2} "$file" %{gcclibdir} >"${file}.fixed"
617 %{__mv} "${file}.fixed" "$file"
618done
619
b07ce80e
JB
620# for pretty-printers see native gcc
621%{__rm} $RPM_BUILD_ROOT%{gcclibdir}/libstdc++.dll.a-gdb.py
622%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/gcc-%{version}/python/libstdcxx
4b27d406
JB
623# no plugin development for mingw32 (at least for now)
624%{__rm} $RPM_BUILD_ROOT%{gcclibdir}/liblto_plugin.la
b07ce80e 625%{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/plugin
73ff33c1
JB
626# already in native gcc
627%{__rm} -r $RPM_BUILD_ROOT%{_infodir}
628# common FSF man pages
629%{__rm} $RPM_BUILD_ROOT%{_mandir}/man7/{fsf-funding,gfdl,gpl}.7
7f7a2048
JB
630# programs not packaged
631%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/%{target}-{aot-compile,gc-analyze,gcj-dbtool,gij,grmic,jv-convert,rebuild-gcj-db}.1
8c4c66e6 632
b336056d 633%clean
b336056d
JB
634rm -rf $RPM_BUILD_ROOT
635
636%files
637%defattr(644,root,root,755)
83afd976 638%attr(755,root,root) %{_bindir}/%{target}-gcc
b4c37c30 639%attr(755,root,root) %{_bindir}/%{target}-cpp
640%attr(755,root,root) %{_bindir}/%{target}-gcov
da54ab64 641%attr(755,root,root) %{_bindir}/%{target}-gcov-dump
14b9b67e 642%attr(755,root,root) %{_bindir}/%{target}-gcov-tool
77399965
JB
643%attr(755,root,root) %{archbindir}/%{target}-gcc
644%attr(755,root,root) %{archbindir}/%{target}-gcc-%{version}
645%attr(755,root,root) %{archbindir}/%{target}-gcc-ar
646%attr(755,root,root) %{archbindir}/%{target}-gcc-nm
647%attr(755,root,root) %{archbindir}/%{target}-gcc-ranlib
648%attr(755,root,root) %{archbindir}/%{target}-cpp
649%attr(755,root,root) %{archbindir}/%{target}-gcov
650%attr(755,root,root) %{archbindir}/%{target}-gcov-dump
651%attr(755,root,root) %{archbindir}/%{target}-gcov-tool
73ff33c1
JB
652%dir %{gccarchdir}
653%dir %{gcclibdir}
654%attr(755,root,root) %{gcclibdir}/cc1
655%attr(755,root,root) %{gcclibdir}/collect2
656%attr(755,root,root) %{gcclibdir}/lto-wrapper
4b27d406
JB
657%attr(755,root,root) %{gcclibdir}/lto1
658%attr(755,root,root) %{gcclibdir}/liblto_plugin.so*
73ff33c1
JB
659%{gcclibdir}/libgcc.a
660%{gcclibdir}/libgcc_eh.a
661%{gcclibdir}/libgcc_s.a
662%{gcclibdir}/libgcov.a
00383376
AF
663%{gcclibdir}/crtbegin.o
664%{gcclibdir}/crtend.o
665%{gcclibdir}/crtfastmath.o
73ff33c1
JB
666%dir %{gcclibdir}/include
667%{gcclibdir}/include/*.h
539d7886 668%{_mandir}/man1/%{target}-cpp.1*
d3f237e2 669%{_mandir}/man1/%{target}-gcc.1*
539d7886 670%{_mandir}/man1/%{target}-gcov.1*
da54ab64
JB
671%{_mandir}/man1/%{target}-gcov-dump.1*
672%{_mandir}/man1/%{target}-gcov-tool.1*
d3f237e2 673
73ff33c1
JB
674%files -n crossmingw32-libgcc-dll
675%defattr(644,root,root,755)
676%{_dlldir}/libgcc_s_dw2-1.dll
677
14b9b67e
JB
678%files -n crossmingw32-libatomic
679%defattr(644,root,root,755)
680%{gcclibdir}/libatomic.dll.a
681%{gcclibdir}/libatomic.la
682
683%files -n crossmingw32-libatomic-static
684%defattr(644,root,root,755)
685%{gcclibdir}/libatomic.a
686
687%files -n crossmingw32-libatomic-dll
688%defattr(644,root,root,755)
689%{_dlldir}/libatomic-1.dll
690
6ccf21dc
JB
691%if %{with gomp}
692%files -n crossmingw32-libgomp
693%defattr(644,root,root,755)
694%{gcclibdir}/libgomp.dll.a
695%{gcclibdir}/libgomp.la
696%{gcclibdir}/libgomp.spec
697
698%files -n crossmingw32-libgomp-static
699%defattr(644,root,root,755)
700%{gcclibdir}/libgomp.a
701
702%files -n crossmingw32-libgomp-dll
703%defattr(644,root,root,755)
704%{_dlldir}/libgomp-1.dll
705%endif
706
14b9b67e
JB
707%files -n crossmingw32-libvtv
708%defattr(644,root,root,755)
709%{gcclibdir}/libvtv.dll.a
710%{gcclibdir}/libvtv.la
711%{gcclibdir}/libvtv_stubs.dll.a
712%{gcclibdir}/libvtv_stubs.la
713
714%files -n crossmingw32-libvtv-static
715%defattr(644,root,root,755)
716%{gcclibdir}/libvtv.a
717%{gcclibdir}/libvtv_stubs.a
718
719%files -n crossmingw32-libvtv-dll
720%defattr(644,root,root,755)
721%{_dlldir}/libvtv-0.dll
722%{_dlldir}/libvtv_stubs-0.dll
723
d3f237e2
JB
724%files c++
725%defattr(644,root,root,755)
83afd976 726%attr(755,root,root) %{_bindir}/%{target}-g++
77399965
JB
727%attr(755,root,root) %{archbindir}/%{target}-c++
728%attr(755,root,root) %{archbindir}/%{target}-g++
73ff33c1
JB
729%attr(755,root,root) %{gcclibdir}/cc1plus
730%{gcclibdir}/libstdc++.dll.a
731%{gcclibdir}/libstdc++.la
732%{gcclibdir}/libsupc++.la
733%{gcclibdir}/libsupc++.a
73ff33c1 734%{gcclibdir}/include/c++
d3f237e2
JB
735%{_mandir}/man1/%{target}-g++.1*
736
73ff33c1
JB
737%files -n crossmingw32-libstdc++-static
738%defattr(644,root,root,755)
739%{gcclibdir}/libstdc++.a
740
741%files -n crossmingw32-libstdc++-dll
742%defattr(644,root,root,755)
743%{_dlldir}/libstdc++-6.dll
744
d3f237e2
JB
745%files objc
746%defattr(644,root,root,755)
14b9b67e 747%doc libobjc/README
8f1d5c0c
JB
748%attr(755,root,root) %{gcclibdir}/cc1obj
749%{gcclibdir}/libobjc.dll.a
750%{gcclibdir}/libobjc.la
751%{gcclibdir}/include/objc
d3f237e2 752
14b9b67e
JB
753%files objc++
754%defattr(644,root,root,755)
755%doc gcc/objcp/ChangeLog
756%attr(755,root,root) %{gcclibdir}/cc1objplus
757
8f1d5c0c
JB
758%files -n crossmingw32-libobjc-static
759%defattr(644,root,root,755)
760%{gcclibdir}/libobjc.a
761
762%files -n crossmingw32-libobjc-dll
763%defattr(644,root,root,755)
669fa8b1 764%{_dlldir}/libobjc-4.dll
8f1d5c0c 765
52a544a1 766%files fortran
d3f237e2 767%defattr(644,root,root,755)
52a544a1 768%attr(755,root,root) %{_bindir}/%{target}-gfortran
77399965 769%attr(755,root,root) %{archbindir}/%{target}-gfortran
7f7a2048 770%attr(755,root,root) %{gcclibdir}/f951
0d9cd0a8 771%{gcclibdir}/finclude
669fa8b1
JB
772%{gcclibdir}/libcaf_single.a
773%{gcclibdir}/libcaf_single.la
0d9cd0a8
JB
774%{gcclibdir}/libgfortran.dll.a
775%{gcclibdir}/libgfortran.la
b07ce80e 776%{gcclibdir}/libgfortran.spec
52a544a1 777%{_mandir}/man1/%{target}-gfortran.1*
0d9cd0a8
JB
778
779%files -n crossmingw32-libgfortran-static
780%defattr(644,root,root,755)
781%{gcclibdir}/libgfortran.a
782
783%files -n crossmingw32-libgfortran-dll
784%defattr(644,root,root,755)
785%{_dlldir}/libgfortran-3.dll
d3f237e2 786
b07ce80e
JB
787%files -n crossmingw32-libquadmath
788%defattr(644,root,root,755)
789%{gcclibdir}/libquadmath.dll.a
790%{gcclibdir}/libquadmath.la
791
792%files -n crossmingw32-libquadmath-static
793%defattr(644,root,root,755)
794%{gcclibdir}/libquadmath.a
795
796%files -n crossmingw32-libquadmath-dll
797%defattr(644,root,root,755)
798%{_dlldir}/libquadmath-0.dll
799
d3f237e2
JB
800%files java
801%defattr(644,root,root,755)
802%attr(755,root,root) %{_bindir}/%{target}-gcj
7fc2a2bb 803%attr(755,root,root) %{_bindir}/%{target}-jcf-dump
77399965
JB
804%attr(755,root,root) %{archbindir}/%{target}-gcj
805%attr(755,root,root) %{archbindir}/%{target}-jcf-dump
7f7a2048
JB
806%attr(755,root,root) %{gcclibdir}/jc1
807%attr(755,root,root) %{gcclibdir}/jvgenmain
d12aabe0 808%{_mandir}/man1/%{target}-gcj.1*
539d7886 809%{_mandir}/man1/%{target}-jcf-dump.1*
This page took 0.208324 seconds and 4 git commands to generate.