]> git.pld-linux.org Git - packages/crossmingw32-gcc.git/blame - crossmingw32-gcc.spec
- updated to 5.4.0 (with C++14 support)
[packages/crossmingw32-gcc.git] / crossmingw32-gcc.spec
CommitLineData
a3bdc2a1 1#
2# Conditional build:
6ccf21dc
JB
3%bcond_with bootstrap # bootstrap build (using binary w32api/mingwrt, no gomp)
4%bcond_without gomp # OpenMP libraries
a3bdc2a1 5#
6ccf21dc
JB
6%if %{with bootstrap}
7%undefine with_gomp
8%endif
8c4c66e6
JB
9Summary: Cross MinGW32 GNU binary utility development utilities - gcc
10Summary(es.UTF-8): Utilitarios para desarrollo de binarios de la GNU - MinGW32 gcc
11Summary(fr.UTF-8): Utilitaires de développement binaire de GNU - MinGW32 gcc
12Summary(pl.UTF-8): Skrośne narzędzia programistyczne GNU dla MinGW32 - gcc
13Summary(pt_BR.UTF-8): Utilitários para desenvolvimento de binários da GNU - MinGW32 gcc
14Summary(tr.UTF-8): GNU geliştirme araçları - MinGW32 gcc
b336056d 15Name: crossmingw32-gcc
14b9b67e
JB
16Version: 5.4.0
17Release: 1
d3f237e2 18Epoch: 1
acb9fe67 19License: GPL v3+
d3f237e2 20Group: Development/Languages
26277b32 21Source0: https://ftp.gnu.org/gnu/gcc/gcc-%{version}/gcc-%{version}.tar.bz2
14b9b67e 22# Source0-md5: 4c626ac2a83ef30dfb9260e6f59c2b30
ba1fe36b
JB
23%define mingw32_ver 4.0.3
24Source1: http://downloads.sourceforge.net/mingw/mingwrt-%{mingw32_ver}-1-mingw32-dev.tar.lzma
25# Source1-md5: c2c9aa82e0cb47abac01760525684858
6ccf21dc 26Source2: gcc-optimize-la.pl
14b9b67e 27# svn diff -x --ignore-eol-style --force svn://gcc.gnu.org/svn/gcc/tags/gcc_5_4_0_release svn://gcc.gnu.org/svn/gcc/branches/gcc-5-branch > gcc-branch.diff
83afd976 28Patch100: gcc-branch.diff
14b9b67e 29# Patch100-md5: 8211f0f6f0a2179e51b4ac42f91bd44d
83afd976
ŁK
30Patch0: %{name}-buildsystem1.patch
31Patch1: %{name}-buildsystem2.patch
32Patch2: %{name}-lfs.patch
14b9b67e 33Patch3: gcc-mingw32.patch
6ccf21dc 34URL: http://gcc.gnu.org/
669fa8b1 35BuildRequires: autoconf >= 2.64
14b9b67e 36BuildRequires: automake >= 1:1.11.1
d12aabe0 37BuildRequires: bison
14b9b67e 38BuildRequires: crossmingw32-binutils >= 2.23
6ccf21dc
JB
39%{?with_gomp:BuildRequires: crossmingw32-pthreads-w32}
40%if %{without bootstrap}
41BuildRequires: crossmingw32-runtime >= 3.5
42BuildRequires: crossmingw32-w32api >= 3.1
43%endif
14b9b67e
JB
44BuildRequires: flex >= 2.5.4
45BuildRequires: gettext-tools >= 0.14.5
46BuildRequires: gmp-devel >= 4.3.2
47BuildRequires: isl-devel >= 0.14
48BuildRequires: libmpc-devel >= 0.8.1
49BuildRequires: mpfr-devel >= 2.4.2
207a380a 50BuildRequires: perl-tools-pod
14b9b67e
JB
51BuildRequires: texinfo >= 4.7
52BuildRequires: zlib-devel
73ff33c1
JB
53%if %{with booststrap}
54BuildRequires: tar >= 1:1.22
55BuildRequires: xz
56%endif
14b9b67e
JB
57BuildConflicts: pdksh < 5.2.14-50
58Requires: crossmingw32-binutils >= 2.23
6ab368b0 59Requires: gcc-dirs
14b9b67e
JB
60Requires: gmp >= 4.3.2
61Requires: isl >= 0.14
62Requires: libmpc >= 0.8.1
63Requires: mpfr >= 2.4.2
b336056d
JB
64BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
d3f237e2 66%define target i386-mingw32
8f1d5c0c
JB
67%define sysprefix /usr
68%define arch %{sysprefix}/%{target}
73ff33c1
JB
69%define gccarchdir %{_libdir}/gcc/%{target}
70%define gcclibdir %{gccarchdir}/%{version}
71%define _dlldir /usr/share/wine/windows/system
dee9b92f 72
5b936a1d 73%define _noautostrip .*/lib.*\\.a
b336056d 74
66f480ce
JP
75%define _enable_debug_packages 0
76
45ff11c2
JR
77# functions with printf format attribute but with special parser and also
78# receiving non constant format strings
79%define Werror_cflags %{nil}
42fa9439 80%define _ssp_cflags %{nil}
c07647a9
JB
81# -fPIC is not valid for target platform
82%define filterout_c -fPIC
42fa9439 83
b336056d
JB
84%description
85crossmingw32 is a complete cross-compiling development system for
86building stand-alone Microsoft Windows applications under Linux using
8c4c66e6 87the MinGW32 build libraries. This includes a binutils, gcc with g++
b336056d
JB
88and objc, and libstdc++, all cross targeted to i386-mingw32, along
89with supporting Win32 libraries in 'coff' format from free sources.
90
d3f237e2 91This package contains cross targeted gcc.
b336056d 92
4a6c89d0 93%description -l de.UTF-8
94Dieses Paket enthält einen Cross-gcc, der es erlaubt, auf einem
95anderem Rechner Code für Win32 zu generieren.
9dd4c848 96
4a6c89d0 97%description -l pl.UTF-8
98crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
99pozwalającym budować aplikacje MS Windows pod Linuksem używając
8c4c66e6 100bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
4a6c89d0 101libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
2e5b9011 102z bibliotek w formacie COFF.
d790a8ba 103
4a6c89d0 104Ten pakiet zawiera gcc generujące skrośnie kod dla Win32.
d790a8ba 105
73ff33c1
JB
106%package -n crossmingw32-libgcc-dll
107Summary: libgcc DLL library for Windows
108Summary(pl.UTF-8): Biblioteka DLL libgcc dla Windows
109Group: Applications/Emulators
110Requires: wine
111
112%description -n crossmingw32-libgcc-dll
113libgcc DLL library for Windows.
114
115%description -n crossmingw32-libgcc-dll -l pl.UTF-8
116Biblioteka DLL libgcc dla Windows.
117
14b9b67e
JB
118%package -n crossmingw32-libatomic
119Summary: The GNU Atomic library - cross MinGW32 version
120Summary(pl.UTF-8): Biblioteka GNU Atomic - wersja skrośna MinGW32
121License: GPL v3+ with GCC Runtime Library Exception v3.1
122Group: Development/Libraries
123Requires: %{name} = %{epoch}:%{version}-%{release}
124
125%description -n crossmingw32-libatomic
126This package contains cross MinGW32 version of the GNU Atomic library
127which is a GCC support library for atomic operations not supported by
128hardware.
129
130%description -n crossmingw32-libatomic -l pl.UTF-8
131Ten pakiet zawiera wersję skrośną MinGW32 biblioteki GNU Atomic,
132będącej biblioteką GCC, wspierającej operacje atomowe na sprzęcie ich
133nie obsługującym.
134
135%package -n crossmingw32-libatomic-static
136Summary: The GNU Atomic static library - cross MinGW32 version
137Summary(pl.UTF-8): Statyczna biblioteka GNU Atomic - wersja skrośna MinGW32
138License: GPL v3+ with GCC Runtime Library Exception v3.1
139Group: Development/Libraries
140Requires: crossmingw32-libatomic = %{epoch}:%{version}-%{release}
141
142%description -n crossmingw32-libatomic-static
143The GNU Atomic static library - cross MinGW32 version.
144
145%description -n crossmingw32-libatomic-static
146Statyczna biblioteka GNU Atomic - wersja skrośna MinGW32.
147
148%package -n crossmingw32-libatomic-dll
149Summary: DLL GNU Atomic library for Windows
150Summary(pl.UTF-8): Biblioteka DLL GNU Atomic dla Windows
151License: GPL v3+ with GCC Runtime Library Exception v3.1
152Group: Applications/Emulators
153Requires: wine
154
155%description -n crossmingw32-libatomic-dll
156DLL GNU Atomic library for Windows.
157
158%description -n crossmingw32-libatomic-dll -l pl.UTF-8
159Biblioteka DLL GNU Atomic dla Windows.
160
6ccf21dc
JB
161%package -n crossmingw32-libgomp
162Summary: GNU OpenMP library - cross MinGW32 version
163Summary(pl.UTF-8): Biblioteka GNU OpenMP - wersja skrośna MinGW32
164License: GPL v3+ with GCC Runtime Library Exception v3.1
165Group: Development/Libraries
166Requires: %{name} = %{epoch}:%{version}-%{release}
167
168%description -n crossmingw32-libgomp
169This package contains cross MinGW32 version of GNU OpenMP library.
170
171%description -n crossmingw32-libgomp -l pl.UTF-8
172Ten pakiet zawiera wersję skrośną MinGW32 biblioteki GNU OpenMP.
173
174%package -n crossmingw32-libgomp-static
175Summary: Static GNU OpenMP library - cross MinGW32 version
176Summary(pl.UTF-8): Statyczna biblioteka GNU OpenMP - wersja skrośna MinGW32
177License: GPL v3+ with GCC Runtime Library Exception v3.1
178Group: Development/Libraries
179Requires: crossmingw32-libgomp = %{epoch}:%{version}-%{release}
180
181%description -n crossmingw32-libgomp-static
182Static GNU OpenMP library - cross MinGW32 version.
183
184%description -n crossmingw32-libgomp-static -l pl.UTF-8
185Statyczna biblioteka GNU OpenMP - wersja skrośna MinGW32.
186
187%package -n crossmingw32-libgomp-dll
188Summary: DLL GNU OpenMP library for Windows
189Summary(pl.UTF-8): Biblioteka DLL GNU OpenMP dla Windows
190License: GPL v3+ with GCC Runtime Library Exception v3.1
14b9b67e 191Group: Applications/Emulators
6ccf21dc 192Requires: crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
e49d4dab 193Requires: crossmingw32-pthreads-w32-dll
6ccf21dc
JB
194
195%description -n crossmingw32-libgomp-dll
196DLL GNU OpenMP library for Windows.
197
198%description -n crossmingw32-libgomp-dll -l pl.UTF-8
199Biblioteka DLL GNU OpenMP dla Windows.
200
14b9b67e
JB
201%package -n crossmingw32-libvtv
202Summary: The Virtual Table Verification library - cross MinGW32 version
203Summary(pl.UTF-8): Biblioteka Virtual Table Verification do weryfikacji tablicy wirtualnej - wersja skrośna MinGW32
204License: GPL v3+ with GCC Runtime Library Exception v3.1
205Group: Development/Libraries
206URL: https://gcc.gnu.org/wiki/vtv
207Requires: %{name} = %{epoch}:%{version}-%{release}
208
209%description -n crossmingw32-libvtv
210This package contains cross MinGW32 version of the Virtual Table
211Verification library which is used for -fvtable-verify=...
212instrumented programs.
213
214%description -n crossmingw32-libvtv -l pl.UTF-8
215Ten pakiet zawiera wersję skrośną MinGW32 biblioteki Virtual Table
216Verification, służącej do weryfikacji tablicy wirtualnej w programach
217kompilowanych z opcją -fvtable-verify=....
218
219%package -n crossmingw32-libvtv-static
220Summary: The Virtual Table Verification static library - cross MinGW32 version
221Summary(pl.UTF-8): Statyczna biblioteka Virtual Table Verification - wersja skrośna MinGW32
222License: GPL v3+ with GCC Runtime Library Exception v3.1
223Group: Development/Libraries
224URL: https://gcc.gnu.org/wiki/vtv
225Requires: crossmingw32-libvtv = %{epoch}:%{version}-%{release}
226
227%description -n crossmingw32-libvtv-static
228The Virtual Table Verification static library - cross MinGW32 version.
229
230%description -n crossmingw32-libvtv-static -l pl.UTF-8
231Statyczna biblioteka Virtual Table Verification - wersja skrośna
232MinGW32.
233
234%package -n crossmingw32-libvtv-dll
235Summary: DLL Virtual Table Verification libraries for Windows
236Summary(pl.UTF-8): Biblioteki DLL Virtual Table Verification dla Windows
237License: GPL v3+ with GCC Runtime Library Exception v3.1
238Group: Applications/Emulators
239URL: https://gcc.gnu.org/wiki/vtv
240Requires: crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
241
242%description -n crossmingw32-libvtv-dll
243DLL Virtual Table Verification libraries for Windows.
244
245%description -n crossmingw32-libvtv-dll -l pl.UTF-8
246Biblioteki DLL Virtual Table Verification dla Windows.
247
d3f237e2 248%package c++
8c4c66e6
JB
249Summary: MinGW32 binary utility development utilities - g++
250Summary(pl.UTF-8): Zestaw narzędzi MinGW32 - g++
d3f237e2 251Group: Development/Languages
cae974d4 252Requires: %{name} = %{epoch}:%{version}-%{release}
b336056d 253
d3f237e2
JB
254%description c++
255crossmingw32 is a complete cross-compiling development system for
256building stand-alone Microsoft Windows applications under Linux using
8c4c66e6 257the MinGW32 build libraries. This includes a binutils, gcc with g++
d3f237e2
JB
258and objc, and libstdc++, all cross targeted to i386-mingw32, along
259with supporting Win32 libraries in 'coff' format from free sources.
260
261This package contains cross targeted g++ and (static) libstdc++.
262
4a6c89d0 263%description c++ -l pl.UTF-8
264crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
265pozwalającym budować aplikacje MS Windows pod Linuksem używając
8c4c66e6 266bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
4a6c89d0 267libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
2e5b9011 268z bibliotek w formacie COFF.
d790a8ba 269
4a6c89d0 270Ten pakiet zawiera g++ generujące kod pod Win32 oraz bibliotekę
d790a8ba
JB
271libstdc++.
272
73ff33c1
JB
273%package -n crossmingw32-libstdc++-static
274Summary: Static standard C++ library - cross MinGW32 version
275Summary(pl.UTF-8): Statyczna biblioteka standardowa C++ - wersja skrośna MinGW32
276Group: Development/Libraries
277Requires: %{name}-c++ = %{epoch}:%{version}-%{release}
278
279%description -n crossmingw32-libstdc++-static
280Static standard C++ library - cross MinGW32 version.
281
282%description -n crossmingw32-libstdc++-static -l pl.UTF-8
283Statyczna biblioteka standardowa C++ - wersja skrośna MinGW32.
284
285%package -n crossmingw32-libstdc++-dll
286Summary: libstdc++ DLL library for Windows
287Summary(pl.UTF-8): Biblioteka DLL libstdc++ dla Windows
288Group: Applications/Emulators
289Requires: crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
290Requires: wine
291
292%description -n crossmingw32-libstdc++-dll
293libstdc++ DLL library for Windows.
294
295%description -n crossmingw32-libstdc++-dll -l pl.UTF-8
296Biblioteka DLL libstdc++ dla Windows.
297
d3f237e2 298%package objc
8c4c66e6
JB
299Summary: MinGW32 binary utility development utilities - objc
300Summary(pl.UTF-8): Zestaw narzędzi MinGW32 - objc
d3f237e2 301Group: Development/Languages
cae974d4 302Requires: %{name} = %{epoch}:%{version}-%{release}
d3f237e2
JB
303
304%description objc
305crossmingw32 is a complete cross-compiling development system for
306building stand-alone Microsoft Windows applications under Linux using
8c4c66e6 307the MinGW32 build libraries. This includes a binutils, gcc with g++
d3f237e2
JB
308and objc, and libstdc++, all cross targeted to i386-mingw32, along
309with supporting Win32 libraries in 'coff' format from free sources.
310
37948e2b 311This package contains cross targeted objc compiler.
d3f237e2 312
4a6c89d0 313%description objc -l pl.UTF-8
314crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
315pozwalającym budować aplikacje MS Windows pod Linuksem używając
8c4c66e6 316bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
4a6c89d0 317libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
2e5b9011 318z bibliotek w formacie COFF.
d790a8ba 319
4a6c89d0 320Ten pakiet zawiera kompilator objc generujący kod pod Win32.
d790a8ba 321
14b9b67e
JB
322%package objc++
323Summary: MinGW32 binary utility development utilities - objc++
324Summary(pl.UTF-8): Zestaw narzędzi MinGW32 - objc++
325Group: Development/Languages
326Requires: %{name}-objc = %{epoch}:%{version}-%{release}
327
328%description objc++
329crossmingw32 is a complete cross-compiling development system for
330building stand-alone Microsoft Windows applications under Linux using
331the MinGW32 build libraries. This includes a binutils, gcc with g++
332and objc, and libstdc++, all cross targeted to i386-mingw32, along
333with supporting Win32 libraries in 'coff' format from free sources.
334
335This package contains Objective C++ support.
336
337%description objc++ -l pl.UTF-8
338crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
339pozwalającym budować aplikacje MS Windows pod Linuksem używając
340bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
341libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
342z bibliotek w formacie COFF.
343
344Ten pakiet zawiera obsługę języka Objective C++.
345
8f1d5c0c
JB
346%package -n crossmingw32-libobjc-static
347Summary: Static Objective C library - cross MinGW32 version
348Summary(pl.UTF-8): Statyczna biblioteka Objective C - wersja skrośna MinGW32
349Group: Development/Libraries
350Requires: %{name}-objc = %{epoch}:%{version}-%{release}
351
352%description -n crossmingw32-libobjc-static
353Static Objective C library - cross MinGW32 version.
354
355%description -n crossmingw32-libobjc-static -l pl.UTF-8
356Statyczna biblioteka Objective C - wersja skrośna MinGW32.
357
358%package -n crossmingw32-libobjc-dll
359Summary: libobjc DLL library for Windows
360Summary(pl.UTF-8): Biblioteka DLL libobjc dla Windows
361Group: Applications/Emulators
362Requires: crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
363Requires: wine
364
365%description -n crossmingw32-libobjc-dll
366libobjc DLL library for Windows.
367
368%description -n crossmingw32-libobjc-dll -l pl.UTF-8
369Biblioteka DLL libobjc dla Windows.
370
52a544a1 371%package fortran
8c4c66e6
JB
372Summary: MinGW32 binary utility development utilities - Fortran
373Summary(pl.UTF-8): Zestaw narzędzi MinGW32 - Fortran
d3f237e2 374Group: Development/Languages
cae974d4 375Requires: %{name} = %{epoch}:%{version}-%{release}
ed6b55ce 376Requires: crossmingw32-libquadmath = %{epoch}:%{version}-%{release}
37948e2b 377Obsoletes: crossmingw32-gcc-g77
d3f237e2 378
52a544a1 379%description fortran
d3f237e2
JB
380crossmingw32 is a complete cross-compiling development system for
381building stand-alone Microsoft Windows applications under Linux using
8c4c66e6 382the MinGW32 build libraries. This includes a binutils, gcc with g++
d3f237e2
JB
383and objc, and libstdc++, all cross targeted to i386-mingw32, along
384with supporting Win32 libraries in 'coff' format from free sources.
385
37948e2b 386This package contains cross targeted Fortran compiler.
d3f237e2 387
4a6c89d0 388%description fortran -l pl.UTF-8
389crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
390pozwalającym budować aplikacje MS Windows pod Linuksem używając
8c4c66e6 391bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
4a6c89d0 392libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
2e5b9011 393z bibliotek w formacie COFF.
d790a8ba 394
4a6c89d0 395Ten pakiet zawiera kompilator Fortranu generujący kod pod Win32.
d790a8ba 396
0d9cd0a8
JB
397%package -n crossmingw32-libgfortran-static
398Summary: Static Fortran library - cross MinGW32 version
6a795f6e 399Summary(pl.UTF-8): Statyczna biblioteka Fortranu - wersja skrośna MinGW32
0d9cd0a8
JB
400Group: Development/Libraries
401Requires: %{name}-fortran = %{epoch}:%{version}-%{release}
402
403%description -n crossmingw32-libgfortran-static
404Static Fortran library - cross MinGW32 version.
405
406%description -n crossmingw32-libgfortran-static -l pl.UTF-8
6a795f6e 407Statyczna biblioteka Fortranu - wersja skrośna MinGW32.
0d9cd0a8
JB
408
409%package -n crossmingw32-libgfortran-dll
410Summary: libgfortran DLL library for Windows
411Summary(pl.UTF-8): Biblioteka DLL libgfortran dla Windows
412Group: Applications/Emulators
b07ce80e 413Requires: crossmingw32-libquadmath-dll
0d9cd0a8
JB
414
415%description -n crossmingw32-libgfortran-dll
416libgfortran DLL library for Windows.
417
418%description -n crossmingw32-libgfortran-dll -l pl.UTF-8
419Biblioteka DLL libgfortran dla Windows.
420
b07ce80e
JB
421%package -n crossmingw32-libquadmath
422Summary: GCC __float128 support library - cross MinGW32 version
423Summary(pl.UTF-8): Biblioteka do obsługi typu __float128 - wersja skrośna MinGW32
424License: GPL v2+ with linking exception
425Group: Development/Libraries
426Requires: %{name} = %{epoch}:%{version}-%{release}
427
428%description -n crossmingw32-libquadmath
429This package contains cross MinGW32 version of GCC support library
430which is needed for __float128 math support and for Fortran REAL*16
431support.
432
433%description -n crossmingw32-libquadmath -l pl.UTF-8
434Ten pakiet zawiera wersję skrośną MinGW32 biblioteki GCC do obsługi
435operacji matematycznych na zmiennych typu __float128 oraz typu REAL*16
436w Fortranie.
437
438%package -n crossmingw32-libquadmath-static
439Summary: Static GCC __float128 support library - cross MinGW32 version
440Summary(pl.UTF-8): Biblioteka statyczna GCC do obsługi typu __float128 - wersja skrośna MinGW32
441License: GPL v2+ with linking exception
442Group: Development/Libraries
443Requires: crossmingw32-libquadmath = %{epoch}:%{version}-%{release}
444
445%description -n crossmingw32-libquadmath-static
446Static GCC __float128 support library - cross MinGW32 version.
447
448%description -n crossmingw32-libquadmath-static -l pl.UTF-8
449Biblioteka statyczna GCC do obsługi typu __float128 - wersja skrośna
450MinGW32.
451
452%package -n crossmingw32-libquadmath-dll
453Summary: DLL GCC __float128 support library for Windows
454Summary(pl.UTF-8): Biblioteka DLL GCC do obsługi typu __float128 dla Windows
455License: GPL v2+ with linking exception
456Group: Applications/Emulators
457Requires: wine
458
459%description -n crossmingw32-libquadmath-dll
460DLL GCC __float128 support library for Windows.
461
462%description -n crossmingw32-libquadmath-dll -l pl.UTF-8
463Biblioteka DLL GCC do obsługi typu __float128 dla Windows.
464
d3f237e2 465%package java
8c4c66e6
JB
466Summary: MinGW32 binary utility development utilities - Java
467Summary(pl.UTF-8): Zestaw narzędzi MinGW32 - Java
d3f237e2 468Group: Development/Languages
cae974d4 469Requires: %{name} = %{epoch}:%{version}-%{release}
d3f237e2
JB
470
471%description java
472crossmingw32 is a complete cross-compiling development system for
473building stand-alone Microsoft Windows applications under Linux using
8c4c66e6 474the MinGW32 build libraries. This includes a binutils, gcc with g++
d3f237e2
JB
475and objc, and libstdc++, all cross targeted to i386-mingw32, along
476with supporting Win32 libraries in 'coff' format from free sources.
477
37948e2b 478This package contains cross targeted Java compiler.
d3f237e2 479
4a6c89d0 480%description java -l pl.UTF-8
4a6c89d0 481crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
482pozwalającym budować aplikacje MS Windows pod Linuksem używając
8c4c66e6 483bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
4a6c89d0 484libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
2e5b9011 485z bibliotek w formacie COFF.
d790a8ba 486
4a6c89d0 487Ten pakiet zawiera kompilator Javy generujący kod pod Win32.
d790a8ba 488
d3f237e2 489%prep
dee9b92f 490%setup -q -n gcc-%{version}
83afd976
ŁK
491%patch100 -p0
492%patch0 -p1
493%patch2 -p1
14b9b67e 494%patch3 -p1
83afd976 495
b399bc1a 496%if %{with bootstrap}
ba1fe36b
JB
497# note: "winsup" dir is special, handled by gcc's configure
498install -d winsup/mingw
499tar xf %{SOURCE1} -C winsup/mingw
b399bc1a 500%endif
83afd976
ŁK
501
502# override snapshot version.
503echo %{version} > gcc/BASE-VER
504echo "release" > gcc/DEV-PHASE
b336056d
JB
505
506%build
73ff33c1 507rm -rf builddir && install -d builddir && cd builddir
b399bc1a 508%if %{with bootstrap}
73ff33c1 509install -d %{target}/winsup
73ff33c1 510ln -sf ../../../winsup/mingw/lib %{target}/winsup/mingw
ba1fe36b 511ln -sf ../../../winsup/mingw/include %{target}/winsup/w32api
73ff33c1 512WINSUPDIR=$(cd ..; pwd)/winsup
b399bc1a
AF
513%endif
514
83afd976 515CC="%{__cc}" \
b4c37c30 516CFLAGS="%{rpmcflags}" \
83afd976 517CXXFLAGS="%{rpmcxxflags}" \
b4c37c30 518TEXCONFIG=false \
b336056d 519../configure \
8f1d5c0c
JB
520 --prefix=%{sysprefix} \
521 --bindir=%{arch}/bin \
73ff33c1 522 --libdir=%{_libdir} \
8f1d5c0c 523 --includedir=%{arch}/include \
73ff33c1 524 --libexecdir=%{_libdir} \
b336056d
JB
525 --infodir=%{_infodir} \
526 --mandir=%{_mandir} \
6ccf21dc 527 --with-build-time-tools=%{arch}/bin \
73ff33c1
JB
528 %{!?with_bootstrap:--with-headers=%{arch}/include} \
529 --with-libs=%{!?with_bootstrap:%{arch}/lib}%{?with_bootstrap:${WINSUPDIR}/mingw/lib} \
14b9b67e 530 --with-demangler-in-ld \
83afd976
ŁK
531 --with-dwarf2 \
532 --with-gnu-as \
533 --with-gnu-ld \
83afd976 534 --with-long-double-128 \
14b9b67e
JB
535 --enable-c99 \
536 --enable-fully-dynamic-string \
6ccf21dc 537 --disable-isl-version-check \
14b9b67e 538 --enable-languages="c,c++,fortran,java,objc,obj-c++" \
6ccf21dc 539 --enable-shared \
0dcd3a97 540 --enable-threads \
14b9b67e
JB
541 --disable-libcc1 \
542 --enable-libgomp%{!?with_gomp:=no} \
543 --disable-libssp \
83afd976 544 --enable-libstdcxx-allocator=new \
14b9b67e 545 --enable-linker-build-id \
6ccf21dc 546 --enable-long-long \
14b9b67e 547 --enable-lto \
6ccf21dc 548 --disable-multilib \
0dcd3a97 549 --disable-nls \
83afd976 550 --disable-sjlj-exceptions \
6ccf21dc 551 --disable-symvers \
14b9b67e
JB
552 --enable-version-specific-runtime-libs \
553 --disable-werror \
83afd976 554 --disable-win32-registry \
b336056d
JB
555 --target=%{target}
556
83afd976
ŁK
557cd ..
558%{__make} -C builddir all-host
559patch -p1 <%{PATCH1}
560%{__make} -C builddir
b336056d
JB
561
562%install
b336056d 563rm -rf $RPM_BUILD_ROOT
73ff33c1 564install -d $RPM_BUILD_ROOT%{_bindir}
b336056d 565
83afd976 566%{__make} -C builddir install \
d12aabe0 567 DESTDIR=$RPM_BUILD_ROOT
b336056d 568
14b9b67e 569%{__mv} $RPM_BUILD_ROOT%{gcclibdir}/include-fixed/{limits,syslimits}.h $RPM_BUILD_ROOT%{gcclibdir}/include
73ff33c1
JB
570%{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/include-fixed
571%{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/install-tools
d12aabe0 572
82f2d40f
JB
573# these must be symlinks: gcclibdir is calculated relatively to real binary path
574ln -sf %{arch}/bin/%{target}-gcc $RPM_BUILD_ROOT%{_bindir}/%{target}-gcc
575ln -sf %{arch}/bin/%{target}-g++ $RPM_BUILD_ROOT%{_bindir}/%{target}-g++
576ln -sf %{arch}/bin/%{target}-cpp $RPM_BUILD_ROOT%{_bindir}/%{target}-cpp
577ln -sf %{arch}/bin/%{target}-gcov $RPM_BUILD_ROOT%{_bindir}/%{target}-gcov
14b9b67e 578ln -sf %{arch}/bin/%{target}-gcov-tool $RPM_BUILD_ROOT%{_bindir}/%{target}-gcov-tool
82f2d40f
JB
579ln -sf %{arch}/bin/%{target}-gcj $RPM_BUILD_ROOT%{_bindir}/%{target}-gcj
580ln -sf %{arch}/bin/%{target}-jcf-dump $RPM_BUILD_ROOT%{_bindir}/%{target}-jcf-dump
581ln -sf %{arch}/bin/%{target}-gfortran $RPM_BUILD_ROOT%{_bindir}/%{target}-gfortran
83afd976 582
73ff33c1
JB
583# DLLs
584install -d $RPM_BUILD_ROOT%{_dlldir}
14b9b67e
JB
585%{__mv} $RPM_BUILD_ROOT%{gccarchdir}/*.dll $RPM_BUILD_ROOT%{_dlldir}
586%{__mv} $RPM_BUILD_ROOT%{gcclibdir}/*.dll $RPM_BUILD_ROOT%{_dlldir}
8f1d5c0c
JB
587if [ ! -f $RPM_BUILD_ROOT%{_dlldir}/libgcc_s_dw2-1.dll ]; then
588 echo "libgcc DLL not installed?"
589 install builddir/i386-mingw32/libgcc/shlib/libgcc_s_dw2-1.dll $RPM_BUILD_ROOT%{_dlldir}
590fi
d12aabe0 591
73ff33c1
JB
592%if 0%{!?debug:1}
593%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
d33f98c7 594%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{gcclibdir}/lib*.a
73ff33c1 595%endif
83afd976 596
6ccf21dc
JB
597# avoid -L poisoning in *.la
598for f in libcaf_single.la libgfortran.la libgfortranbegin.la libobjc.la libquadmath.la %{?with_gomp:libgomp.la} ; do
599 file="$RPM_BUILD_ROOT%{gcclibdir}/$f"
600 %{__perl} %{SOURCE2} "$file" %{gcclibdir} >"${file}.fixed"
601 %{__mv} "${file}.fixed" "$file"
602done
603
b07ce80e
JB
604# for pretty-printers see native gcc
605%{__rm} $RPM_BUILD_ROOT%{gcclibdir}/libstdc++.dll.a-gdb.py
606%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/gcc-%{version}/python/libstdcxx
4b27d406
JB
607# no plugin development for mingw32 (at least for now)
608%{__rm} $RPM_BUILD_ROOT%{gcclibdir}/liblto_plugin.la
b07ce80e 609%{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/plugin
73ff33c1
JB
610# already in native gcc
611%{__rm} -r $RPM_BUILD_ROOT%{_infodir}
612# common FSF man pages
613%{__rm} $RPM_BUILD_ROOT%{_mandir}/man7/{fsf-funding,gfdl,gpl}.7
7f7a2048
JB
614# programs not packaged
615%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/%{target}-{aot-compile,gc-analyze,gcj-dbtool,gij,grmic,jv-convert,rebuild-gcj-db}.1
8c4c66e6 616
b336056d 617%clean
b336056d
JB
618rm -rf $RPM_BUILD_ROOT
619
620%files
621%defattr(644,root,root,755)
83afd976 622%attr(755,root,root) %{_bindir}/%{target}-gcc
b4c37c30 623%attr(755,root,root) %{_bindir}/%{target}-cpp
624%attr(755,root,root) %{_bindir}/%{target}-gcov
14b9b67e 625%attr(755,root,root) %{_bindir}/%{target}-gcov-tool
73ff33c1
JB
626%attr(755,root,root) %{arch}/bin/%{target}-gcc
627%attr(755,root,root) %{arch}/bin/%{target}-gcc-%{version}
669fa8b1
JB
628%attr(755,root,root) %{arch}/bin/%{target}-gcc-ar
629%attr(755,root,root) %{arch}/bin/%{target}-gcc-nm
630%attr(755,root,root) %{arch}/bin/%{target}-gcc-ranlib
83afd976
ŁK
631%attr(755,root,root) %{arch}/bin/%{target}-cpp
632%attr(755,root,root) %{arch}/bin/%{target}-gcov
14b9b67e 633%attr(755,root,root) %{arch}/bin/%{target}-gcov-tool
73ff33c1
JB
634%dir %{gccarchdir}
635%dir %{gcclibdir}
636%attr(755,root,root) %{gcclibdir}/cc1
637%attr(755,root,root) %{gcclibdir}/collect2
638%attr(755,root,root) %{gcclibdir}/lto-wrapper
4b27d406
JB
639%attr(755,root,root) %{gcclibdir}/lto1
640%attr(755,root,root) %{gcclibdir}/liblto_plugin.so*
73ff33c1
JB
641%{gcclibdir}/libgcc.a
642%{gcclibdir}/libgcc_eh.a
643%{gcclibdir}/libgcc_s.a
644%{gcclibdir}/libgcov.a
00383376
AF
645%{gcclibdir}/crtbegin.o
646%{gcclibdir}/crtend.o
647%{gcclibdir}/crtfastmath.o
73ff33c1
JB
648%dir %{gcclibdir}/include
649%{gcclibdir}/include/*.h
539d7886 650%{_mandir}/man1/%{target}-cpp.1*
d3f237e2 651%{_mandir}/man1/%{target}-gcc.1*
539d7886 652%{_mandir}/man1/%{target}-gcov.1*
d3f237e2 653
73ff33c1
JB
654%files -n crossmingw32-libgcc-dll
655%defattr(644,root,root,755)
656%{_dlldir}/libgcc_s_dw2-1.dll
657
14b9b67e
JB
658%files -n crossmingw32-libatomic
659%defattr(644,root,root,755)
660%{gcclibdir}/libatomic.dll.a
661%{gcclibdir}/libatomic.la
662
663%files -n crossmingw32-libatomic-static
664%defattr(644,root,root,755)
665%{gcclibdir}/libatomic.a
666
667%files -n crossmingw32-libatomic-dll
668%defattr(644,root,root,755)
669%{_dlldir}/libatomic-1.dll
670
6ccf21dc
JB
671%if %{with gomp}
672%files -n crossmingw32-libgomp
673%defattr(644,root,root,755)
674%{gcclibdir}/libgomp.dll.a
675%{gcclibdir}/libgomp.la
14b9b67e
JB
676%{gcclibdir}/libgomp-plugin-host_nonshm.dll.a
677%{gcclibdir}/libgomp-plugin-host_nonshm.la
6ccf21dc
JB
678%{gcclibdir}/libgomp.spec
679
680%files -n crossmingw32-libgomp-static
681%defattr(644,root,root,755)
682%{gcclibdir}/libgomp.a
683
684%files -n crossmingw32-libgomp-dll
685%defattr(644,root,root,755)
686%{_dlldir}/libgomp-1.dll
14b9b67e 687%{_dlldir}/libgomp-plugin-host_nonshm-1.dll
6ccf21dc
JB
688%endif
689
14b9b67e
JB
690%files -n crossmingw32-libvtv
691%defattr(644,root,root,755)
692%{gcclibdir}/libvtv.dll.a
693%{gcclibdir}/libvtv.la
694%{gcclibdir}/libvtv_stubs.dll.a
695%{gcclibdir}/libvtv_stubs.la
696
697%files -n crossmingw32-libvtv-static
698%defattr(644,root,root,755)
699%{gcclibdir}/libvtv.a
700%{gcclibdir}/libvtv_stubs.a
701
702%files -n crossmingw32-libvtv-dll
703%defattr(644,root,root,755)
704%{_dlldir}/libvtv-0.dll
705%{_dlldir}/libvtv_stubs-0.dll
706
d3f237e2
JB
707%files c++
708%defattr(644,root,root,755)
83afd976
ŁK
709%attr(755,root,root) %{_bindir}/%{target}-g++
710%attr(755,root,root) %{arch}/bin/%{target}-c++
711%attr(755,root,root) %{arch}/bin/%{target}-g++
73ff33c1
JB
712%attr(755,root,root) %{gcclibdir}/cc1plus
713%{gcclibdir}/libstdc++.dll.a
714%{gcclibdir}/libstdc++.la
715%{gcclibdir}/libsupc++.la
716%{gcclibdir}/libsupc++.a
73ff33c1 717%{gcclibdir}/include/c++
d3f237e2
JB
718%{_mandir}/man1/%{target}-g++.1*
719
73ff33c1
JB
720%files -n crossmingw32-libstdc++-static
721%defattr(644,root,root,755)
722%{gcclibdir}/libstdc++.a
723
724%files -n crossmingw32-libstdc++-dll
725%defattr(644,root,root,755)
726%{_dlldir}/libstdc++-6.dll
727
d3f237e2
JB
728%files objc
729%defattr(644,root,root,755)
14b9b67e 730%doc libobjc/README
8f1d5c0c
JB
731%attr(755,root,root) %{gcclibdir}/cc1obj
732%{gcclibdir}/libobjc.dll.a
733%{gcclibdir}/libobjc.la
734%{gcclibdir}/include/objc
d3f237e2 735
14b9b67e
JB
736%files objc++
737%defattr(644,root,root,755)
738%doc gcc/objcp/ChangeLog
739%attr(755,root,root) %{gcclibdir}/cc1objplus
740
8f1d5c0c
JB
741%files -n crossmingw32-libobjc-static
742%defattr(644,root,root,755)
743%{gcclibdir}/libobjc.a
744
745%files -n crossmingw32-libobjc-dll
746%defattr(644,root,root,755)
669fa8b1 747%{_dlldir}/libobjc-4.dll
8f1d5c0c 748
52a544a1 749%files fortran
d3f237e2 750%defattr(644,root,root,755)
52a544a1 751%attr(755,root,root) %{_bindir}/%{target}-gfortran
0d9cd0a8 752%attr(755,root,root) %{arch}/bin/%{target}-gfortran
7f7a2048 753%attr(755,root,root) %{gcclibdir}/f951
0d9cd0a8 754%{gcclibdir}/finclude
669fa8b1
JB
755%{gcclibdir}/libcaf_single.a
756%{gcclibdir}/libcaf_single.la
0d9cd0a8
JB
757%{gcclibdir}/libgfortran.dll.a
758%{gcclibdir}/libgfortran.la
b07ce80e 759%{gcclibdir}/libgfortran.spec
0d9cd0a8
JB
760%{gcclibdir}/libgfortranbegin.a
761%{gcclibdir}/libgfortranbegin.la
52a544a1 762%{_mandir}/man1/%{target}-gfortran.1*
0d9cd0a8
JB
763
764%files -n crossmingw32-libgfortran-static
765%defattr(644,root,root,755)
766%{gcclibdir}/libgfortran.a
767
768%files -n crossmingw32-libgfortran-dll
769%defattr(644,root,root,755)
770%{_dlldir}/libgfortran-3.dll
d3f237e2 771
b07ce80e
JB
772%files -n crossmingw32-libquadmath
773%defattr(644,root,root,755)
774%{gcclibdir}/libquadmath.dll.a
775%{gcclibdir}/libquadmath.la
776
777%files -n crossmingw32-libquadmath-static
778%defattr(644,root,root,755)
779%{gcclibdir}/libquadmath.a
780
781%files -n crossmingw32-libquadmath-dll
782%defattr(644,root,root,755)
783%{_dlldir}/libquadmath-0.dll
784
d3f237e2
JB
785%files java
786%defattr(644,root,root,755)
787%attr(755,root,root) %{_bindir}/%{target}-gcj
7fc2a2bb 788%attr(755,root,root) %{_bindir}/%{target}-jcf-dump
7f7a2048
JB
789%attr(755,root,root) %{arch}/bin/%{target}-gcj
790%attr(755,root,root) %{arch}/bin/%{target}-jcf-dump
791%attr(755,root,root) %{gcclibdir}/jc1
792%attr(755,root,root) %{gcclibdir}/jvgenmain
d12aabe0 793%{_mandir}/man1/%{target}-gcj.1*
539d7886 794%{_mandir}/man1/%{target}-jcf-dump.1*
This page took 0.222616 seconds and 4 git commands to generate.