]> git.pld-linux.org Git - packages/crossmingw32-gcc.git/blame - crossmingw32-gcc.spec
- stick to libexecdir=libdir for gcc, split is too messy
[packages/crossmingw32-gcc.git] / crossmingw32-gcc.spec
CommitLineData
a3bdc2a1 1#
2# Conditional build:
6ccf21dc
JB
3%bcond_with bootstrap # bootstrap build (using binary w32api/mingwrt, no gomp)
4%bcond_without gomp # OpenMP libraries
a3bdc2a1 5#
6ccf21dc
JB
6%if %{with bootstrap}
7%undefine with_gomp
8%endif
8c4c66e6
JB
9Summary: Cross MinGW32 GNU binary utility development utilities - gcc
10Summary(es.UTF-8): Utilitarios para desarrollo de binarios de la GNU - MinGW32 gcc
11Summary(fr.UTF-8): Utilitaires de développement binaire de GNU - MinGW32 gcc
12Summary(pl.UTF-8): Skrośne narzędzia programistyczne GNU dla MinGW32 - gcc
13Summary(pt_BR.UTF-8): Utilitários para desenvolvimento de binários da GNU - MinGW32 gcc
14Summary(tr.UTF-8): GNU geliştirme araçları - MinGW32 gcc
b336056d 15Name: crossmingw32-gcc
da54ab64 16Version: 6.4.0
14b9b67e 17Release: 1
d3f237e2 18Epoch: 1
acb9fe67 19License: GPL v3+
d3f237e2 20Group: Development/Languages
da54ab64
JB
21Source0: https://ftp.gnu.org/gnu/gcc/gcc-%{version}/gcc-%{version}.tar.xz
22# Source0-md5: 11ba51a0cfb8471927f387c8895fe232
ba1fe36b
JB
23%define mingw32_ver 4.0.3
24Source1: http://downloads.sourceforge.net/mingw/mingwrt-%{mingw32_ver}-1-mingw32-dev.tar.lzma
25# Source1-md5: c2c9aa82e0cb47abac01760525684858
6ccf21dc 26Source2: gcc-optimize-la.pl
14b9b67e 27# svn diff -x --ignore-eol-style --force svn://gcc.gnu.org/svn/gcc/tags/gcc_5_4_0_release svn://gcc.gnu.org/svn/gcc/branches/gcc-5-branch > gcc-branch.diff
83afd976 28Patch100: gcc-branch.diff
da54ab64 29# Patch100-md5: 1d4bc26154e47de7d727d6767215e776
83afd976
ŁK
30Patch0: %{name}-buildsystem1.patch
31Patch1: %{name}-buildsystem2.patch
32Patch2: %{name}-lfs.patch
14b9b67e 33Patch3: gcc-mingw32.patch
da54ab64 34Patch4: gcc-build-libvtv.patch
6ccf21dc 35URL: http://gcc.gnu.org/
669fa8b1 36BuildRequires: autoconf >= 2.64
14b9b67e 37BuildRequires: automake >= 1:1.11.1
d12aabe0 38BuildRequires: bison
14b9b67e 39BuildRequires: crossmingw32-binutils >= 2.23
6ccf21dc
JB
40%{?with_gomp:BuildRequires: crossmingw32-pthreads-w32}
41%if %{without bootstrap}
42BuildRequires: crossmingw32-runtime >= 3.5
43BuildRequires: crossmingw32-w32api >= 3.1
44%endif
14b9b67e
JB
45BuildRequires: flex >= 2.5.4
46BuildRequires: gettext-tools >= 0.14.5
47BuildRequires: gmp-devel >= 4.3.2
da54ab64 48BuildRequires: isl-devel >= 0.15
14b9b67e 49BuildRequires: libmpc-devel >= 0.8.1
da54ab64 50BuildRequires: libstdc++-devel
14b9b67e 51BuildRequires: mpfr-devel >= 2.4.2
207a380a 52BuildRequires: perl-tools-pod
73ff33c1 53BuildRequires: tar >= 1:1.22
da54ab64 54BuildRequires: texinfo >= 4.7
73ff33c1 55BuildRequires: xz
da54ab64 56BuildRequires: zlib-devel
14b9b67e
JB
57BuildConflicts: pdksh < 5.2.14-50
58Requires: crossmingw32-binutils >= 2.23
6ab368b0 59Requires: gcc-dirs
14b9b67e 60Requires: gmp >= 4.3.2
da54ab64 61Requires: isl >= 0.15
14b9b67e
JB
62Requires: libmpc >= 0.8.1
63Requires: mpfr >= 2.4.2
b336056d
JB
64BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
d3f237e2 66%define target i386-mingw32
8f1d5c0c
JB
67%define sysprefix /usr
68%define arch %{sysprefix}/%{target}
73ff33c1
JB
69%define gccarchdir %{_libdir}/gcc/%{target}
70%define gcclibdir %{gccarchdir}/%{version}
71%define _dlldir /usr/share/wine/windows/system
dee9b92f 72
5b936a1d 73%define _noautostrip .*/lib.*\\.a
b336056d 74
66f480ce
JP
75%define _enable_debug_packages 0
76
45ff11c2
JR
77# functions with printf format attribute but with special parser and also
78# receiving non constant format strings
79%define Werror_cflags %{nil}
42fa9439 80%define _ssp_cflags %{nil}
c07647a9
JB
81# -fPIC is not valid for target platform
82%define filterout_c -fPIC
42fa9439 83
b336056d
JB
84%description
85crossmingw32 is a complete cross-compiling development system for
86building stand-alone Microsoft Windows applications under Linux using
8c4c66e6 87the MinGW32 build libraries. This includes a binutils, gcc with g++
b336056d
JB
88and objc, and libstdc++, all cross targeted to i386-mingw32, along
89with supporting Win32 libraries in 'coff' format from free sources.
90
d3f237e2 91This package contains cross targeted gcc.
b336056d 92
4a6c89d0 93%description -l de.UTF-8
94Dieses Paket enthält einen Cross-gcc, der es erlaubt, auf einem
95anderem Rechner Code für Win32 zu generieren.
9dd4c848 96
4a6c89d0 97%description -l pl.UTF-8
98crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
99pozwalającym budować aplikacje MS Windows pod Linuksem używając
8c4c66e6 100bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
4a6c89d0 101libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
2e5b9011 102z bibliotek w formacie COFF.
d790a8ba 103
4a6c89d0 104Ten pakiet zawiera gcc generujące skrośnie kod dla Win32.
d790a8ba 105
73ff33c1
JB
106%package -n crossmingw32-libgcc-dll
107Summary: libgcc DLL library for Windows
108Summary(pl.UTF-8): Biblioteka DLL libgcc dla Windows
109Group: Applications/Emulators
110Requires: wine
111
112%description -n crossmingw32-libgcc-dll
113libgcc DLL library for Windows.
114
115%description -n crossmingw32-libgcc-dll -l pl.UTF-8
116Biblioteka DLL libgcc dla Windows.
117
14b9b67e
JB
118%package -n crossmingw32-libatomic
119Summary: The GNU Atomic library - cross MinGW32 version
120Summary(pl.UTF-8): Biblioteka GNU Atomic - wersja skrośna MinGW32
121License: GPL v3+ with GCC Runtime Library Exception v3.1
122Group: Development/Libraries
123Requires: %{name} = %{epoch}:%{version}-%{release}
124
125%description -n crossmingw32-libatomic
126This package contains cross MinGW32 version of the GNU Atomic library
127which is a GCC support library for atomic operations not supported by
128hardware.
129
130%description -n crossmingw32-libatomic -l pl.UTF-8
131Ten pakiet zawiera wersję skrośną MinGW32 biblioteki GNU Atomic,
132będącej biblioteką GCC, wspierającej operacje atomowe na sprzęcie ich
133nie obsługującym.
134
135%package -n crossmingw32-libatomic-static
136Summary: The GNU Atomic static library - cross MinGW32 version
137Summary(pl.UTF-8): Statyczna biblioteka GNU Atomic - wersja skrośna MinGW32
138License: GPL v3+ with GCC Runtime Library Exception v3.1
139Group: Development/Libraries
140Requires: crossmingw32-libatomic = %{epoch}:%{version}-%{release}
141
142%description -n crossmingw32-libatomic-static
143The GNU Atomic static library - cross MinGW32 version.
144
145%description -n crossmingw32-libatomic-static
146Statyczna biblioteka GNU Atomic - wersja skrośna MinGW32.
147
148%package -n crossmingw32-libatomic-dll
149Summary: DLL GNU Atomic library for Windows
150Summary(pl.UTF-8): Biblioteka DLL GNU Atomic dla Windows
151License: GPL v3+ with GCC Runtime Library Exception v3.1
152Group: Applications/Emulators
153Requires: wine
154
155%description -n crossmingw32-libatomic-dll
156DLL GNU Atomic library for Windows.
157
158%description -n crossmingw32-libatomic-dll -l pl.UTF-8
159Biblioteka DLL GNU Atomic dla Windows.
160
6ccf21dc
JB
161%package -n crossmingw32-libgomp
162Summary: GNU OpenMP library - cross MinGW32 version
163Summary(pl.UTF-8): Biblioteka GNU OpenMP - wersja skrośna MinGW32
164License: GPL v3+ with GCC Runtime Library Exception v3.1
165Group: Development/Libraries
166Requires: %{name} = %{epoch}:%{version}-%{release}
167
168%description -n crossmingw32-libgomp
169This package contains cross MinGW32 version of GNU OpenMP library.
170
171%description -n crossmingw32-libgomp -l pl.UTF-8
172Ten pakiet zawiera wersję skrośną MinGW32 biblioteki GNU OpenMP.
173
174%package -n crossmingw32-libgomp-static
175Summary: Static GNU OpenMP library - cross MinGW32 version
176Summary(pl.UTF-8): Statyczna biblioteka GNU OpenMP - wersja skrośna MinGW32
177License: GPL v3+ with GCC Runtime Library Exception v3.1
178Group: Development/Libraries
179Requires: crossmingw32-libgomp = %{epoch}:%{version}-%{release}
180
181%description -n crossmingw32-libgomp-static
182Static GNU OpenMP library - cross MinGW32 version.
183
184%description -n crossmingw32-libgomp-static -l pl.UTF-8
185Statyczna biblioteka GNU OpenMP - wersja skrośna MinGW32.
186
187%package -n crossmingw32-libgomp-dll
188Summary: DLL GNU OpenMP library for Windows
189Summary(pl.UTF-8): Biblioteka DLL GNU OpenMP dla Windows
190License: GPL v3+ with GCC Runtime Library Exception v3.1
14b9b67e 191Group: Applications/Emulators
6ccf21dc 192Requires: crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
e49d4dab 193Requires: crossmingw32-pthreads-w32-dll
6ccf21dc
JB
194
195%description -n crossmingw32-libgomp-dll
196DLL GNU OpenMP library for Windows.
197
198%description -n crossmingw32-libgomp-dll -l pl.UTF-8
199Biblioteka DLL GNU OpenMP dla Windows.
200
14b9b67e
JB
201%package -n crossmingw32-libvtv
202Summary: The Virtual Table Verification library - cross MinGW32 version
203Summary(pl.UTF-8): Biblioteka Virtual Table Verification do weryfikacji tablicy wirtualnej - wersja skrośna MinGW32
204License: GPL v3+ with GCC Runtime Library Exception v3.1
205Group: Development/Libraries
206URL: https://gcc.gnu.org/wiki/vtv
207Requires: %{name} = %{epoch}:%{version}-%{release}
208
209%description -n crossmingw32-libvtv
210This package contains cross MinGW32 version of the Virtual Table
211Verification library which is used for -fvtable-verify=...
212instrumented programs.
213
214%description -n crossmingw32-libvtv -l pl.UTF-8
215Ten pakiet zawiera wersję skrośną MinGW32 biblioteki Virtual Table
216Verification, służącej do weryfikacji tablicy wirtualnej w programach
217kompilowanych z opcją -fvtable-verify=....
218
219%package -n crossmingw32-libvtv-static
220Summary: The Virtual Table Verification static library - cross MinGW32 version
221Summary(pl.UTF-8): Statyczna biblioteka Virtual Table Verification - wersja skrośna MinGW32
222License: GPL v3+ with GCC Runtime Library Exception v3.1
223Group: Development/Libraries
224URL: https://gcc.gnu.org/wiki/vtv
225Requires: crossmingw32-libvtv = %{epoch}:%{version}-%{release}
226
227%description -n crossmingw32-libvtv-static
228The Virtual Table Verification static library - cross MinGW32 version.
229
230%description -n crossmingw32-libvtv-static -l pl.UTF-8
231Statyczna biblioteka Virtual Table Verification - wersja skrośna
232MinGW32.
233
234%package -n crossmingw32-libvtv-dll
235Summary: DLL Virtual Table Verification libraries for Windows
236Summary(pl.UTF-8): Biblioteki DLL Virtual Table Verification dla Windows
237License: GPL v3+ with GCC Runtime Library Exception v3.1
238Group: Applications/Emulators
239URL: https://gcc.gnu.org/wiki/vtv
240Requires: crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
241
242%description -n crossmingw32-libvtv-dll
243DLL Virtual Table Verification libraries for Windows.
244
245%description -n crossmingw32-libvtv-dll -l pl.UTF-8
246Biblioteki DLL Virtual Table Verification dla Windows.
247
d3f237e2 248%package c++
8c4c66e6
JB
249Summary: MinGW32 binary utility development utilities - g++
250Summary(pl.UTF-8): Zestaw narzędzi MinGW32 - g++
d3f237e2 251Group: Development/Languages
cae974d4 252Requires: %{name} = %{epoch}:%{version}-%{release}
b336056d 253
d3f237e2
JB
254%description c++
255crossmingw32 is a complete cross-compiling development system for
256building stand-alone Microsoft Windows applications under Linux using
8c4c66e6 257the MinGW32 build libraries. This includes a binutils, gcc with g++
d3f237e2
JB
258and objc, and libstdc++, all cross targeted to i386-mingw32, along
259with supporting Win32 libraries in 'coff' format from free sources.
260
261This package contains cross targeted g++ and (static) libstdc++.
262
4a6c89d0 263%description c++ -l pl.UTF-8
264crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
265pozwalającym budować aplikacje MS Windows pod Linuksem używając
8c4c66e6 266bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
4a6c89d0 267libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
2e5b9011 268z bibliotek w formacie COFF.
d790a8ba 269
4a6c89d0 270Ten pakiet zawiera g++ generujące kod pod Win32 oraz bibliotekę
d790a8ba
JB
271libstdc++.
272
73ff33c1
JB
273%package -n crossmingw32-libstdc++-static
274Summary: Static standard C++ library - cross MinGW32 version
275Summary(pl.UTF-8): Statyczna biblioteka standardowa C++ - wersja skrośna MinGW32
276Group: Development/Libraries
277Requires: %{name}-c++ = %{epoch}:%{version}-%{release}
278
279%description -n crossmingw32-libstdc++-static
280Static standard C++ library - cross MinGW32 version.
281
282%description -n crossmingw32-libstdc++-static -l pl.UTF-8
283Statyczna biblioteka standardowa C++ - wersja skrośna MinGW32.
284
285%package -n crossmingw32-libstdc++-dll
286Summary: libstdc++ DLL library for Windows
287Summary(pl.UTF-8): Biblioteka DLL libstdc++ dla Windows
288Group: Applications/Emulators
289Requires: crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
290Requires: wine
291
292%description -n crossmingw32-libstdc++-dll
293libstdc++ DLL library for Windows.
294
295%description -n crossmingw32-libstdc++-dll -l pl.UTF-8
296Biblioteka DLL libstdc++ dla Windows.
297
d3f237e2 298%package objc
8c4c66e6
JB
299Summary: MinGW32 binary utility development utilities - objc
300Summary(pl.UTF-8): Zestaw narzędzi MinGW32 - objc
d3f237e2 301Group: Development/Languages
cae974d4 302Requires: %{name} = %{epoch}:%{version}-%{release}
d3f237e2
JB
303
304%description objc
305crossmingw32 is a complete cross-compiling development system for
306building stand-alone Microsoft Windows applications under Linux using
8c4c66e6 307the MinGW32 build libraries. This includes a binutils, gcc with g++
d3f237e2
JB
308and objc, and libstdc++, all cross targeted to i386-mingw32, along
309with supporting Win32 libraries in 'coff' format from free sources.
310
37948e2b 311This package contains cross targeted objc compiler.
d3f237e2 312
4a6c89d0 313%description objc -l pl.UTF-8
314crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
315pozwalającym budować aplikacje MS Windows pod Linuksem używając
8c4c66e6 316bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
4a6c89d0 317libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
2e5b9011 318z bibliotek w formacie COFF.
d790a8ba 319
4a6c89d0 320Ten pakiet zawiera kompilator objc generujący kod pod Win32.
d790a8ba 321
14b9b67e
JB
322%package objc++
323Summary: MinGW32 binary utility development utilities - objc++
324Summary(pl.UTF-8): Zestaw narzędzi MinGW32 - objc++
325Group: Development/Languages
326Requires: %{name}-objc = %{epoch}:%{version}-%{release}
327
328%description objc++
329crossmingw32 is a complete cross-compiling development system for
330building stand-alone Microsoft Windows applications under Linux using
331the MinGW32 build libraries. This includes a binutils, gcc with g++
332and objc, and libstdc++, all cross targeted to i386-mingw32, along
333with supporting Win32 libraries in 'coff' format from free sources.
334
335This package contains Objective C++ support.
336
337%description objc++ -l pl.UTF-8
338crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
339pozwalającym budować aplikacje MS Windows pod Linuksem używając
340bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
341libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
342z bibliotek w formacie COFF.
343
344Ten pakiet zawiera obsługę języka Objective C++.
345
8f1d5c0c
JB
346%package -n crossmingw32-libobjc-static
347Summary: Static Objective C library - cross MinGW32 version
348Summary(pl.UTF-8): Statyczna biblioteka Objective C - wersja skrośna MinGW32
349Group: Development/Libraries
350Requires: %{name}-objc = %{epoch}:%{version}-%{release}
351
352%description -n crossmingw32-libobjc-static
353Static Objective C library - cross MinGW32 version.
354
355%description -n crossmingw32-libobjc-static -l pl.UTF-8
356Statyczna biblioteka Objective C - wersja skrośna MinGW32.
357
358%package -n crossmingw32-libobjc-dll
359Summary: libobjc DLL library for Windows
360Summary(pl.UTF-8): Biblioteka DLL libobjc dla Windows
361Group: Applications/Emulators
362Requires: crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
363Requires: wine
364
365%description -n crossmingw32-libobjc-dll
366libobjc DLL library for Windows.
367
368%description -n crossmingw32-libobjc-dll -l pl.UTF-8
369Biblioteka DLL libobjc dla Windows.
370
52a544a1 371%package fortran
8c4c66e6
JB
372Summary: MinGW32 binary utility development utilities - Fortran
373Summary(pl.UTF-8): Zestaw narzędzi MinGW32 - Fortran
d3f237e2 374Group: Development/Languages
cae974d4 375Requires: %{name} = %{epoch}:%{version}-%{release}
ed6b55ce 376Requires: crossmingw32-libquadmath = %{epoch}:%{version}-%{release}
37948e2b 377Obsoletes: crossmingw32-gcc-g77
d3f237e2 378
52a544a1 379%description fortran
d3f237e2
JB
380crossmingw32 is a complete cross-compiling development system for
381building stand-alone Microsoft Windows applications under Linux using
8c4c66e6 382the MinGW32 build libraries. This includes a binutils, gcc with g++
d3f237e2
JB
383and objc, and libstdc++, all cross targeted to i386-mingw32, along
384with supporting Win32 libraries in 'coff' format from free sources.
385
37948e2b 386This package contains cross targeted Fortran compiler.
d3f237e2 387
4a6c89d0 388%description fortran -l pl.UTF-8
389crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
390pozwalającym budować aplikacje MS Windows pod Linuksem używając
8c4c66e6 391bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
4a6c89d0 392libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
2e5b9011 393z bibliotek w formacie COFF.
d790a8ba 394
4a6c89d0 395Ten pakiet zawiera kompilator Fortranu generujący kod pod Win32.
d790a8ba 396
0d9cd0a8
JB
397%package -n crossmingw32-libgfortran-static
398Summary: Static Fortran library - cross MinGW32 version
6a795f6e 399Summary(pl.UTF-8): Statyczna biblioteka Fortranu - wersja skrośna MinGW32
0d9cd0a8
JB
400Group: Development/Libraries
401Requires: %{name}-fortran = %{epoch}:%{version}-%{release}
402
403%description -n crossmingw32-libgfortran-static
404Static Fortran library - cross MinGW32 version.
405
406%description -n crossmingw32-libgfortran-static -l pl.UTF-8
6a795f6e 407Statyczna biblioteka Fortranu - wersja skrośna MinGW32.
0d9cd0a8
JB
408
409%package -n crossmingw32-libgfortran-dll
410Summary: libgfortran DLL library for Windows
411Summary(pl.UTF-8): Biblioteka DLL libgfortran dla Windows
412Group: Applications/Emulators
b07ce80e 413Requires: crossmingw32-libquadmath-dll
0d9cd0a8
JB
414
415%description -n crossmingw32-libgfortran-dll
416libgfortran DLL library for Windows.
417
418%description -n crossmingw32-libgfortran-dll -l pl.UTF-8
419Biblioteka DLL libgfortran dla Windows.
420
b07ce80e
JB
421%package -n crossmingw32-libquadmath
422Summary: GCC __float128 support library - cross MinGW32 version
423Summary(pl.UTF-8): Biblioteka do obsługi typu __float128 - wersja skrośna MinGW32
424License: GPL v2+ with linking exception
425Group: Development/Libraries
426Requires: %{name} = %{epoch}:%{version}-%{release}
427
428%description -n crossmingw32-libquadmath
429This package contains cross MinGW32 version of GCC support library
430which is needed for __float128 math support and for Fortran REAL*16
431support.
432
433%description -n crossmingw32-libquadmath -l pl.UTF-8
434Ten pakiet zawiera wersję skrośną MinGW32 biblioteki GCC do obsługi
435operacji matematycznych na zmiennych typu __float128 oraz typu REAL*16
436w Fortranie.
437
438%package -n crossmingw32-libquadmath-static
439Summary: Static GCC __float128 support library - cross MinGW32 version
440Summary(pl.UTF-8): Biblioteka statyczna GCC do obsługi typu __float128 - wersja skrośna MinGW32
441License: GPL v2+ with linking exception
442Group: Development/Libraries
443Requires: crossmingw32-libquadmath = %{epoch}:%{version}-%{release}
444
445%description -n crossmingw32-libquadmath-static
446Static GCC __float128 support library - cross MinGW32 version.
447
448%description -n crossmingw32-libquadmath-static -l pl.UTF-8
449Biblioteka statyczna GCC do obsługi typu __float128 - wersja skrośna
450MinGW32.
451
452%package -n crossmingw32-libquadmath-dll
453Summary: DLL GCC __float128 support library for Windows
454Summary(pl.UTF-8): Biblioteka DLL GCC do obsługi typu __float128 dla Windows
455License: GPL v2+ with linking exception
456Group: Applications/Emulators
457Requires: wine
458
459%description -n crossmingw32-libquadmath-dll
460DLL GCC __float128 support library for Windows.
461
462%description -n crossmingw32-libquadmath-dll -l pl.UTF-8
463Biblioteka DLL GCC do obsługi typu __float128 dla Windows.
464
d3f237e2 465%package java
8c4c66e6
JB
466Summary: MinGW32 binary utility development utilities - Java
467Summary(pl.UTF-8): Zestaw narzędzi MinGW32 - Java
d3f237e2 468Group: Development/Languages
cae974d4 469Requires: %{name} = %{epoch}:%{version}-%{release}
d3f237e2
JB
470
471%description java
472crossmingw32 is a complete cross-compiling development system for
473building stand-alone Microsoft Windows applications under Linux using
8c4c66e6 474the MinGW32 build libraries. This includes a binutils, gcc with g++
d3f237e2
JB
475and objc, and libstdc++, all cross targeted to i386-mingw32, along
476with supporting Win32 libraries in 'coff' format from free sources.
477
37948e2b 478This package contains cross targeted Java compiler.
d3f237e2 479
4a6c89d0 480%description java -l pl.UTF-8
4a6c89d0 481crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
482pozwalającym budować aplikacje MS Windows pod Linuksem używając
8c4c66e6 483bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
4a6c89d0 484libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
2e5b9011 485z bibliotek w formacie COFF.
d790a8ba 486
4a6c89d0 487Ten pakiet zawiera kompilator Javy generujący kod pod Win32.
d790a8ba 488
d3f237e2 489%prep
dee9b92f 490%setup -q -n gcc-%{version}
83afd976
ŁK
491%patch100 -p0
492%patch0 -p1
493%patch2 -p1
14b9b67e 494%patch3 -p1
da54ab64 495%patch4 -p1
83afd976 496
b399bc1a 497%if %{with bootstrap}
ba1fe36b
JB
498# note: "winsup" dir is special, handled by gcc's configure
499install -d winsup/mingw
500tar xf %{SOURCE1} -C winsup/mingw
b399bc1a 501%endif
83afd976
ŁK
502
503# override snapshot version.
504echo %{version} > gcc/BASE-VER
505echo "release" > gcc/DEV-PHASE
b336056d
JB
506
507%build
da54ab64
JB
508cd libvtv
509%{__aclocal} -I .. -I ../config
510%{__autoconf}
511%{__automake}
512cd ..
513
73ff33c1 514rm -rf builddir && install -d builddir && cd builddir
b399bc1a 515%if %{with bootstrap}
73ff33c1 516install -d %{target}/winsup
73ff33c1 517ln -sf ../../../winsup/mingw/lib %{target}/winsup/mingw
ba1fe36b 518ln -sf ../../../winsup/mingw/include %{target}/winsup/w32api
73ff33c1 519WINSUPDIR=$(cd ..; pwd)/winsup
b399bc1a
AF
520%endif
521
da54ab64 522# note: libbacktrace requires at least i486 now
83afd976 523CC="%{__cc}" \
b4c37c30 524CFLAGS="%{rpmcflags}" \
83afd976 525CXXFLAGS="%{rpmcxxflags}" \
b4c37c30 526TEXCONFIG=false \
da54ab64
JB
527CFLAGS_FOR_TARGET="-O2 -march=i486" \
528CXXFLAGS_FOR_TARGET="-O2 -march=i486" \
b336056d 529../configure \
8f1d5c0c
JB
530 --prefix=%{sysprefix} \
531 --bindir=%{arch}/bin \
73ff33c1 532 --libdir=%{_libdir} \
8f1d5c0c 533 --includedir=%{arch}/include \
a7ca5423 534 --libexecdir=%{_libdir} \
b336056d
JB
535 --infodir=%{_infodir} \
536 --mandir=%{_mandir} \
6ccf21dc 537 --with-build-time-tools=%{arch}/bin \
73ff33c1
JB
538 %{!?with_bootstrap:--with-headers=%{arch}/include} \
539 --with-libs=%{!?with_bootstrap:%{arch}/lib}%{?with_bootstrap:${WINSUPDIR}/mingw/lib} \
14b9b67e 540 --with-demangler-in-ld \
83afd976
ŁK
541 --with-dwarf2 \
542 --with-gnu-as \
543 --with-gnu-ld \
83afd976 544 --with-long-double-128 \
14b9b67e
JB
545 --enable-c99 \
546 --enable-fully-dynamic-string \
6ccf21dc 547 --disable-isl-version-check \
14b9b67e 548 --enable-languages="c,c++,fortran,java,objc,obj-c++" \
14b9b67e
JB
549 --disable-libcc1 \
550 --enable-libgomp%{!?with_gomp:=no} \
551 --disable-libssp \
83afd976 552 --enable-libstdcxx-allocator=new \
14b9b67e 553 --enable-linker-build-id \
6ccf21dc 554 --enable-long-long \
14b9b67e 555 --enable-lto \
6ccf21dc 556 --disable-multilib \
0dcd3a97 557 --disable-nls \
da54ab64 558 --enable-shared \
83afd976 559 --disable-sjlj-exceptions \
6ccf21dc 560 --disable-symvers \
da54ab64 561 --enable-threads \
14b9b67e
JB
562 --enable-version-specific-runtime-libs \
563 --disable-werror \
83afd976 564 --disable-win32-registry \
b336056d
JB
565 --target=%{target}
566
83afd976
ŁK
567cd ..
568%{__make} -C builddir all-host
569patch -p1 <%{PATCH1}
570%{__make} -C builddir
b336056d
JB
571
572%install
b336056d 573rm -rf $RPM_BUILD_ROOT
73ff33c1 574install -d $RPM_BUILD_ROOT%{_bindir}
b336056d 575
83afd976 576%{__make} -C builddir install \
d12aabe0 577 DESTDIR=$RPM_BUILD_ROOT
b336056d 578
14b9b67e 579%{__mv} $RPM_BUILD_ROOT%{gcclibdir}/include-fixed/{limits,syslimits}.h $RPM_BUILD_ROOT%{gcclibdir}/include
73ff33c1
JB
580%{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/include-fixed
581%{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/install-tools
d12aabe0 582
82f2d40f
JB
583# these must be symlinks: gcclibdir is calculated relatively to real binary path
584ln -sf %{arch}/bin/%{target}-gcc $RPM_BUILD_ROOT%{_bindir}/%{target}-gcc
585ln -sf %{arch}/bin/%{target}-g++ $RPM_BUILD_ROOT%{_bindir}/%{target}-g++
586ln -sf %{arch}/bin/%{target}-cpp $RPM_BUILD_ROOT%{_bindir}/%{target}-cpp
587ln -sf %{arch}/bin/%{target}-gcov $RPM_BUILD_ROOT%{_bindir}/%{target}-gcov
da54ab64 588ln -sf %{arch}/bin/%{target}-gcov-dump $RPM_BUILD_ROOT%{_bindir}/%{target}-gcov-dump
14b9b67e 589ln -sf %{arch}/bin/%{target}-gcov-tool $RPM_BUILD_ROOT%{_bindir}/%{target}-gcov-tool
82f2d40f
JB
590ln -sf %{arch}/bin/%{target}-gcj $RPM_BUILD_ROOT%{_bindir}/%{target}-gcj
591ln -sf %{arch}/bin/%{target}-jcf-dump $RPM_BUILD_ROOT%{_bindir}/%{target}-jcf-dump
592ln -sf %{arch}/bin/%{target}-gfortran $RPM_BUILD_ROOT%{_bindir}/%{target}-gfortran
83afd976 593
73ff33c1
JB
594# DLLs
595install -d $RPM_BUILD_ROOT%{_dlldir}
14b9b67e
JB
596%{__mv} $RPM_BUILD_ROOT%{gccarchdir}/*.dll $RPM_BUILD_ROOT%{_dlldir}
597%{__mv} $RPM_BUILD_ROOT%{gcclibdir}/*.dll $RPM_BUILD_ROOT%{_dlldir}
8f1d5c0c
JB
598if [ ! -f $RPM_BUILD_ROOT%{_dlldir}/libgcc_s_dw2-1.dll ]; then
599 echo "libgcc DLL not installed?"
600 install builddir/i386-mingw32/libgcc/shlib/libgcc_s_dw2-1.dll $RPM_BUILD_ROOT%{_dlldir}
601fi
d12aabe0 602
73ff33c1
JB
603%if 0%{!?debug:1}
604%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
d33f98c7 605%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{gcclibdir}/lib*.a
73ff33c1 606%endif
83afd976 607
6ccf21dc 608# avoid -L poisoning in *.la
da54ab64 609for f in libatomic.la libcaf_single.la libgfortran.la libobjc.la libquadmath.la %{?with_gomp:libgomp.la} ; do
6ccf21dc
JB
610 file="$RPM_BUILD_ROOT%{gcclibdir}/$f"
611 %{__perl} %{SOURCE2} "$file" %{gcclibdir} >"${file}.fixed"
612 %{__mv} "${file}.fixed" "$file"
613done
614
b07ce80e
JB
615# for pretty-printers see native gcc
616%{__rm} $RPM_BUILD_ROOT%{gcclibdir}/libstdc++.dll.a-gdb.py
617%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/gcc-%{version}/python/libstdcxx
4b27d406
JB
618# no plugin development for mingw32 (at least for now)
619%{__rm} $RPM_BUILD_ROOT%{gcclibdir}/liblto_plugin.la
b07ce80e 620%{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/plugin
73ff33c1
JB
621# already in native gcc
622%{__rm} -r $RPM_BUILD_ROOT%{_infodir}
623# common FSF man pages
624%{__rm} $RPM_BUILD_ROOT%{_mandir}/man7/{fsf-funding,gfdl,gpl}.7
7f7a2048
JB
625# programs not packaged
626%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/%{target}-{aot-compile,gc-analyze,gcj-dbtool,gij,grmic,jv-convert,rebuild-gcj-db}.1
8c4c66e6 627
b336056d 628%clean
b336056d
JB
629rm -rf $RPM_BUILD_ROOT
630
631%files
632%defattr(644,root,root,755)
83afd976 633%attr(755,root,root) %{_bindir}/%{target}-gcc
b4c37c30 634%attr(755,root,root) %{_bindir}/%{target}-cpp
635%attr(755,root,root) %{_bindir}/%{target}-gcov
da54ab64 636%attr(755,root,root) %{_bindir}/%{target}-gcov-dump
14b9b67e 637%attr(755,root,root) %{_bindir}/%{target}-gcov-tool
73ff33c1
JB
638%attr(755,root,root) %{arch}/bin/%{target}-gcc
639%attr(755,root,root) %{arch}/bin/%{target}-gcc-%{version}
669fa8b1
JB
640%attr(755,root,root) %{arch}/bin/%{target}-gcc-ar
641%attr(755,root,root) %{arch}/bin/%{target}-gcc-nm
642%attr(755,root,root) %{arch}/bin/%{target}-gcc-ranlib
83afd976
ŁK
643%attr(755,root,root) %{arch}/bin/%{target}-cpp
644%attr(755,root,root) %{arch}/bin/%{target}-gcov
da54ab64 645%attr(755,root,root) %{arch}/bin/%{target}-gcov-dump
14b9b67e 646%attr(755,root,root) %{arch}/bin/%{target}-gcov-tool
73ff33c1
JB
647%dir %{gccarchdir}
648%dir %{gcclibdir}
649%attr(755,root,root) %{gcclibdir}/cc1
650%attr(755,root,root) %{gcclibdir}/collect2
651%attr(755,root,root) %{gcclibdir}/lto-wrapper
4b27d406
JB
652%attr(755,root,root) %{gcclibdir}/lto1
653%attr(755,root,root) %{gcclibdir}/liblto_plugin.so*
73ff33c1
JB
654%{gcclibdir}/libgcc.a
655%{gcclibdir}/libgcc_eh.a
656%{gcclibdir}/libgcc_s.a
657%{gcclibdir}/libgcov.a
00383376
AF
658%{gcclibdir}/crtbegin.o
659%{gcclibdir}/crtend.o
660%{gcclibdir}/crtfastmath.o
73ff33c1
JB
661%dir %{gcclibdir}/include
662%{gcclibdir}/include/*.h
539d7886 663%{_mandir}/man1/%{target}-cpp.1*
d3f237e2 664%{_mandir}/man1/%{target}-gcc.1*
539d7886 665%{_mandir}/man1/%{target}-gcov.1*
da54ab64
JB
666%{_mandir}/man1/%{target}-gcov-dump.1*
667%{_mandir}/man1/%{target}-gcov-tool.1*
d3f237e2 668
73ff33c1
JB
669%files -n crossmingw32-libgcc-dll
670%defattr(644,root,root,755)
671%{_dlldir}/libgcc_s_dw2-1.dll
672
14b9b67e
JB
673%files -n crossmingw32-libatomic
674%defattr(644,root,root,755)
675%{gcclibdir}/libatomic.dll.a
676%{gcclibdir}/libatomic.la
677
678%files -n crossmingw32-libatomic-static
679%defattr(644,root,root,755)
680%{gcclibdir}/libatomic.a
681
682%files -n crossmingw32-libatomic-dll
683%defattr(644,root,root,755)
684%{_dlldir}/libatomic-1.dll
685
6ccf21dc
JB
686%if %{with gomp}
687%files -n crossmingw32-libgomp
688%defattr(644,root,root,755)
689%{gcclibdir}/libgomp.dll.a
690%{gcclibdir}/libgomp.la
691%{gcclibdir}/libgomp.spec
692
693%files -n crossmingw32-libgomp-static
694%defattr(644,root,root,755)
695%{gcclibdir}/libgomp.a
696
697%files -n crossmingw32-libgomp-dll
698%defattr(644,root,root,755)
699%{_dlldir}/libgomp-1.dll
700%endif
701
14b9b67e
JB
702%files -n crossmingw32-libvtv
703%defattr(644,root,root,755)
704%{gcclibdir}/libvtv.dll.a
705%{gcclibdir}/libvtv.la
706%{gcclibdir}/libvtv_stubs.dll.a
707%{gcclibdir}/libvtv_stubs.la
708
709%files -n crossmingw32-libvtv-static
710%defattr(644,root,root,755)
711%{gcclibdir}/libvtv.a
712%{gcclibdir}/libvtv_stubs.a
713
714%files -n crossmingw32-libvtv-dll
715%defattr(644,root,root,755)
716%{_dlldir}/libvtv-0.dll
717%{_dlldir}/libvtv_stubs-0.dll
718
d3f237e2
JB
719%files c++
720%defattr(644,root,root,755)
83afd976
ŁK
721%attr(755,root,root) %{_bindir}/%{target}-g++
722%attr(755,root,root) %{arch}/bin/%{target}-c++
723%attr(755,root,root) %{arch}/bin/%{target}-g++
73ff33c1
JB
724%attr(755,root,root) %{gcclibdir}/cc1plus
725%{gcclibdir}/libstdc++.dll.a
726%{gcclibdir}/libstdc++.la
727%{gcclibdir}/libsupc++.la
728%{gcclibdir}/libsupc++.a
73ff33c1 729%{gcclibdir}/include/c++
d3f237e2
JB
730%{_mandir}/man1/%{target}-g++.1*
731
73ff33c1
JB
732%files -n crossmingw32-libstdc++-static
733%defattr(644,root,root,755)
734%{gcclibdir}/libstdc++.a
735
736%files -n crossmingw32-libstdc++-dll
737%defattr(644,root,root,755)
738%{_dlldir}/libstdc++-6.dll
739
d3f237e2
JB
740%files objc
741%defattr(644,root,root,755)
14b9b67e 742%doc libobjc/README
8f1d5c0c
JB
743%attr(755,root,root) %{gcclibdir}/cc1obj
744%{gcclibdir}/libobjc.dll.a
745%{gcclibdir}/libobjc.la
746%{gcclibdir}/include/objc
d3f237e2 747
14b9b67e
JB
748%files objc++
749%defattr(644,root,root,755)
750%doc gcc/objcp/ChangeLog
751%attr(755,root,root) %{gcclibdir}/cc1objplus
752
8f1d5c0c
JB
753%files -n crossmingw32-libobjc-static
754%defattr(644,root,root,755)
755%{gcclibdir}/libobjc.a
756
757%files -n crossmingw32-libobjc-dll
758%defattr(644,root,root,755)
669fa8b1 759%{_dlldir}/libobjc-4.dll
8f1d5c0c 760
52a544a1 761%files fortran
d3f237e2 762%defattr(644,root,root,755)
52a544a1 763%attr(755,root,root) %{_bindir}/%{target}-gfortran
0d9cd0a8 764%attr(755,root,root) %{arch}/bin/%{target}-gfortran
7f7a2048 765%attr(755,root,root) %{gcclibdir}/f951
0d9cd0a8 766%{gcclibdir}/finclude
669fa8b1
JB
767%{gcclibdir}/libcaf_single.a
768%{gcclibdir}/libcaf_single.la
0d9cd0a8
JB
769%{gcclibdir}/libgfortran.dll.a
770%{gcclibdir}/libgfortran.la
b07ce80e 771%{gcclibdir}/libgfortran.spec
52a544a1 772%{_mandir}/man1/%{target}-gfortran.1*
0d9cd0a8
JB
773
774%files -n crossmingw32-libgfortran-static
775%defattr(644,root,root,755)
776%{gcclibdir}/libgfortran.a
777
778%files -n crossmingw32-libgfortran-dll
779%defattr(644,root,root,755)
780%{_dlldir}/libgfortran-3.dll
d3f237e2 781
b07ce80e
JB
782%files -n crossmingw32-libquadmath
783%defattr(644,root,root,755)
784%{gcclibdir}/libquadmath.dll.a
785%{gcclibdir}/libquadmath.la
786
787%files -n crossmingw32-libquadmath-static
788%defattr(644,root,root,755)
789%{gcclibdir}/libquadmath.a
790
791%files -n crossmingw32-libquadmath-dll
792%defattr(644,root,root,755)
793%{_dlldir}/libquadmath-0.dll
794
d3f237e2
JB
795%files java
796%defattr(644,root,root,755)
797%attr(755,root,root) %{_bindir}/%{target}-gcj
7fc2a2bb 798%attr(755,root,root) %{_bindir}/%{target}-jcf-dump
7f7a2048
JB
799%attr(755,root,root) %{arch}/bin/%{target}-gcj
800%attr(755,root,root) %{arch}/bin/%{target}-jcf-dump
801%attr(755,root,root) %{gcclibdir}/jc1
802%attr(755,root,root) %{gcclibdir}/jvgenmain
d12aabe0 803%{_mandir}/man1/%{target}-gcj.1*
539d7886 804%{_mandir}/man1/%{target}-jcf-dump.1*
This page took 0.494271 seconds and 4 git commands to generate.