]> git.pld-linux.org Git - packages/crossmingw32-evil.git/blob - crossmingw32-evil.spec
do not provide pkgconfig deps in system namespace
[packages/crossmingw32-evil.git] / crossmingw32-evil.spec
1 Summary:        Evil - EFL Windows compatibility layer
2 Summary(pl.UTF-8):      Evil - Warstwa kompatybilności EFL z Windows
3 Name:           crossmingw32-evil
4 Version:        1.7.6
5 Release:        2
6 License:        Free (see COPYING)
7 Group:          Development/Libraries
8 Source0:        http://download.enlightenment.org/releases/evil-%{version}.tar.bz2
9 # Source0-md5:  869f827d33e86bd912c006a85d3f9504
10 URL:            http://trac.enlightenment.org/e/wiki/EFL
11 BuildRequires:  autoconf >= 2.52
12 BuildRequires:  automake >= 1.6
13 BuildRequires:  crossmingw32-gcc
14 BuildRequires:  libtool >= 2:2.4
15 BuildRequires:  rpmbuild(macros) >= 1.197
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         no_install_post_strip   1
19
20 %define         target                  i386-mingw32
21 %define         target_platform         i386-pc-mingw32
22
23 %define         _sysprefix              /usr
24 %define         _prefix                 %{_sysprefix}/%{target}
25 %define         _libdir                 %{_prefix}/lib
26 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
27 %define         _dlldir                 /usr/share/wine/windows/system
28 %define         __cc                    %{target}-gcc
29 %define         __cxx                   %{target}-g++
30 %define         __pkgconfig_provides    %{nil}
31
32 %ifnarch %{ix86}
33 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
34 %define         optflags        -O2
35 %endif
36 # -z options are invalid for mingw linker, most of -f options are Linux-specific
37 %define         filterout_ld    -Wl,-z,.*
38 %define         filterout_c     -f[-a-z0-9=]*
39 %define         filterout_cxx   -f[-a-z0-9=]*
40
41 %description
42 The Evil library tried to port some convenient Unix functions to the
43 Windows (XP or CE) platform. They are used in the Enlightenment
44 Foundation Libraries (EFL).
45
46 This package contains the cross version for Win32.
47
48 %description -l pl.UTF-8
49 Biblioteka Evil jest próbą przeniesienia niektórych wygodnych funkcji
50 uniksowych na platformę Windows (XP lub CE). Jest wykorzystywana w
51 bibliotekach EFL (Enlightenment Foundation Libraries).
52
53 Ten pakiet zawiera wersję skrośną dla Win32.
54
55 %package static
56 Summary:        Static Evil libraries (cross MinGW32 version)
57 Summary(pl.UTF-8):      Statyczne biblioteki Evil (wersja skrośna MinGW32)
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60
61 %description static
62 Static Evil libraries (cross MinGW32 version).
63
64 %description static -l pl.UTF-8
65 Statyczne biblioteki Evil (wersja skrośna MinGW32).
66
67 %package dll
68 Summary:        DLL Evil libraries for Windows
69 Summary(pl.UTF-8):      Biblioteki DLL Evil dla Windows
70 Group:          Applications/Emulators
71 Requires:       wine
72
73 %description dll
74 DLL Evil libraries for Windows.
75
76 %description dll -l pl.UTF-8
77 Biblioteki DLL Evil dla Windows.
78
79 %prep
80 %setup -q -n evil-%{version}
81
82 %build
83 %{__libtoolize}
84 %{__aclocal} -I m4 -I m4/common -I m4/evil
85 %{__autoconf}
86 %{__autoheader}
87 %{__automake}
88 %configure \
89         --target=%{target} \
90         --host=%{target} \
91         --disable-silent-rules
92
93 %{__make} -j1
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} -j1 install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 install -d $RPM_BUILD_ROOT%{_dlldir}
102 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
103
104 %if 0%{!?debug:1}
105 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
106 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
107 %endif
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %files
113 %defattr(644,root,root,755)
114 %doc AUTHORS COPYING COPYING-PLAIN ChangeLog NEWS README
115 %{_libdir}/libdl.dll.a
116 %{_libdir}/libdl.la
117 %{_libdir}/libevil.dll.a
118 %{_libdir}/libevil.la
119 %{_includedir}/evil-1
120 %{_pkgconfigdir}/evil.pc
121
122 %files static
123 %defattr(644,root,root,755)
124 %{_libdir}/libdl.a
125 %{_libdir}/libevil.a
126
127 %files dll
128 %defattr(644,root,root,755)
129 %{_dlldir}/libdl-1.dll
130 %{_dlldir}/libevil-1.dll
This page took 0.076676 seconds and 4 git commands to generate.