]> git.pld-linux.org Git - packages/crossmingw32-evil.git/blob - crossmingw32-evil.spec
- Windows-specific part of EFL
[packages/crossmingw32-evil.git] / crossmingw32-evil.spec
1 Summary:        Evil - EFL Windows compatibility layer
2 Summary(pl.UTF-8):      Evil - Warstwa kompatybilności EFL z Windows
3 Name:           crossmingw32-evil
4 Version:        1.0.0
5 Release:        1
6 License:        Free (see COPYING)
7 Group:          Development/Libraries
8 Source0:        http://download.enlightenment.org/releases/evil-%{version}.tar.bz2
9 # Source0-md5:  4772bb5ee4f9d1287a31a4e922cc7b3f
10 URL:            http://trac.enlightenment.org/e/wiki/EFL
11 BuildRequires:  autoconf >= 2.52
12 BuildRequires:  automake >= 1.6
13 BuildRequires:  crossmingw32-gcc
14 BuildRequires:  libtool >= 2:2.4
15 BuildRequires:  rpmbuild(macros) >= 1.197
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         no_install_post_strip   1
19
20 %define         target                  i386-mingw32
21 %define         target_platform         i386-pc-mingw32
22
23 %define         _sysprefix              /usr
24 %define         _prefix                 %{_sysprefix}/%{target}
25 %define         _libdir                 %{_prefix}/lib
26 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
27 %define         _dlldir                 /usr/share/wine/windows/system
28 %define         __cc                    %{target}-gcc
29 %define         __cxx                   %{target}-g++
30
31 %ifnarch %{ix86}
32 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
33 %define         optflags        -O2
34 %endif
35 # -z options are invalid for mingw linker
36 %define         filterout_ld    -Wl,-z,.*
37
38 %description
39 The Evil library tried to port some convenient Unix functions to the
40 Windows (XP or CE) platform. They are used in the Enlightenment
41 Foundation Libraries (EFL).
42
43 This package contains the cross version for Win32.
44
45 %description -l pl.UTF-8
46 Biblioteka Evil jest próbą przeniesienia niektórych wygodnych funkcji
47 uniksowych na platformę Windows (XP lub CE). Jest wykorzystywana w
48 bibliotekach EFL (Enlightenment Foundation Libraries).
49
50 Ten pakiet zawiera wersję skrośną dla Win32.
51
52 %package static
53 Summary:        Static Evil libraries (cross MinGW32 version)
54 Summary(pl.UTF-8):      Statyczne biblioteki Evil (wersja skrośna MinGW32)
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57
58 %description static
59 Static Evil libraries (cross MinGW32 version).
60
61 %description static -l pl.UTF-8
62 Statyczne biblioteki Evil (wersja skrośna MinGW32).
63
64 %package dll
65 Summary:        DLL Evil libraries for Windows
66 Summary(pl.UTF-8):      Biblioteki DLL Evil dla Windows
67 Group:          Applications/Emulators
68 Requires:       wine
69
70 %description dll
71 DLL Evil libraries for Windows.
72
73 %description dll -l pl.UTF-8
74 Biblioteki DLL Evil dla Windows.
75
76 %prep
77 %setup -q -n evil-%{version}
78
79 %build
80 %{__libtoolize}
81 %{__aclocal} -I m4
82 %{__autoconf}
83 %{__autoheader}
84 %{__automake}
85 %configure \
86         --target=%{target} \
87         --host=%{target} \
88         --disable-silent-rules
89
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %{__make} -j1 install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 install -d $RPM_BUILD_ROOT%{_dlldir}
99 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
100
101 %if 0%{!?debug:1}
102 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
103 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
104 %endif
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %files
110 %defattr(644,root,root,755)
111 %doc AUTHORS COPYING COPYING-PLAIN ChangeLog NEWS README
112 %{_libdir}/libdl.dll.a
113 %{_libdir}/libdl.la
114 %{_libdir}/libevil.dll.a
115 %{_libdir}/libevil.la
116 %{_includedir}/evil-1
117 %{_pkgconfigdir}/evil.pc
118
119 %files static
120 %defattr(644,root,root,755)
121 %{_libdir}/libdl.a
122 %{_libdir}/libevil.a
123
124 %files dll
125 %defattr(644,root,root,755)
126 %{_dlldir}/libdl-1.dll
127 %{_dlldir}/libevil-1.dll
This page took 0.106966 seconds and 4 git commands to generate.