]> git.pld-linux.org Git - packages/crossmingw32-evil.git/blob - crossmingw32-evil.spec
do not require pkgconfig deps either
[packages/crossmingw32-evil.git] / crossmingw32-evil.spec
1 Summary:        Evil - EFL Windows compatibility layer
2 Summary(pl.UTF-8):      Evil - Warstwa kompatybilności EFL z Windows
3 Name:           crossmingw32-evil
4 Version:        1.7.6
5 Release:        3
6 License:        Free (see COPYING)
7 Group:          Development/Libraries
8 Source0:        http://download.enlightenment.org/releases/evil-%{version}.tar.bz2
9 # Source0-md5:  869f827d33e86bd912c006a85d3f9504
10 URL:            http://trac.enlightenment.org/e/wiki/EFL
11 BuildRequires:  autoconf >= 2.52
12 BuildRequires:  automake >= 1.6
13 BuildRequires:  crossmingw32-gcc
14 BuildRequires:  libtool >= 2:2.4
15 BuildRequires:  rpmbuild(macros) >= 1.197
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         no_install_post_strip   1
19
20 %define         target                  i386-mingw32
21 %define         target_platform         i386-pc-mingw32
22
23 %define         _sysprefix              /usr
24 %define         _prefix                 %{_sysprefix}/%{target}
25 %define         _libdir                 %{_prefix}/lib
26 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
27 %define         _dlldir                 /usr/share/wine/windows/system
28 %define         __cc                    %{target}-gcc
29 %define         __cxx                   %{target}-g++
30 %define         __pkgconfig_provides    %{nil}
31 %define         __pkgconfig_requires    %{nil}
32
33 %ifnarch %{ix86}
34 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
35 %define         optflags        -O2
36 %endif
37 # -z options are invalid for mingw linker, most of -f options are Linux-specific
38 %define         filterout_ld    -Wl,-z,.*
39 %define         filterout_c     -f[-a-z0-9=]*
40 %define         filterout_cxx   -f[-a-z0-9=]*
41
42 %description
43 The Evil library tried to port some convenient Unix functions to the
44 Windows (XP or CE) platform. They are used in the Enlightenment
45 Foundation Libraries (EFL).
46
47 This package contains the cross version for Win32.
48
49 %description -l pl.UTF-8
50 Biblioteka Evil jest próbą przeniesienia niektórych wygodnych funkcji
51 uniksowych na platformę Windows (XP lub CE). Jest wykorzystywana w
52 bibliotekach EFL (Enlightenment Foundation Libraries).
53
54 Ten pakiet zawiera wersję skrośną dla Win32.
55
56 %package static
57 Summary:        Static Evil libraries (cross MinGW32 version)
58 Summary(pl.UTF-8):      Statyczne biblioteki Evil (wersja skrośna MinGW32)
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61
62 %description static
63 Static Evil libraries (cross MinGW32 version).
64
65 %description static -l pl.UTF-8
66 Statyczne biblioteki Evil (wersja skrośna MinGW32).
67
68 %package dll
69 Summary:        DLL Evil libraries for Windows
70 Summary(pl.UTF-8):      Biblioteki DLL Evil dla Windows
71 Group:          Applications/Emulators
72 Requires:       wine
73
74 %description dll
75 DLL Evil libraries for Windows.
76
77 %description dll -l pl.UTF-8
78 Biblioteki DLL Evil dla Windows.
79
80 %prep
81 %setup -q -n evil-%{version}
82
83 %build
84 %{__libtoolize}
85 %{__aclocal} -I m4 -I m4/common -I m4/evil
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90         --target=%{target} \
91         --host=%{target} \
92         --disable-silent-rules
93
94 %{__make} -j1
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} -j1 install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 install -d $RPM_BUILD_ROOT%{_dlldir}
103 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
104
105 %if 0%{!?debug:1}
106 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
107 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
108 %endif
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %files
114 %defattr(644,root,root,755)
115 %doc AUTHORS COPYING COPYING-PLAIN ChangeLog NEWS README
116 %{_libdir}/libdl.dll.a
117 %{_libdir}/libdl.la
118 %{_libdir}/libevil.dll.a
119 %{_libdir}/libevil.la
120 %{_includedir}/evil-1
121 %{_pkgconfigdir}/evil.pc
122
123 %files static
124 %defattr(644,root,root,755)
125 %{_libdir}/libdl.a
126 %{_libdir}/libevil.a
127
128 %files dll
129 %defattr(644,root,root,755)
130 %{_dlldir}/libdl-1.dll
131 %{_dlldir}/libevil-1.dll
This page took 0.428711 seconds and 4 git commands to generate.