]> git.pld-linux.org Git - packages/crossmingw32-evil.git/blob - crossmingw32-evil.spec
- build seems racy, try -j1
[packages/crossmingw32-evil.git] / crossmingw32-evil.spec
1 Summary:        Evil - EFL Windows compatibility layer
2 Summary(pl.UTF-8):      Evil - Warstwa kompatybilności EFL z Windows
3 Name:           crossmingw32-evil
4 Version:        1.7.0
5 Release:        1
6 License:        Free (see COPYING)
7 Group:          Development/Libraries
8 Source0:        http://download.enlightenment.org/releases/evil-%{version}.tar.bz2
9 # Source0-md5:  bf3f25749657cf7171aa58debada3e13
10 URL:            http://trac.enlightenment.org/e/wiki/EFL
11 BuildRequires:  autoconf >= 2.52
12 BuildRequires:  automake >= 1.6
13 BuildRequires:  crossmingw32-gcc
14 BuildRequires:  libtool >= 2:2.4
15 BuildRequires:  rpmbuild(macros) >= 1.197
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         no_install_post_strip   1
19
20 %define         target                  i386-mingw32
21 %define         target_platform         i386-pc-mingw32
22
23 %define         _sysprefix              /usr
24 %define         _prefix                 %{_sysprefix}/%{target}
25 %define         _libdir                 %{_prefix}/lib
26 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
27 %define         _dlldir                 /usr/share/wine/windows/system
28 %define         __cc                    %{target}-gcc
29 %define         __cxx                   %{target}-g++
30
31 %ifnarch %{ix86}
32 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
33 %define         optflags        -O2
34 %endif
35 # -z options are invalid for mingw linker, most of -f options are Linux-specific
36 %define         filterout_ld    -Wl,-z,.*
37 %define         filterout_c     -f[-a-z0-9=]*
38
39 %description
40 The Evil library tried to port some convenient Unix functions to the
41 Windows (XP or CE) platform. They are used in the Enlightenment
42 Foundation Libraries (EFL).
43
44 This package contains the cross version for Win32.
45
46 %description -l pl.UTF-8
47 Biblioteka Evil jest próbą przeniesienia niektórych wygodnych funkcji
48 uniksowych na platformę Windows (XP lub CE). Jest wykorzystywana w
49 bibliotekach EFL (Enlightenment Foundation Libraries).
50
51 Ten pakiet zawiera wersję skrośną dla Win32.
52
53 %package static
54 Summary:        Static Evil libraries (cross MinGW32 version)
55 Summary(pl.UTF-8):      Statyczne biblioteki Evil (wersja skrośna MinGW32)
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58
59 %description static
60 Static Evil libraries (cross MinGW32 version).
61
62 %description static -l pl.UTF-8
63 Statyczne biblioteki Evil (wersja skrośna MinGW32).
64
65 %package dll
66 Summary:        DLL Evil libraries for Windows
67 Summary(pl.UTF-8):      Biblioteki DLL Evil dla Windows
68 Group:          Applications/Emulators
69 Requires:       wine
70
71 %description dll
72 DLL Evil libraries for Windows.
73
74 %description dll -l pl.UTF-8
75 Biblioteki DLL Evil dla Windows.
76
77 %prep
78 %setup -q -n evil-%{version}
79
80 %build
81 %{__libtoolize}
82 %{__aclocal} -I m4 -I m4/common -I m4/evil
83 %{__autoconf}
84 %{__autoheader}
85 %{__automake}
86 %configure \
87         --target=%{target} \
88         --host=%{target} \
89         --disable-silent-rules
90
91 %{__make} -j1
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} -j1 install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 install -d $RPM_BUILD_ROOT%{_dlldir}
100 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
101
102 %if 0%{!?debug:1}
103 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
104 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
105 %endif
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %files
111 %defattr(644,root,root,755)
112 %doc AUTHORS COPYING COPYING-PLAIN ChangeLog NEWS README
113 %{_libdir}/libdl.dll.a
114 %{_libdir}/libdl.la
115 %{_libdir}/libevil.dll.a
116 %{_libdir}/libevil.la
117 %{_includedir}/evil-1
118 %{_pkgconfigdir}/evil.pc
119
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/libdl.a
123 %{_libdir}/libevil.a
124
125 %files dll
126 %defattr(644,root,root,755)
127 %{_dlldir}/libdl-1.dll
128 %{_dlldir}/libevil-1.dll
This page took 0.412466 seconds and 3 git commands to generate.