]> git.pld-linux.org Git - packages/crossmingw32-evil.git/blob - crossmingw32-evil.spec
- updated to 1.7.6
[packages/crossmingw32-evil.git] / crossmingw32-evil.spec
1 Summary:        Evil - EFL Windows compatibility layer
2 Summary(pl.UTF-8):      Evil - Warstwa kompatybilności EFL z Windows
3 Name:           crossmingw32-evil
4 Version:        1.7.6
5 Release:        1
6 License:        Free (see COPYING)
7 Group:          Development/Libraries
8 Source0:        http://download.enlightenment.org/releases/evil-%{version}.tar.bz2
9 # Source0-md5:  869f827d33e86bd912c006a85d3f9504
10 URL:            http://trac.enlightenment.org/e/wiki/EFL
11 BuildRequires:  autoconf >= 2.52
12 BuildRequires:  automake >= 1.6
13 BuildRequires:  crossmingw32-gcc
14 BuildRequires:  libtool >= 2:2.4
15 BuildRequires:  rpmbuild(macros) >= 1.197
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         no_install_post_strip   1
19
20 %define         target                  i386-mingw32
21 %define         target_platform         i386-pc-mingw32
22
23 %define         _sysprefix              /usr
24 %define         _prefix                 %{_sysprefix}/%{target}
25 %define         _libdir                 %{_prefix}/lib
26 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
27 %define         _dlldir                 /usr/share/wine/windows/system
28 %define         __cc                    %{target}-gcc
29 %define         __cxx                   %{target}-g++
30
31 %ifnarch %{ix86}
32 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
33 %define         optflags        -O2
34 %endif
35 # -z options are invalid for mingw linker, most of -f options are Linux-specific
36 %define         filterout_ld    -Wl,-z,.*
37 %define         filterout_c     -f[-a-z0-9=]*
38 %define         filterout_cxx   -f[-a-z0-9=]*
39
40 %description
41 The Evil library tried to port some convenient Unix functions to the
42 Windows (XP or CE) platform. They are used in the Enlightenment
43 Foundation Libraries (EFL).
44
45 This package contains the cross version for Win32.
46
47 %description -l pl.UTF-8
48 Biblioteka Evil jest próbą przeniesienia niektórych wygodnych funkcji
49 uniksowych na platformę Windows (XP lub CE). Jest wykorzystywana w
50 bibliotekach EFL (Enlightenment Foundation Libraries).
51
52 Ten pakiet zawiera wersję skrośną dla Win32.
53
54 %package static
55 Summary:        Static Evil libraries (cross MinGW32 version)
56 Summary(pl.UTF-8):      Statyczne biblioteki Evil (wersja skrośna MinGW32)
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59
60 %description static
61 Static Evil libraries (cross MinGW32 version).
62
63 %description static -l pl.UTF-8
64 Statyczne biblioteki Evil (wersja skrośna MinGW32).
65
66 %package dll
67 Summary:        DLL Evil libraries for Windows
68 Summary(pl.UTF-8):      Biblioteki DLL Evil dla Windows
69 Group:          Applications/Emulators
70 Requires:       wine
71
72 %description dll
73 DLL Evil libraries for Windows.
74
75 %description dll -l pl.UTF-8
76 Biblioteki DLL Evil dla Windows.
77
78 %prep
79 %setup -q -n evil-%{version}
80
81 %build
82 %{__libtoolize}
83 %{__aclocal} -I m4 -I m4/common -I m4/evil
84 %{__autoconf}
85 %{__autoheader}
86 %{__automake}
87 %configure \
88         --target=%{target} \
89         --host=%{target} \
90         --disable-silent-rules
91
92 %{__make} -j1
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} -j1 install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 install -d $RPM_BUILD_ROOT%{_dlldir}
101 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
102
103 %if 0%{!?debug:1}
104 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
105 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
106 %endif
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files
112 %defattr(644,root,root,755)
113 %doc AUTHORS COPYING COPYING-PLAIN ChangeLog NEWS README
114 %{_libdir}/libdl.dll.a
115 %{_libdir}/libdl.la
116 %{_libdir}/libevil.dll.a
117 %{_libdir}/libevil.la
118 %{_includedir}/evil-1
119 %{_pkgconfigdir}/evil.pc
120
121 %files static
122 %defattr(644,root,root,755)
123 %{_libdir}/libdl.a
124 %{_libdir}/libevil.a
125
126 %files dll
127 %defattr(644,root,root,755)
128 %{_dlldir}/libdl-1.dll
129 %{_dlldir}/libevil-1.dll
This page took 0.146892 seconds and 3 git commands to generate.