]> git.pld-linux.org Git - packages/crossmingw32-cairomm.git/blob - crossmingw32-cairomm.spec
do not require pkgconfig deps either
[packages/crossmingw32-cairomm.git] / crossmingw32-cairomm.spec
1 Summary:        C++ wrapper for cairo - cross MinGW32 version
2 Summary(pl.UTF-8):      Interfejs C++ do cairo - wersja skrośna dla MinGW32
3 %define         realname   cairomm
4 Name:           crossmingw32-%{realname}
5 Version:        1.10.0
6 Release:        3
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        http://cairographics.org/releases/%{realname}-%{version}.tar.gz
10 # Source0-md5:  9c63fb1c04c8ecd3c5e6473075b8c39f
11 URL:            http://cairographics.org/
12 BuildRequires:  autoconf >= 2.62
13 BuildRequires:  automake >= 1:1.11
14 BuildRequires:  crossmingw32-cairo >= 1.10.0
15 BuildRequires:  crossmingw32-gcc-c++
16 BuildRequires:  crossmingw32-libsigc++ >= 2.0
17 BuildRequires:  libtool >= 2:1.5
18 BuildRequires:  mm-common >= 0.8
19 BuildRequires:  pkgconfig >= 1:0.15
20 Requires:       crossmingw32-cairo >= 1.10.0
21 Requires:       crossmingw32-libsigc++ >= 2.0
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         no_install_post_strip   1
25
26 %define         target                  i386-mingw32
27 %define         target_platform         i386-pc-mingw32
28
29 %define         _sysprefix              /usr
30 %define         _prefix                 %{_sysprefix}/%{target}
31 %define         _libdir                 %{_prefix}/lib
32 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
33 %define         _dlldir                 /usr/share/wine/windows/system
34 %define         __cc                    %{target}-gcc
35 %define         __cxx                   %{target}-g++
36 %define         __pkgconfig_provides    %{nil}
37 %define         __pkgconfig_requires    %{nil}
38
39 %ifnarch %{ix86}
40 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
41 %define         optflags        -O2
42 %endif
43 # -z options are invalid for mingw linker
44 %define         filterout_ld    -Wl,-z,.*
45
46 %description
47 C++ wrapper for cairo (cross MinGW32 version).
48
49 %description -l pl.UTF-8
50 Interfejs C++ do cairo (wersja skrośna MinGW32).
51
52 %package static
53 Summary:        Static cairomm library (cross MinGW32 version)
54 Summary(pl.UTF-8):      Statyczna biblioteka cairomm (wersja skrośna MinGW32)
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57
58 %description static
59 Static cairomm library (cross MinGW32 version).
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka cairomm (wersja skrośna MinGW32).
63
64 %package dll
65 Summary:        DLL cairomm library for Windows
66 Summary(pl.UTF-8):      Biblioteka DLL cairomm dla Windows
67 Group:          Applications/Emulators
68 Requires:       crossmingw32-cairo-dll >= 1.10.0
69 Requires:       crossmingw32-libsigc++-dll >= 2.0
70
71 %description dll
72 DLL cairomm library for Windows.
73
74 %description dll -l pl.UTF-8
75 Biblioteka DLL cairomm dla Windows.
76
77 %prep
78 %setup -q -n %{realname}-%{version}
79
80 %build
81 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
82 %{__libtoolize}
83 %{__aclocal} -I build
84 %{__automake}
85 %{__autoconf}
86 %configure \
87         --enable-static \
88         --target=%{target} \
89         --host=%{target}
90
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 install -d $RPM_BUILD_ROOT%{_dlldir}
100 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
101
102 %if 0%{!?debug:1}
103 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
104 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
105 %endif
106
107 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{doc/cairomm-1.0,devhelp}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %files
113 %defattr(644,root,root,755)
114 %doc AUTHORS ChangeLog MAINTAINERS NEWS README
115 %{_libdir}/libcairomm-1.0.dll.a
116 %{_libdir}/libcairomm-1.0.la
117 %{_libdir}/cairomm-1.0
118 %{_includedir}/cairomm-1.0
119 %{_pkgconfigdir}/cairomm-1.0.pc
120 %{_pkgconfigdir}/cairomm-ft-1.0.pc
121 %{_pkgconfigdir}/cairomm-pdf-1.0.pc
122 %{_pkgconfigdir}/cairomm-png-1.0.pc
123 %{_pkgconfigdir}/cairomm-ps-1.0.pc
124 %{_pkgconfigdir}/cairomm-svg-1.0.pc
125 %{_pkgconfigdir}/cairomm-win32-1.0.pc
126 %{_pkgconfigdir}/cairomm-win32-font-1.0.pc
127
128 %files static
129 %defattr(644,root,root,755)
130 %{_libdir}/libcairomm-1.0.a
131
132 %files dll
133 %defattr(644,root,root,755)
134 %{_dlldir}/libcairomm-1.0-*.dll
This page took 0.064158 seconds and 3 git commands to generate.