]> git.pld-linux.org Git - packages/crossmingw32-cairo.git/blob - crossmingw32-cairo.spec
- updated to 1.4.14
[packages/crossmingw32-cairo.git] / crossmingw32-cairo.spec
1 #
2 # Conditional build:
3 %bcond_with     glitz           # build with glitz backend
4 #
5 Summary:        Cairo - multi-platform 2D graphics library - cross Mingw32 version
6 Summary(pl.UTF-8):      Cairo - wieloplatformowa biblioteka graficzna 2D - skrośna wersja Mingw32
7 %define         realname   cairo
8 Name:           crossmingw32-%{realname}
9 Version:        1.4.14
10 Release:        1
11 License:        LGPL v2.1 or MPL 1.1
12 Group:          Development/Libraries
13 Source0:        http://cairographics.org/releases/%{realname}-%{version}.tar.gz
14 # Source0-md5:  e8c442ff821c0719a69508fecba9038f
15 URL:            http://cairographics.org/
16 BuildRequires:  autoconf >= 2.54
17 BuildRequires:  automake >= 1:1.7
18 BuildRequires:  crossmingw32-fontconfig
19 BuildRequires:  crossmingw32-freetype >= 2.1.10
20 %{?with_glitz:BuildRequires:    crossmingw32-glitz >= 0.5.1}
21 BuildRequires:  crossmingw32-libpng
22 BuildRequires:  crossmingw32-zlib
23 BuildRequires:  libtool
24 BuildRequires:  pkgconfig >= 1:0.15
25 Requires:       crossmingw32-fontconfig
26 Requires:       crossmingw32-freetype >= 2.1.10
27 %{?with_glitz:Requires: crossmingw32-glitz >= 0.5.1}
28 Requires:       crossmingw32-libpng
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         no_install_post_strip   1
32
33 %define         target                  i386-mingw32
34 %define         target_platform         i386-pc-mingw32
35
36 %define         _sysprefix              /usr
37 %define         _prefix                 %{_sysprefix}/%{target}
38 %define         _libdir                 %{_prefix}/lib
39 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
40 %define         _dlldir                 /usr/share/wine/windows/system
41 %define         __cc                    %{target}-gcc
42 %define         __cxx                   %{target}-g++
43
44 %description
45 Cairo provides anti-aliased vector-based rendering for X. Paths
46 consist of line segments and cubic splines and can be rendered at any
47 width with various join and cap styles. All colors may be specified
48 with optional translucence (opacity/alpha) and combined using the
49 extended Porter/Duff compositing algebra as found in the X Render
50 Extension.
51
52 Cairo exports a stateful rendering API similar in spirit to the path
53 construction, text, and painting operators of PostScript, (with the
54 significant addition of translucence in the imaging model). When
55 complete, the API is intended to support the complete imaging model of
56 PDF 1.4.
57
58 This package contains the cross version for Win32.
59
60 %description -l pl.UTF-8
61 Cairo obsługuje oparty na wektorach rendering z antyaliasingiem dla X.
62 Ścieżki składają się z odcinków i splajnów kubicznych, a renderowane
63 mogą być z dowolną grubością i różnymi stylami połączeń i zakończeń.
64 Wszystkie kolory mogą być podane z opcjonalną półprzezroczystością
65 (podaną przez współczynnik nieprzezroczystości lub alpha) i łączone
66 przy użyciu rozszerzonego algorytmu mieszania Portera-Duffa, który
67 można znaleźć w rozszerzeniu X Render.
68
69 Cairo eksportuje stanowe API renderujące w duchu podobne do operatorów
70 konstruowania ścieżek, tekstu i rysowania z PostScriptu (ze znacznym
71 dodatkiem półprzezroczystości w modelu obrazu). Kiedy API zostanie
72 ukończone, ma obsługiwać pełny model obrazu z PDF w wersji 1.4.
73
74 Ten pakiet zawiera wersję skrośną dla Win32.
75
76 %package static
77 Summary:        Static cairo library (cross mingw32 version)
78 Summary(pl.UTF-8):      Statyczna biblioteka cairo (wersja skrośna mingw32)
79 Group:          Development/Libraries
80 Requires:       %{name} = %{version}-%{release}
81
82 %description static
83 Static cairo library (cross mingw32 version).
84
85 %description static -l pl.UTF-8
86 Statyczna biblioteka cairo (wersja skrośna mingw32).
87
88 %package dll
89 Summary:        DLL cairo library for Windows
90 Summary(pl.UTF-8):      Biblioteka DLL cairo dla Windows
91 Group:          Applications/Emulators
92 Requires:       crossmingw32-fontconfig-dll
93 Requires:       crossmingw32-freetype-dll >= 2.1.10
94 %{?with_glitz:Requires: crossmingw32-glitz-dll >= 0.5.1}
95 Requires:       crossmingw32-libpng-dll
96
97 %description dll
98 DLL cairo library for Windows.
99
100 %description dll -l pl.UTF-8
101 Biblioteka DLL cairo dla Windows.
102
103 %prep
104 %setup -q -n %{realname}-%{version}
105
106 %build
107 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
108 %{__libtoolize}
109 %{__aclocal}
110 %{__autoheader}
111 %{__autoconf}
112 %{__automake}
113 %configure \
114         lt_cv_deplibs_check_method=pass_all \
115         --target=%{target} \
116         --host=%{target} \
117         --disable-gtk-doc \
118         --disable-xlib \
119         --disable-xlib-render \
120         --enable-freetype \
121         %{?with_glitz:--enable-glitz} \
122         --enable-pdf \
123         --enable-png \
124         --enable-ps \
125         --enable-svg \
126         --enable-windows
127
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 install -d $RPM_BUILD_ROOT%{_dlldir}
137 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
138
139 %if 0%{!?debug:1}
140 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
141 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
142 %endif
143
144 rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %files
150 %defattr(644,root,root,755)
151 # COPYING contains only notes, not LGPL/MPL texts
152 %doc AUTHORS COPYING ChangeLog NEWS README TODO
153 %{_libdir}/libcairo.dll.a
154 %{_libdir}/libcairo.la
155 %{_includedir}/cairo
156 %{_pkgconfigdir}/cairo.pc
157 %{_pkgconfigdir}/cairo-ft.pc
158 %{_pkgconfigdir}/cairo-pdf.pc
159 %{_pkgconfigdir}/cairo-png.pc
160 %{_pkgconfigdir}/cairo-ps.pc
161 %{_pkgconfigdir}/cairo-svg.pc
162 %{_pkgconfigdir}/cairo-win32.pc
163
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/libcairo.a
167
168 %files dll
169 %defattr(644,root,root,755)
170 %{_dlldir}/libcairo-*.dll
This page took 0.068025 seconds and 3 git commands to generate.